This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 434685 - Adobe Reader breaks PDF displaying in Kpdf
Adobe Reader breaks PDF displaying in Kpdf
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showpos...
:
: 435079 470607 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-24 06:10 EST by Mostafa Afgani
Modified: 2008-11-10 13:16 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 10:22:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of kpdf (26.97 KB, image/png)
2008-02-24 06:10 EST, Mostafa Afgani
no flags Details
Strace output (765.58 KB, text/plain)
2008-02-24 06:11 EST, Mostafa Afgani
no flags Details
kpdf crashes while opening this file (194.82 KB, application/pdf)
2008-03-23 14:34 EDT, Paul Smith
no flags Details
/usr/share/mimelnk/application/pdf.desktop from RHEL 5.2 (2.24 KB, text/plain)
2008-11-03 11:53 EST, Aleksey Nogin
no flags Details

  None (edit)
Description Mostafa Afgani 2008-02-24 06:10:03 EST
Description of problem:
kpdf is unable to display pdf files.

Version-Release number of selected component (if applicable):
3.5.8-7.fc8

How reproducible:
Always

Steps to Reproduce:
1. Open any pdf file with kpdf
2.
3.
  
Actual results:
kpdf says "Loaded a one-page document" and displays a tiny square regardless of
the actual file.

Expected results:
kpdf opens the pdf file normally.

Additional info:
The problem appears to be system-wide. Not quite sure exactly when the problem
showed up. I'm attaching screenshots and a strace output.
Comment 1 Mostafa Afgani 2008-02-24 06:10:03 EST
Created attachment 295737 [details]
Screenshot of kpdf
Comment 2 Mostafa Afgani 2008-02-24 06:11:26 EST
Created attachment 295738 [details]
Strace output
Comment 3 Andris Pavenis 2008-02-24 09:02:46 EST
Got the same problem for x86_64. Attempt to rebuild kdegraphics 
from SRPM(kdegraphics-3.5.8-7.fc8.src.rpm) failed due to unresolved
references (sane_*).

Binary RPMs from updates-testing (3.5.9-1) seem however to fix the
problem with displaying PDF. I tested only on x86_64.
Comment 4 Mostafa Afgani 2008-02-24 10:27:50 EST
Strangely enough, I have a x86_64 machine running the very same package without
any problems.

Thanks for pointing out the updated packages in testing. The update does indeed
solve the problem.
Comment 5 Miles Sabin 2008-02-24 10:57:54 EST
I'm also seeing this on F7 with kdegraphics-3.5.8-7.fc7.
Comment 6 Kevin Kofler 2008-02-24 13:06:35 EST
All the reports I'm aware of are with KPDF running in a GNOME session (and the 
window decoration in this screenshot looks a lot like nodoka-metacity-theme to 
me ;-) ), so I'm adding that to the subject.

I'm setting this to ON_QA given the reports that this is fixed in KDE 3.5.9 in 
updates-testing (comment #3).
Comment 7 Miles Sabin 2008-02-24 13:18:46 EST
I'm seeing it in a KDE session, and this wasn't fixed for my by the update in
updates-testing for F7.
Comment 8 Kevin Kofler 2008-02-24 13:21:30 EST
Then let's drop the "in GNOME session" from the subject.
The issue might be different though.
Comment 9 Rex Dieter 2008-02-27 08:01:25 EST
*** Bug 435079 has been marked as a duplicate of this bug. ***
Comment 10 Rex Dieter 2008-02-27 08:13:52 EST
Can anyone attach a smallish pdf file that demonstrates this problem?  (So far,
I've been unable to reproduce this).
Comment 11 Rex Dieter 2008-02-27 08:22:01 EST
Anyone seeing this *not* have Adobe acrobat installed? :)

I ask because it seems to induce this problem:
http://forum.fedoraforum.org/forum/showthread.php?t=175215&page=1&pp=15
in particular,
http://forum.fedoraforum.org/forum/showpost.php?p=963682&postcount=13
when someone noted that upgrading from 8.1.1 to 8.1.2 broke mime associations
horribly.

Fwiw, I just installed 8.1.2 clean (no upgrade), and all seems well here.
Comment 12 Mostafa Afgani 2008-02-27 08:42:37 EST
I did have Adobe Reader installed when the problem cropped up.
Comment 13 Kevin Kofler 2008-02-29 15:39:28 EST
So, anyone seeing this without having the proprietary Adobe Reader (acroread) 
installed? If not, we will have to assume this bug is caused by the 
aforementioned acroread bug, and thus be forced to mark this as CANTFIX, as we 
have no way to fix bugs in Adobe's packages.
Comment 14 J.Jansen 2008-03-03 05:22:40 EST
Probably I found a "work-around" by performing the following steps:
 1) remove both kdegraphics, kdegrahics-libs and the adobe-reader
 2) install kdegraphics, kdegrahic-libs
 3) install adobe-reader
I got kpdf working again. note that steps 1&2 alone are not sufficient. Also
performing the steps in any other order may not work (i.e. only removing and
reinstalling adobe did not work for me)

              Jouk
Comment 15 Rex Dieter 2008-03-22 12:27:12 EDT
*** Bug 438589 has been marked as a duplicate of this bug. ***
Comment 16 Paul Smith 2008-03-23 14:34:56 EDT
Created attachment 298868 [details]
kpdf crashes while opening this file
Comment 17 Paul Smith 2008-03-23 14:38:13 EDT
Kpdf crashes while opening the file that I have just attached (dn.pdf).
Notwithstanding, kpdf can open other pdf files. Moreover, Adobe Reader is not
anymore installed on my computer. Can you open the attached pdf file?
Comment 18 Rex Dieter 2008-03-23 15:14:03 EDT
Paul, see bug #437965 (for which an update is pending).
Comment 19 Aleksey Nogin 2008-09-10 15:52:23 EDT
I am seeing this bug in CentOS 5.2 with AdobeReader_enu-8.1.2_SU1-1.i486.rpm installed. Removing/reinstalling kdegraphics did not help :-(
Comment 20 Rex Dieter 2008-09-10 16:01:44 EDT
From what I can tell from testing @ work, AdobeReader_enu-8.1.2_SU1-1.i486.rpm is completely broken.  Complain to adobe.
Comment 21 Aleksey Nogin 2008-09-10 17:55:21 EDT
Thanks, Rex, I just posted a complaint at http://www.adobeforums.com/webx/.59b6732c . In the meantime, is there some workaround to get kpdf working again? TIA!
Comment 22 Ian Collier 2008-11-03 07:16:04 EST
For anyone who comes across this bug looking for a solution, it appears
that the crucial file is /usr/share/mimelnk/application/pdf.desktop .
This file is provided by the kdelibs package on F7 and F8 (kdelibs3 on F9
but that's moot since kpdf doesn't exist there).  If you find it missing,
don't reinstall AdobeReader or kdegraphics; just either reinstall kdelibs or
find a copy of that file from somewhere else.
Comment 23 Aleksey Nogin 2008-11-03 11:53:12 EST
Created attachment 322339 [details]
/usr/share/mimelnk/application/pdf.desktop from RHEL 5.2

Ian, thanks so much! Your fix in comment #22 worked for me under CentOS 5. 

Just in case somebody has trouble locating the proper pdf.desktop from RHEL/CentOS 5, the file is attached.
Comment 24 Orion Poplawski 2008-11-10 13:09:26 EST
*** Bug 470607 has been marked as a duplicate of this bug. ***
Comment 25 Rex Dieter 2008-11-10 13:16:00 EST
comment #22 confirmed.

At least with version 4.1.3 of AdobeReader, said file is at least valid.  Adobe still shouldn't be doing that.  Anyone file bug, issue a complaint, or yell at adobe yet?  (if not, I will soonish).

Note You need to log in before you can comment on or make changes to this bug.