Bug 438969 - Fedora 9 Beta corrupted display
Fedora 9 Beta corrupted display
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
http://nicubunu.ro/pictures/f9beta/
:
: 439104 439132 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 05:49 EDT by Nicu Buculei
Modified: 2013-02-01 09:45 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 15:53:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of the issue (943.93 KB, image/png)
2008-03-26 06:32 EDT, Matěj Cepl
no flags Details
example of the issue (755.31 KB, image/png)
2008-03-26 06:33 EDT, Matěj Cepl
no flags Details
example of the issue (157.14 KB, image/png)
2008-03-26 06:33 EDT, Matěj Cepl
no flags Details
as requested, xorg.cong (395 bytes, application/octet-stream)
2008-03-26 07:05 EDT, Nicu Buculei
no flags Details
as requested, Xorg.0.log (26.21 KB, text/plain)
2008-03-26 07:06 EDT, Nicu Buculei
no flags Details

  None (edit)
Description Nicu Buculei 2008-03-26 05:49:23 EDT
Description of problem:
With the released Beta of the Fedora 9 the display is corrupted (both in
Anaconda when booting from the install DVD and from the Live CD in RHGB, GDM and
the desktop): no text, no icons, no widgets (buttons).
This happens when booting from the real media, running the images with qemu is fine.

Version-Release number of selected component (if applicable):
Fedora 9 Beta

How reproducible:
Always

Steps to Reproduce:
1. Boot from the F9 Beta Live CD
  
Actual results:
xorg is unusable.

Expected results:
Usable desktop or Anaconda.

Additional info:
Screenshots of how the desktop looks like (Anaconda is exactly the same):
http://nicubunu.ro/pictures/f9beta/
Comment 1 Nicu Buculei 2008-03-26 05:52:09 EDT
Sorry, forgot to mention: this is using Intel on-board graphics (82G965)
Comment 2 Matěj Cepl 2008-03-26 06:31:30 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Matěj Cepl 2008-03-26 06:32:39 EDT
Created attachment 299123 [details]
example of the issue
Comment 4 Matěj Cepl 2008-03-26 06:33:30 EDT
Created attachment 299124 [details]
example of the issue
Comment 5 Matěj Cepl 2008-03-26 06:33:57 EDT
Created attachment 299125 [details]
example of the issue
Comment 6 Nicu Buculei 2008-03-26 07:05:46 EDT
Created attachment 299129 [details]
as requested, xorg.cong

This is the default xorg.conf file, as booted from Live CD
Comment 7 Nicu Buculei 2008-03-26 07:06:23 EDT
Created attachment 299130 [details]
as requested, Xorg.0.log

the only Xorg.*.log file
Comment 8 Nicu Buculei 2008-03-26 07:09:29 EDT
Attached the requested logs.

I can't run without /etc/X11/xorg.conf, as the issue appears when running from
the Live CD and the install media (F9 Beta install DVD), this is not possible.
Comment 9 Nicu Buculei 2008-03-26 10:39:24 EDT
It seems to be the same as #437910, #438952 and #436746.
Comment 10 Peter Gordon 2008-03-26 11:58:28 EDT
I'm seeing similar corruption during the install phase with Anaconda, using
on-board G965 ("GMA X3000") graphics with my Core 2 Duo setup (running x86_64).
Text-mode seems to work fine, though.

I will try forcing the Vesa driver.
Comment 11 petrosyan 2008-03-27 11:16:55 EDT
*** Bug 439132 has been marked as a duplicate of this bug. ***
Comment 12 petrosyan 2008-03-27 11:17:12 EDT
*** Bug 439104 has been marked as a duplicate of this bug. ***
Comment 13 Peter Gordon 2008-03-27 13:45:59 EDT
The vesa driver worked nicely for the install (though it did look a bit
stretched at 1280x01024 on my widescreen LCD, but that's to be expected); and
after installation switching back to the intel driver worked at least as well as
it did in F8. 
Comment 14 Austin Acton 2008-03-31 21:17:44 EDT
I have the same problem, with an all-Intel laptop, including X3100 video.

I tried booting the live CD (on usb stick) with xdriver=vesa, but I still
encountered the missing font problem.
Comment 15 Klaasjan Brand 2008-04-01 02:54:20 EDT
Seems to be fixed in the latest rawhide livecd. It's working as expected now on
my system.
Comment 16 Nicu Buculei 2008-04-01 03:48:50 EDT
Confirmed, forks for me with the 20080328 Rawhide snapshot Lice CD. HAve not
tested yet for Anaconda.
Comment 17 Bill Nottingham 2008-04-08 01:32:32 EDT
Are you certain the 0328 livecd is still using the intel driver?
Comment 18 Nicu Buculei 2008-04-08 08:52:33 EDT
The 20080404 Rawhide snapshot Live CD works correctly and is using the "intel"
driver.
Comment 19 Bill Nottingham 2008-04-08 11:38:16 EDT
Oh, livecd, not anaconda. Disregard my comment.
Comment 20 Adam Jackson 2008-04-11 15:53:21 EDT
Marking fixed per comment #18

Note You need to log in before you can comment on or make changes to this bug.