Bug 439115 - PackageKit displays the error "No package cache is available" on first use
PackageKit displays the error "No package cache is available" on first use
Status: CLOSED DUPLICATE of bug 439735
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: 440689 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-03-26 22:31 EDT by Basil Mohamed Gohar
Modified: 2008-04-15 17:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-15 17:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Basil Mohamed Gohar 2008-03-26 22:31:29 EDT
On a fresh install of Fedora 9 Beta x86_64, when first using the Add/Remove
Software component of System -> Administration, PackageKit displays the error
"No package cache is available" and "yum cache is invalid and has been rebuilt"
when attempting to view groups.  However, the yum cache does not appear to be

A Google search of the error message lead me to this:


Running the command 'pkcon refresh' did appear to fix the problem.
Comment 1 Richard Hughes 2008-03-31 10:02:09 EDT
Robin, we are currently doing:

self.error(ERROR_NO_CACHE,"Yum cache was invalid and has been rebuilt.")

If we got the cache, can't we just requeue the request in the backend?
ERROR_NO_CACHE is designed for when we have no cache and can't get any.

Ideally, the cache should be refreshed, and then the method should continue.
Comment 2 Robin Norwood 2008-04-07 12:05:46 EDT

Yes, I think you're correct.  I'll need to look at it a bit.

If we do 'start over', at which point should we start over?  Is it alright for
us to resend signals like these:


Comment 3 Richard Hughes 2008-04-13 12:47:14 EDT
Yup. :-) I followed up in my email with other stuff we need to do.
Comment 4 Richard Hughes 2008-04-15 17:06:09 EDT
*** Bug 440689 has been marked as a duplicate of this bug. ***
Comment 5 Richard Hughes 2008-04-15 17:08:07 EDT

*** This bug has been marked as a duplicate of 439735 ***

Note You need to log in before you can comment on or make changes to this bug.