Bug 440031 - icons in tray change to few squares
icons in tray change to few squares
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 449183 450307 (view as bug list)
Depends On: 450287 450292
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 10:00 EDT by Marcela Mašláňová
Modified: 2008-09-10 03:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 03:19:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
squarish icon (41.49 KB, image/png)
2008-04-01 10:04 EDT, Marcela Mašláňová
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 155381 None None None Never

  None (edit)
Description Marcela Mašláňová 2008-04-01 10:00:21 EDT
Description of problem:
Some icons in tray mutate into squarish icon. I suppose they come from
programme, which has been switched off before.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.0.3-5.fc9.i386

How reproducible:
Turn on some programmes like PackageKit, setroubleshooter. The icon aren't
remove after closing the programme.

Steps to Reproduce:
1. run something which create icon in tray
2. close programme
3. see the ugly thing in tray
  
Actual results:
Squarish icons are in tray.

Expected results:
Nothing or correct icon is in a tray.
Comment 1 Marcela Mašláňová 2008-04-01 10:04:27 EDT
Created attachment 299896 [details]
squarish icon

squarish icon
Comment 2 Rex Dieter 2008-04-01 10:09:49 EDT
let me guess, gtk-based applets?  :)
Comment 3 Rex Dieter 2008-04-01 10:10:50 EDT
Likely a dup of http://bugs.kde.org/155381
Comment 4 Marcela Mašláňová 2008-04-03 05:31:22 EDT
I saw it only with setroubleshooter and PackageKit. It must be the gtk :(
Comment 5 Steven M. Parrish 2008-04-09 12:59:53 EDT
Looks like an upstream issue. May want to change to RESOLVED UPSTREAM
Comment 6 Bug Zapper 2008-05-14 04:31:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Rex Dieter 2008-06-06 09:57:32 EDT
OK, confirmed in upstream report
http://bugs.kde.org/155381
this is almost always the app's fault for misrendering systray icons (mis-sized
usually) 

So, task now is to ID the misbehaving apps and file bugs against them appropriately.

I'll go do pidgin, setroubleshooter.
Comment 8 Kevin Kofler 2008-06-06 10:08:08 EDT
I've also seen this happening with nm-applet (NetworkManager-gnome) and 
gnome-packagekit. Usually these appear correctly because sometimes when other 
applets are added afterwards, things get normal, but they all start out with 
the wrong size. So are there _any_ GTK+ applets which are _not_ affected? I 
think this is probably a GTK+ bug, not an application bug.
Comment 9 Rex Dieter 2008-06-06 10:14:25 EDT
pidgin: bug #450287
gnome-packagekit: bug #450292
Comment 10 Rex Dieter 2008-06-06 10:15:00 EDT
nm-applet works fine here (which for me is the lone exception).
Comment 11 Rex Dieter 2008-06-06 10:16:15 EDT
fwiw, if anyone can reproduce the xwininfo/xprop debugging steps to help
identify any other misbahaving apps, by all means, file more bugs. :)
Comment 12 Rex Dieter 2008-06-06 10:27:23 EDT
More details wrt nm-applet: looks correct here, and diagnostics yield size=22x22
(as it should be)
Comment 13 Kevin Kofler 2008-06-06 10:51:10 EDT
OK, so why does nm-applet do the right thing and not all the others?
Comment 14 Rex Dieter 2008-06-06 11:27:08 EDT
I'd venture to guess at one of the following:
1.  it's coded to accomodate different icon sizes
2.  it includes icons are different sizes

In the end though, I'll trust Lubos' word on it that "the systray spec says apps
are to cope with whatever size they get."  which means ultimately it's the
*apps'* problem, not ours.
Comment 15 Rex Dieter 2008-06-06 11:44:51 EDT
setroubleshoot (sealart): bug #450307
Comment 16 Richard Hughes 2008-06-06 12:03:20 EDT
gnome-packagekit (and I assume most GTK software) just uses GtkStatusIcon to see
an icon name - and then leaves it up to GTK and the tray to set the correct
thing. I really don't think it's going to be a per-application problem.
Comment 17 Rex Dieter 2008-06-06 12:54:20 EDT
Here's some interesting info (though maybe not entirely relevant):

nm-applet's icon = nm-device-wireless , available in gnome, Tango themes many
sizes, hicolor,Echo only 48x48
setroubleshoot's icon = setroubleshoot_icon, avail in hicolor 96x96 only
gpk-update-icon = system-software-update , avail in many themes (including
gnome, oxygen, Tango, Echo), many sizes

Comment 18 Kevin Kofler 2008-06-06 21:44:45 EDT
The code of find_icon_size in gtkstatusicon.c is interesting:
http://svn.gnome.org/viewvc/gtk+/trunk/gtk/gtkstatusicon.c?revision=20304&view=markup

The problem is probably somewhere around there in the callgraph.
Comment 19 Christopher Stone 2008-06-07 12:45:08 EDT
(In reply to comment #7)
> OK, confirmed in upstream report
> http://bugs.kde.org/155381
> this is almost always the app's fault for misrendering systray icons (mis-sized
> usually) 
> 
> So, task now is to ID the misbehaving apps and file bugs against them
appropriately.
> 
> I'll go do pidgin, setroubleshooter.

Can we try a test build with this patch:
http://bugs.kde.org/attachment.cgi?id=25181&action=view
Comment 20 Lukáš Tinkl 2008-06-07 14:27:17 EDT
I'll test that patch locally first
Comment 21 Rex Dieter 2008-06-15 17:38:11 EDT
*** Bug 450307 has been marked as a duplicate of this bug. ***
Comment 22 Rex Dieter 2008-06-15 17:40:31 EDT
*** Bug 449183 has been marked as a duplicate of this bug. ***
Comment 23 Rex Dieter 2008-07-10 22:09:13 EDT
Confirmed good in kdebase-workspace-4.0.95-2 and newer (currently in rawhide).
Comment 24 Marcela Mašláňová 2008-07-11 02:33:25 EDT
The icons are working for me in kdebase-workspace-4.0.5-3.fc9.i386. I'm using
still the same programmes.
Comment 25 Kevin Kofler 2008-07-11 03:13:59 EDT
4.0.5-3 doesn't have any of the fixes, only 4.1 snapshots (versions >= 4.0.70) 
have them, and only >= 4.0.95-2 are completely fixed.
Comment 26 Fedora Update System 2008-07-30 16:07:13 EDT
kdeutils-4.1.0-1.fc9.1, kdeedu-4.1.0-1.fc9, qgtkstyle-0.0-0.2.20080719svn693.fc9, PyQt4-4.4.2-2.fc9, automoc-1.0-0.8.rc1.fc9, phonon-4.2.0-2.fc9, kdegraphics-4.1.0-3.fc9, kdelibs-4.1.0-2.fc9, kdebase-runtime-4.1.0-1.fc9, akonadi-1.0.0-1.fc9, kdepimlibs-4.1.0-1.fc9, kdesdk-4.1.0-1.fc9, kde-filesystem-4-17.fc9, kde-l10n-4.1.0-2.fc9, kdebase-workspace-4.1.0-3.fc9, kdemultimedia-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdeaccessibility-4.1.0-1.fc9, kdegames-4.1.0-1.fc9, kdeplasma-addons-4.1.0-1.fc9, qscintilla-2.2-3.fc9, compiz-0.7.6-3.fc9.1, qt-4.4.0-16.fc9, kdebindings-4.1.0-5.fc9, kdeartwork-4.1.0-1.fc9, kde-i18n-3.5.9-8.fc9, kdeadmin-4.1.0-2.fc9, kdebase-4.1.0-1.fc9.1, soprano-2.1-1.fc9, sip-4.7.6-1.fc9, kdenetwork-4.1.0-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdeedu qgtkstyle PyQt4 automoc phonon kdegraphics kdelibs kdebase-runtime akonadi kdepimlibs kdesdk kde-filesystem kde-l10n kdebase-workspace kdemultimedia kdetoys kdeaccessibility kdegames kdeplasma-addons qscintilla compiz qt kdebindings kdeartwork kde-i18n kdeadmin kdebase soprano sip kdenetwork'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6743
Comment 27 Fedora Update System 2008-08-07 19:48:58 EDT
kdebase-runtime-4.1.0-1.fc9, kdeaccessibility-4.1.0-1.fc9, kdegames-4.1.0-1.fc9, kdeplasma-addons-4.1.0-1.fc9, kdebase-workspace-4.1.0-8.fc9, kdebase-4.1.0-1.fc9.1, qgtkstyle-0.0-0.2.20080719svn693.fc9, qt-4.4.0-17.fc9, kdeutils-4.1.0-1.fc9.1, qscintilla-2.2-3.fc9, kdegraphics-4.1.0-3.fc9, kde-i18n-3.5.9-8.fc9, kdeartwork-4.1.0-1.fc9, kdeedu-4.1.0-1.fc9, compiz-0.7.6-3.fc9.1, PyQt4-4.4.2-2.fc9, automoc-1.0-0.8.rc1.fc9, phonon-4.2.0-2.fc9, akonadi-1.0.0-2.fc9, kdenetwork-4.1.0-2.fc9, quarticurve-kwin-theme-0.0-0.5.beta4.fc9, sip-4.7.6-1.fc9, kdepimlibs-4.1.0-2.fc9, kdelibs-4.1.0-4.fc9, kdebindings-4.1.0-5.fc9, kdesdk-4.1.0-1.fc9, kde-filesystem-4-17.fc9, soprano-2.1-1.fc9, kde-l10n-4.1.0-2.fc9, kdemultimedia-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdeadmin-4.1.0-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase-runtime kdeaccessibility kdegames kdeplasma-addons kdebase-workspace kdebase qgtkstyle qt kdeutils qscintilla kdegraphics kde-i18n kdeartwork kdeedu compiz PyQt4 automoc phonon akonadi kdenetwork quarticurve-kwin-theme sip kdepimlibs kdelibs kdebindings kdesdk kde-filesystem soprano kde-l10n kdemultimedia kdetoys kdeadmin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6743
Comment 28 Christopher Stone 2008-08-10 14:15:01 EDT
The klipper icon looks like a big white block with this update.
Comment 29 Fedora Update System 2008-08-12 14:18:56 EDT
kdelibs-4.1.0-5.fc9, kdeedu-4.1.0-1.fc9, quarticurve-kwin-theme-0.0-0.5.beta4.fc9, kdeartwork-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdesdk-4.1.0-1.fc9, PyQt4-4.4.2-2.fc9, kde-i18n-3.5.9-8.fc9, kdebase-4.1.0-1.fc9.1, sip-4.7.6-1.fc9, phonon-4.2.0-2.fc9, kdebase-workspace-4.1.0-8.fc9, automoc-1.0-0.8.rc1.fc9, kdegames-4.1.0-2.fc9, akonadi-1.0.0-2.fc9, soprano-2.1-1.fc9, konq-plugins-4.1.0-2.fc9, compiz-0.7.6-3.fc9.1, qt-4.4.1-2.fc9, qscintilla-2.2-3.fc9, kdepimlibs-4.1.0-2.fc9, kdegraphics-4.1.0-3.fc9, kdebindings-4.1.0-5.fc9, kdenetwork-4.1.0-2.fc9, kde-l10n-4.1.0-2.fc9, kdeplasma-addons-4.1.0-1.fc9, qgtkstyle-0.0-0.2.20080719svn693.fc9, kdeutils-4.1.0-1.fc9.1, kdemultimedia-4.1.0-1.fc9, kdebase-runtime-4.1.0-1.fc9, kdeadmin-4.1.0-2.fc9, kde-filesystem-4-17.fc9, kdeaccessibility-4.1.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs kdeedu quarticurve-kwin-theme kdeartwork kdetoys kdesdk PyQt4 kde-i18n kdebase sip phonon kdebase-workspace automoc kdegames akonadi soprano konq-plugins compiz qt qscintilla kdepimlibs kdegraphics kdebindings kdenetwork kde-l10n kdeplasma-addons qgtkstyle kdeutils kdemultimedia kdebase-runtime kdeadmin kde-filesystem kdeaccessibility'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6743
Comment 30 Fedora Update System 2008-09-10 03:18:53 EDT
kdeedu-4.1.0-1.fc9, quarticurve-kwin-theme-0.0-0.5.beta4.fc9, kdeartwork-4.1.0-1.fc9, kdetoys-4.1.0-1.fc9, kdesdk-4.1.0-1.fc9, PyQt4-4.4.2-2.fc9, kde-i18n-3.5.9-8.fc9, kdebase-4.1.0-1.fc9.1, sip-4.7.6-1.fc9, kdebase-workspace-4.1.0-8.fc9, automoc-1.0-0.8.rc1.fc9, kdegames-4.1.0-2.fc9, akonadi-1.0.0-2.fc9, soprano-2.1-1.fc9, konq-plugins-4.1.0-2.fc9, compiz-0.7.6-3.fc9.1, qt-4.4.1-2.fc9, qscintilla-2.2-3.fc9, kdepimlibs-4.1.0-2.fc9, kdebindings-4.1.0-5.fc9, kdenetwork-4.1.0-2.fc9, kde-l10n-4.1.0-2.fc9, kdeplasma-addons-4.1.0-1.fc9, qgtkstyle-0.0-0.2.20080719svn693.fc9, kdeutils-4.1.0-1.fc9.1, kdemultimedia-4.1.0-1.fc9, kdeadmin-4.1.0-2.fc9, kde-filesystem-4-17.fc9, kdeaccessibility-4.1.0-1.fc9, kdebase-runtime-4.1.0-3.fc9, phonon-4.2.0-4.fc9, kdegraphics-4.1.0-5.fc9, kdelibs-4.1.0-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.