Bug 440033 - Traceback from update
Traceback from update
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 440990 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 10:13 EDT by Jesse Keating
Modified: 2014-01-21 01:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 09:27:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-04-01 10:13:07 EDT
Got this when applying a few updates:

Error Type: <type 'exceptions.AttributeError'>
Error Value: 'NoneType' object has no attribute 'cursor'
  File : /usr/share/PackageKit/helpers/yum/update.py , line 19, in <module>
    backend.update(packages)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 878, in update
    self._runYumTransaction()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 905, in
_runYumTransaction
    rc,msgs =  self.yumbase.buildTransaction()
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 626, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File : /usr/lib/python2.5/site-packages/yum/depsolve.py , line 667, in resolveDeps
    for po, dep in self._checkFileRequires():
  File : /usr/lib/python2.5/site-packages/yum/depsolve.py , line 872, in
_checkFileRequires
    if not self.tsInfo.getOldProvides(filename) and not
self.tsInfo.getNewProvides(filename):
  File : /usr/lib/python2.5/site-packages/yum/transactioninfo.py , line 411, in
getNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
  File : /usr/lib/python2.5/site-packages/yum/packageSack.py , line 294, in
getProvides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
  File : /usr/lib/python2.5/site-packages/yum/packageSack.py , line 446, in
_computeAggregateDictResult
    sackResult = apply(method, args)
  File : /usr/lib/python2.5/site-packages/yum/sqlitesack.py , line 723, in
getProvides
    return self._search("provides", name, flags, version)
  File : /usr/lib/python2.5/site-packages/yum/sqlitesack.py , line 39, in newFunc
    return func(*args, **kwargs)
  File : /usr/lib/python2.5/site-packages/yum/sqlitesack.py , line 702, in _search
    for pkg in self.searchFiles(name, strict=True):
  File : /usr/lib/python2.5/site-packages/yum/sqlitesack.py , line 39, in newFunc
    return func(*args, **kwargs)
  File : /usr/lib/python2.5/site-packages/yum/sqlitesack.py , line 452, in
searchFiles
    cur = cache.cursor()
Comment 1 Richard Hughes 2008-04-01 10:42:44 EDT
Looks like a yum bug. Does this happen every time? Does this happen with "yum
check-update" and "yum update"?
Comment 2 Jesse Keating 2008-04-01 11:37:57 EDT
No, it only seemed to happen once, and it didn't happen on the command line
using yum directly.

You're right, I didn't look closely it does look like it's coming from yum.
Comment 3 Seth Vidal 2008-04-08 01:54:25 EDT
*** Bug 440990 has been marked as a duplicate of this bug. ***
Comment 4 Adrian "Adi1981" P. 2008-04-08 10:44:39 EDT
I've just manage to repeat this. If you've got in repo, lets say "any", only 1
baseurl enabled, during resolving dependencies stage, yum sometimes downloading
again filelists.sqlite.bz2 for repo to resolve dependencies. Hit ctrl+C, then
yum will try to check another mirror, but as there's no other mirrors for repo
"any", yum will crash. It looks like this:


---> Pakiet control-center-filesystem.i386 1:2.22.1-1.fc9 zostanie zaktualizowany
---> Pakiet gecko-mediaplayer.i386 0:0.6.0-3.lvn9 zostanie zaktualizowany
filelists.sqlite.bz2                                     | 202 kB     00:00
filelists.sqlite.bz2                                     | 1.7 MB     00:06     ^C
http://koji.fedoraproject.org/static-repos/dist-f9-build-current/i386/repodata/filelists.sqlite.bz2:
[Errno 4] Socket Error:(4, 'Przerwane wywo\xc5\x82anie systemowe')
Próbowanie innego serwera lustrzanego.
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)


As for some updates yum don't need to download additional filelists.sqlite.bz2
during resolving dependencies stage, easier way to reproduce this is yum info.
1. yum clean all
2. yum info kadu
3. hit ctrl+C when downloading filelists.sqlite.bz2 from repo "any"
100% repeatable. 

Gives maybe not exactly the same all output, but the same error at the end:

    cur = cache.cursor()
AttributeError: 'NoneType' object has no attribute 'cursor'

[root@localhost ~]# yum info kadu
Wczytane wtyczki: aliases, allowdowngrade, changelog, downloadonly, fedorakmod,
                : kernel-module, list-data, merge-conf, presto, priorities,
                : security, tsflags, verify, versionlock
Setting up and reading Presto delta metadata
No Presto metadata available for koji
No Presto metadata available for rawhide
primary.sqlite.bz2                                       | 632 kB     00:02     ^C

 Obecne pobieranie zostało anulowane, przerwij (Ctrl-C) ponownie w ciągu two
sekund, aby zakończyć.

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 238, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 113, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 305, in doCommands
    self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 98, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 104, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 574, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 421, in _getSacks
    self._pkgSack.excludeArchs(archlist)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 391, in
excludeArchs
    sack.excludeArchs(archlist)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 39, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 1021, in
excludeArchs
    cur = cache.cursor()
AttributeError: 'NoneType' object has no attribute 'cursor'


btw. there's another bug in pl_PL translation:
"Obecne pobieranie zostało anulowane, przerwij (Ctrl-C) ponownie w ciągu _two_
sekund, aby zakończyć."
should be 
" Obecne pobieranie zostało anulowane, przerwij (Ctrl-C) ponownie w ciągu
_dwóch_ sekund, aby zakończyć."
Comment 5 Jesse Keating 2008-04-08 11:18:41 EDT
Re-assigning to yum folks.
Comment 6 Bug Zapper 2008-05-14 04:31:52 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jeremy Katz 2008-06-12 14:51:14 EDT
Can you still reproduce it with yum 3.2.16?
Comment 8 seth vidal 2008-09-03 09:27:07 EDT
I'm pretty sure we've fixed the problem causing this one. Reopen if you can reproduce on 3.2.19 or later
Comment 9 Bill Nottingham 2008-09-25 18:04:49 EDT
*** Bug 448970 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.