Bug 440990 - yum crash while doing "yum update"
yum crash while doing "yum update"
Status: CLOSED DUPLICATE of bug 440033
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 16:20 EDT by Adrian "Adi1981" P.
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 01:54:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian "Adi1981" P. 2008-04-04 16:20:21 EDT
Few minutes ago i had crash with yum:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 152, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 626, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 667, in resolveDeps
    for po, dep in self._checkFileRequires():
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 872, in
_checkFileRequires
    if not self.tsInfo.getOldProvides(filename) and not
self.tsInfo.getNewProvides(filename):
  File "/usr/lib/python2.5/site-packages/yum/transactioninfo.py", line 411, in
getNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 294, in
getProvides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 446, in
_computeAggregateDictResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 723, in
getProvides
    return self._search("provides", name, flags, version)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 39, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 702, in _search
    for pkg in self.searchFiles(name, strict=True):
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 39, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 452, in
searchFiles
    cur = cache.cursor()
AttributeError: 'NoneType' object has no attribute 'cursor'

Version-Release number of selected component (if applicable):
yum-3.2.13-2.fc9.noarch

How reproducible:
Happened every time during resolving dependencies, until i've done "yum clean all"
Now all deps are resolved and update is in progress

Steps to Reproduce:
1. Just yum update
Comment 1 seth vidal 2008-04-04 16:26:35 EDT
can you make this happen repeatably?

If so can you grab a copy of your /var/cache/yum metadata and attach it here
when it happens?
thanks

Comment 2 Adrian "Adi1981" P. 2008-04-04 19:18:40 EDT
Well, after 'yum clean all' everything is ok for now and i can't reproduce it,
but if it'll occurs again then i'll post /var/cache/yum. Maybe it'll be usefull
also, that just before traceback i was always getting error about :

---> Pakiet kdeutils.i386 6:4.0.3-3.fc9 ustawiony do zaktualizowania
---> Pakiet libmudflap.i386 0:4.3.0-6 ustawiony do zaktualizowania
---> Pakiet xorg-x11-server-Xorg.i386 0:1.4.99.901-17.20080401.fc9 ustawiony do
zaktualizowania
---> Pakiet libvolume_id.i386 0:120-1.fc9 ustawiony do zaktualizowania
filelists.sqlite.bz2      100% |=========================| 9.5 MB    01:15
http://koji.fedoraproject.org/static-repos/dist-f9-build-current/i386/repodata/filelists.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Tring other mirror.

followed by traceback. So i suppose it could be some temporary issue caused by
some network problems (there are no other mirrors for koji). If it'll not repeat
during next few days, and nobody will confirm this issue, then i think bug can
be closed as NOTABUG ?
Comment 3 Seth Vidal 2008-04-08 01:54:23 EDT

*** This bug has been marked as a duplicate of 440033 ***

Note You need to log in before you can comment on or make changes to this bug.