Bug 440517 - wrong encoding?
wrong encoding?
Status: CLOSED DUPLICATE of bug 447252
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 17:13 EDT by Need Real Name
Modified: 2008-08-07 03:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 03:09:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (59.26 KB, text/plain)
2008-04-09 16:41 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2008-04-03 17:13:11 EDT
I don't this this is the right component..

1. Corrupt characters
 $ man xorg-x11-drv-keyboard
Keine Handbuchseite für xorg-x11-drv-keyboard
$ echo $LANG
de_DE.UTF-8
2. My arrow keys no longer work
3. My home and end keys no longer work

After an f8 upgrade
Comment 1 Need Real Name 2008-04-03 17:17:48 EDT
and delete is now printscreen.
Comment 2 Need Real Name 2008-04-03 17:21:17 EDT
and the enter key (not the return key) no longer works.
The square bracket keys normally accessible with altgr+8 and altgr+9 do not work.
Comment 3 Need Real Name 2008-04-03 17:37:17 EDT
and the at sign on altgr+q and the pipe symbol

I can't get much done :/ 
Comment 4 Matthias Clasen 2008-04-03 22:12:05 EDT
Most likely keyboard driver trouble. Moving to a more appropriate component for
further triage.
Comment 5 Matěj Cepl 2008-04-04 06:56:59 EDT
Could you please restest with the latest upgrade of Rawhide -- fair number of
these disasters seem to be resolved lately.
Comment 6 Need Real Name 2008-04-04 13:16:41 EDT
Nope. Everything is still unusable. 
Comment 7 Need Real Name 2008-04-04 13:29:43 EDT
I used both of the keyboard programs to change my keyboard layout and now it
almost works - except the delete key does printscreen instead.
Comment 8 Need Real Name 2008-04-04 13:30:11 EDT
and the corrupt characters bug is still present.
Comment 9 Need Real Name 2008-04-04 15:09:13 EDT
btw I am using startx since gdm login is broken.
I have rebooted and my keyboard is wrong again.
Comment 10 Michal Schmidt 2008-04-05 17:18:38 EDT
The corrupt characters in German man output is bug 441074.
Comment 11 Need Real Name 2008-04-05 17:30:34 EDT
Thanks. The keyboard problem might be bug 441077.
Comment 12 Matěj Cepl 2008-04-07 07:30:18 EDT
What kind of keyboard (meaning the real piece of hardware) you have?
Comment 13 Need Real Name 2008-04-07 07:56:41 EDT
It's a logitech usb keyboard. dmesg correctly gets the model number.
Do you need it?
Comment 14 Matěj Cepl 2008-04-07 11:13:14 EDT
No, just trying to find out whether it is problem in some exotic keyboard hardware.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 15 Need Real Name 2008-04-09 16:41:05 EDT
Created attachment 301894 [details]
Xorg.0.log

I do not use an xorg.conf file.
Comment 16 Need Real Name 2008-04-12 19:35:53 EDT
Bug 437290 temporarily fixes the keyboard mapping being wrong (until I reboot),
but I am still stuck with missing keys as noted above.
Comment 17 Bug Zapper 2008-05-14 04:38:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Peter Hutterer 2008-08-07 01:16:44 EDT
Sounds like a duplicate of 447252, or at least caused by the same problem. Can you please verify this?
Comment 19 Need Real Name 2008-08-07 02:10:19 EDT
Looks like that's a dupe of mine :)

Let's say it is.
Comment 20 Peter Hutterer 2008-08-07 03:09:07 EDT

*** This bug has been marked as a duplicate of bug 447252 ***

Note You need to log in before you can comment on or make changes to this bug.