Bug 440565 - FTBFS cppad-20071229-6.fc9
FTBFS cppad-20071229-6.fc9
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cppad (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Brad Bell
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
: 440571 (view as bug list)
Depends On:
Blocks: FTBFS
  Show dependency treegraph
 
Reported: 2008-04-03 21:44 EDT by FTBFS
Modified: 2008-04-04 13:45 EDT (History)
0 users

See Also:
Fixed In Version: F-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 13:45:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log.bz2 (1.69 KB, application/x-bzip2)
2008-04-03 21:44 EDT, FTBFS
no flags Details
build.log.bz2 (4.28 KB, application/x-bzip2)
2008-04-03 21:44 EDT, FTBFS
no flags Details
root.log.bz2 (1.70 KB, application/x-bzip2)
2008-04-03 21:44 EDT, FTBFS
no flags Details
build.log.bz2 (4.34 KB, application/x-bzip2)
2008-04-03 21:44 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-04-03 21:44:28 EDT
cppad-20071229-6.fc9.src.rpm Failed To Build From Source
Comment 1 FTBFS 2008-04-03 21:44:31 EDT
Created attachment 300373 [details]
root.log.bz2

root.log for i386
Comment 2 FTBFS 2008-04-03 21:44:34 EDT
Created attachment 300374 [details]
build.log.bz2

build.log for i386
Comment 3 FTBFS 2008-04-03 21:44:35 EDT
Created attachment 300375 [details]
root.log.bz2

root.log for x86_64
Comment 4 FTBFS 2008-04-03 21:44:37 EDT
Created attachment 300376 [details]
build.log.bz2

build.log for x86_64
Comment 5 Brad Bell 2008-04-04 00:54:34 EDT
*** Bug 440571 has been marked as a duplicate of this bug. ***
Comment 6 Brad Bell 2008-04-04 01:07:44 EDT
Inspecting the file
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/cppad-20071229-6.fc9.src.rpm/result/build.log
you will find the error and warning messages:
------------------------------------------------------------------------
g++    -I. -I..    -g    -MT sub_eq.o -MD -MP -MF .deps/sub_eq.Tpo -c -o
sub_eq.o sub_eq.cpp
stack_machine.cpp: In function 'bool<unnamed>::is_number(const std::string&)':
stack_machine.cpp:43: error: 'strchr' was not declared in this scope
...
stack_machine.cpp:148: warning: deprecated conversion from string constant to
'char*'
------------------------------------------------------------------------
This problem, and some others, were fixed in the trunk of CppAD on 2008-03-03.
The corresponding subversion log message is:
------------------------------------------------------------------------
r1134 | bradbell | 2008-03-03 05:18:30 -0800 (Mon, 03 Mar 2008) | 14 lines
trunk: Fix non-standard operations detected by g++ 4.3 ...
------------------------------------------------------------------------

Creating the upstream source has been delayed by the fact that COIN-OR (the open
source repository that cppad uses) wants cppad to convert from year, month, day
version numbering to major, minor, bug fix version numbering. This would require
cppad.spec to use the Epoch command. After reading about how the Epoch command
is discouraged, it may perhaps be better to have cppad continue using year,
month, day version numbering. At least for fixing this bug. That will give us
more time to consider this change.
Comment 7 Brad Bell 2008-04-04 09:17:07 EDT
The new upstream source (using year, month, day version numbering)
    http://www.coin-or.org/CppAD/download/cppad-20080403.gpl.tgz
was created. This fixed most of the problems detected by the new gcc compiler
(see the Thur Apr 03 2008) entries in the cppad.spec changelog).

An exception was one warning and one error in the speed/main.cpp. 
These were not previously detected because they had not been run
with such a new version of gcc before. They were corrected by editing
speed/main.cpp in the setup section of the cppad.spec file
(see the  Fri Apr 04 2008) entry in the cppad.spec changelog).

cppad now build with Fedora-9; see
http://koji.fedoraproject.org/koji/taskinfo?taskID=548221

Note You need to log in before you can comment on or make changes to this bug.