Bug 440767 - FTBFS soundtracker-0.6.8-2.fc6
FTBFS soundtracker-0.6.8-2.fc6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: soundtracker (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Callum Lerwick
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
: 434425 (view as bug list)
Depends On:
Blocks: FTBFS gcc43errors
  Show dependency treegraph
 
Reported: 2008-04-04 11:56 EDT by FTBFS
Modified: 2013-01-09 23:38 EST (History)
2 users (show)

See Also:
Fixed In Version: soundtracker-0.6.8-4.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-01 01:03:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log.bz2 (2.67 KB, application/x-bzip2)
2008-04-04 11:56 EDT, FTBFS
no flags Details
build.log.bz2 (5.43 KB, application/x-bzip2)
2008-04-04 11:56 EDT, FTBFS
no flags Details
root.log.bz2 (2.69 KB, application/x-bzip2)
2008-04-04 11:56 EDT, FTBFS
no flags Details
build.log.bz2 (5.34 KB, application/x-bzip2)
2008-04-04 11:56 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-04-04 11:56:03 EDT
soundtracker-0.6.8-2.fc6.src.rpm Failed To Build From Source
Comment 1 FTBFS 2008-04-04 11:56:07 EDT
Created attachment 300663 [details]
root.log.bz2

root.log for i386
Comment 2 FTBFS 2008-04-04 11:56:09 EDT
Created attachment 300664 [details]
build.log.bz2

build.log for i386
Comment 3 FTBFS 2008-04-04 11:56:11 EDT
Created attachment 300665 [details]
root.log.bz2

root.log for x86_64
Comment 4 FTBFS 2008-04-04 11:56:12 EDT
Created attachment 300666 [details]
build.log.bz2

build.log for x86_64
Comment 5 Bug Zapper 2008-05-14 04:43:27 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Hans Ulrich Niedermann 2008-05-31 11:40:10 EDT
This looks like a question of either porting the upstream source from upstream's
alsa 0.4 or 0.5 support to 1.0, or following the workaround suggested at
http://www.soundtracker.org/requirements.php3:

Add --disable-alsa to %configure line, use soundtracker's OSS output with ALSA's
OSS emulation, and accept the loss of MIDI input capability.

Comment 7 Hans Ulrich Niedermann 2008-05-31 15:06:11 EDT
(In reply to comment #6)

> Add --disable-alsa to %configure line, use soundtracker's OSS output with ALSA's
> OSS emulation, and accept the loss of MIDI input capability.

It builds for F-9 and rawhide in koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=638322
http://koji.fedoraproject.org/koji/taskinfo?taskID=638317

As to whether this soundtracker package still works, I'll have to find out. If
it does, and nobody comments here that it is a bad idea, I'll upload the
alsa-disabled soundtracker to F-9/ and devel/ in a few days.
Comment 8 Hans Ulrich Niedermann 2008-05-31 15:32:41 EDT
The --disable-alsa build works OOTB for module playback on my F-9 via the ALSA
OSS emulation and pulseaudio.
Comment 9 Hans Ulrich Niedermann 2008-05-31 15:56:42 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=638413

Does this mean CLOSED RAWHIDE, or should I to do something else?

Comment 10 Matt Domsch 2008-06-01 01:03:13 EDT
CLOSED RAWHIDE is appropriate, it builds now.
Comment 11 Hans Ulrich Niedermann 2008-06-01 04:57:33 EDT
I'm putting rebuilds for F-9 and F-8 into the respective updates-testing
repository: https://admin.fedoraproject.org/updates/soundtracker

I won't request F-8 stable unless there are three positive karma votes. F-9 I'll
push to stable in a few days as I am running F-9 myself.
Comment 12 Hans Ulrich Niedermann 2008-06-01 10:58:27 EDT
*** Bug 434425 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.