Bug 440981 - anaconda unhandled exception save to USB flash drive with FAT partition fails
anaconda unhandled exception save to USB flash drive with FAT partition fails
Status: CLOSED DUPLICATE of bug 429185
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 15:32 EDT by Paul Walmsley
Modified: 2008-04-04 15:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 15:35:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Walmsley 2008-04-04 15:32:34 EDT
Description of problem:
Attempting to save an Anaconda traceback to a USB flash drive fails with a "Bug"
 dialog:

Assertion (ped_partition_is_active (part)) at disk.c:1186 in function
ped_partition_get_flag() failed.

Clicking the "Ignore" button then pops up another Bug window:

Assertion (part->disk_specific != NULL) at dos.c:1423 in function
msdos_partition_get_flag() failed.

Clicking "Ignore" then hangs the machine.

Version-Release number of selected component (if applicable):
Fedora 9 beta

How reproducible:
Cause traceback via bug 440976; plug in USB drive; click "Save."  Also happens
when USB flash drive is plugged in at boot time.  Note that if no USB drive is
plugged in at all, bug does not occur, and "Disk" radio-button in the Save
dialog box is grayed out.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2008-04-04 15:35:21 EDT

*** This bug has been marked as a duplicate of 429185 ***

Note You need to log in before you can comment on or make changes to this bug.