Bug 441631 - pressing the 'Power' button offers a log out dialog
pressing the 'Power' button offers a log out dialog
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 453297 457696 458516 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-04-09 02:48 EDT by petrosyan
Modified: 2008-11-26 03:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 03:26:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 252795 None None None Never

  None (edit)
Description petrosyan 2008-04-09 02:48:36 EDT
Description of problem:
gnome-power-manager preferences has an option that when pressing the 'Power'
button it should 'Ask me' whether to suspend, hibernate or shut down.
Instead when I press the 'Power' button it shows a dialogue window which says
"Are you sure you want to log out?" and "OK" and "Cancel" buttons.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.22.1-1.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. in gnome-power-manager preferences in the General tab set 'When the power
button is pressed:' to 'Ask me'
2. press the power button

Actual results:
It asks me if I am sure that I want to log out.

Expected results:
It should ask me whether I want to suspend, hibernate or shut down the computer.
Comment 1 Matthias Clasen 2008-04-09 12:19:34 EDT
Can we get this fixed for F9, Richard ?
Comment 2 Richard Hughes 2008-04-18 08:32:06 EDT
Well, the gnome-session code for this has changed - see the bug
http://bugzilla.gnome.org/show_bug.cgi?id=507393 for more details.

This is F10 material IMO.
Comment 3 Jesse Keating 2008-04-18 11:42:37 EDT
Agreed, moving.
Comment 4 Bug Zapper 2008-05-14 05:10:27 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 petrosyan 2008-07-22 10:07:20 EDT
*** Bug 453297 has been marked as a duplicate of this bug. ***
Comment 6 petrosyan 2008-07-22 10:08:55 EDT
from bug 453297

When I set it to shutdown without asking it just shuts down X and stops with a
console login prompt. I have to press the shutdown button a second time to
perform the shutdown.
Comment 7 drago01 2008-07-22 10:20:42 EDT
(In reply to comment #6)
> from bug 453297
> 
> When I set it to shutdown without asking it just shuts down X and stops with a
> console login prompt. I have to press the shutdown button a second time to
> perform the shutdown.

Ignore this part, this was some other weird issue that somehow "fixed itself"
with other updates.
Comment 8 Hendrik Borghorst 2008-08-04 21:23:55 EDT
*** Bug 457696 has been marked as a duplicate of this bug. ***
Comment 9 Richard Hughes 2008-09-10 08:47:35 EDT
Does this now work correctly with rawhide?
Comment 10 petrosyan 2008-10-01 02:40:13 EDT
In rawhide pressing the power button shuts down the machine even if power-manager setting requests "Ask Me" when power button pressed.
Comment 11 petrosyan 2008-10-01 18:04:13 EDT
*** Bug 458516 has been marked as a duplicate of this bug. ***
Comment 12 petrosyan 2008-11-26 03:26:08 EST
This bug has been fixed in Fedora 10.

Note You need to log in before you can comment on or make changes to this bug.