Bug 441775 - bzip2-libs contains wrong link for libzip2.so.1
bzip2-libs contains wrong link for libzip2.so.1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bzip2 (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: Reopened
: 442231 448264 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 18:50 EDT by Christian Krause
Modified: 2008-07-26 01:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0.5-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 18:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2008-04-09 18:50:56 EDT
the package bzip2-libs contains the link "/lib/libbz2.so.1" which points to
"libbz2.so.1.0.5" (which is wrong, because the library's filename is still
"/lib/libbz2.so.1.0.4")

sure, running "ldconfig" "fixes" the problem, but then rpm -V bzip2-libs reports
an error that the link has changed

----------------------
root@localhost:~# rpm -qlv bzip2-libs
[...] 15    Mar 25 14:09 /lib/libbz2.so.1 -> libbz2.so.1.0.5
[...] 70464 Mar 25 14:09 /lib/libbz2.so.1.0.4
root@localhost:~# rpm -V bzip2-libs
....L...    /lib/libbz2.so.1
root@localhost:~# 
----------------------

The root cause for the problem is, that even that the version of the package has
been increased, the library's version within the package hasn't. This small
patch for the spec file fixes the problem and makes bzip2.spec a little bit more
generic:

RCS file: /cvs/pkgs/rpms/bzip2/devel/bzip2.spec,v
retrieving revision 1.36
diff -u -r1.36 bzip2.spec
--- bzip2.spec  25 Mar 2008 13:02:53 -0000      1.36
+++ bzip2.spec  9 Apr 2008 22:46:09 -0000
@@ -1,3 +1,4 @@
+%define library_version 1.0.4
 Summary: A file compression utility
 Name: bzip2
 Version: 1.0.5
@@ -65,7 +66,7 @@
 cp -p bzlib.h $RPM_BUILD_ROOT%{_includedir}
 # temporary for rpm
 install -m 644 libbz2.a $RPM_BUILD_ROOT%{_libdir}
-install -m 755 libbz2.so.1.0.4 $RPM_BUILD_ROOT/%{_lib}
+install -m 755 libbz2.so.%{library_version} $RPM_BUILD_ROOT/%{_lib}
 install -m 755 bzip2-shared  $RPM_BUILD_ROOT%{_bindir}/bzip2
 install -m 755 bzip2recover bzgrep bzdiff bzmore  $RPM_BUILD_ROOT%{_bindir}/
 cp -p bzip2.1 bzdiff.1 bzgrep.1 bzmore.1  $RPM_BUILD_ROOT%{_mandir}/man1/
@@ -73,7 +74,7 @@
 ln -s bzip2 $RPM_BUILD_ROOT%{_bindir}/bzcat
 ln -s bzdiff $RPM_BUILD_ROOT%{_bindir}/bzcmp
 ln -s bzmore $RPM_BUILD_ROOT%{_bindir}/bzless
-ln -s libbz2.so.%{version} $RPM_BUILD_ROOT/%{_lib}/libbz2.so.1
+ln -s libbz2.so.%{library_version} $RPM_BUILD_ROOT/%{_lib}/libbz2.so.1
 ln -s ../../%{_lib}/libbz2.so.1 $RPM_BUILD_ROOT/%{_libdir}/libbz2.so
 ln -s bzip2.1 $RPM_BUILD_ROOT%{_mandir}/man1/bzip2recover.1
 ln -s bzip2.1 $RPM_BUILD_ROOT%{_mandir}/man1/bunzip2.1
Comment 1 Ivana Varekova 2008-04-10 03:29:22 EDT
Thanks. Fixed in  bzip2-1.0.5-2.fc9.
Comment 2 Ivana Varekova 2008-04-14 03:33:14 EDT
*** Bug 442231 has been marked as a duplicate of this bug. ***
Comment 3 Robert Scheck 2008-04-14 04:01:39 EDT
Well, why has the symlink still 1.0.4 rather 1.0.5 when looking to this:
http://cvs.fedoraproject.org/viewcvs/devel/bzip2/bzip2.spec?r1=1.36&r2=1.37
Comment 4 Robert Scheck 2008-04-14 04:03:09 EDT
Sorry, but IMHO the correct fix is to replace %{library_version} by %{version}
at the symlink part simply.
Comment 5 Ivana Varekova 2008-04-14 04:15:11 EDT
This name is upstream choice - there is no need to change it.
Comment 6 petrosyan 2008-05-17 20:50:51 EDT
Is bzip2-1.0.5-2.fc9 going to be released as Fedora 9 update?
Comment 7 petrosyan 2008-05-21 11:03:49 EDT
I am reopening this bug because bzip2-1.0.5-2.fc9 was never pushed as an update
or an update-testing for Fedora 9.
Comment 8 Fedora Update System 2008-05-29 03:47:46 EDT
bzip2-1.0.5-2.fc9 has been submitted as an update for Fedora 9
Comment 9 Ivana Varekova 2008-05-29 03:49:09 EDT
*** Bug 448264 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2008-05-30 22:17:22 EDT
bzip2-1.0.5-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bzip2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4796
Comment 11 Fedora Update System 2008-06-06 18:11:06 EDT
bzip2-1.0.5-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-06-09 23:17:04 EDT
bzip2-1.0.5-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-07-26 01:57:07 EDT
bzip2-1.0.5-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.