Bug 442188 - Useless error message after media verification: "Error: [OK]"
Useless error message after media verification: "Error: [OK]"
Status: CLOSED DUPLICATE of bug 375011
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target 442208
  Show dependency treegraph
 
Reported: 2008-04-12 11:16 EDT by Hans Ulrich Niedermann
Modified: 2008-04-22 10:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 10:52:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Ulrich Niedermann 2008-04-12 11:16:40 EDT
Description of problem:

  Anaconda displays useless error message dialog when it cannot read the
installation medium (DVD):

  +----[Error]----+
  | OK            |
  |          [OK] |
  +---------------+

Version-Release number of selected component (if applicable):

  anaconda from the F9-Beta DVD image

How reproducible:

  every time

Steps to Reproduce:
1. Insert F9 Beta DVD and boot from it in graphical mode.
2. Check/Verify the DVD when asked about it (still in text mode).
3. Watch DVD being ejected while anaconda asks you whether you want to [test] 
another medium or [continue] with the installation.
4. choose [continue] and re-insert the DVD tray
5. Watch anaconda try to read from the DVD while the DVD drive is still
detecting the drive. Anaconda's read will fail and anaconda will display the
completely useless error message.
  
Actual results:

  Nonsensical error dialog as depicted above.

Expected results:

  1. Anaconda should retry a few times.
  2. If reads still fail after 5 to 10 seconds, an error message telling about
the problem and proposing useful courses of action. 

Additional info:
Comment 1 Chris Lumens 2008-04-22 10:52:50 EDT

*** This bug has been marked as a duplicate of 375011 ***

Note You need to log in before you can comment on or make changes to this bug.