Bug 375011 - Can't continue installation after running media check
Can't continue installation after running media check
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: Reopened
: 441041 442188 442208 446265 446301 446838 447165 451785 459056 459342 461876 465257 467566 470033 479543 (view as bug list)
Depends On:
Blocks: F10AnacondaBlocker
  Show dependency treegraph
 
Reported: 2007-11-10 15:24 EST by Kevin Cozens
Modified: 2013-01-09 23:29 EST (History)
20 users (show)

See Also:
Fixed In Version: anaconda-11.4.1.58-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 11:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Cozens 2007-11-10 15:24:39 EST
Boot a Fedora DVD, select item 1 (install/upgrade existing partition), and run
the media check when given the option. When the media check completes the DVD is
ejected and the user can select "Test" or "Continue". Select continue. The DVD
is reloaded, the DVD drive light flashes for a while and is eventually ejected
once more. The screen shows a dialog box titled "Error" containing the message
"OK" in black, and a button with the text "OK" on it.

The only way to get past this point is to reboot the computer using the DVD, and
when asked about running a media check, select "Skip" to skip the media check.

This problem exists with both the F8 i386 and F8 x86_64 DVD's. I download the
ISO's for the discs off the net. Both DVD ISO images passed the 'sha1sum -c'
test. Each image was burned to a DVD and verified by k3b. I was able to
successfully upgrade the i386 and x86_64 partitions of my computer with the
DVD's as long as I skip the media check.
Comment 1 Luigi Tarenga 2007-11-10 18:22:16 EST
i did a media check too and once the dvd was ejected i pressed "continue",
a new windows prompt out with only an "Ok" message, i inserted the dvd media,
pressed ok and the installation went on smoothly... i didn't get this kind
of error even if i executed a media check
Comment 2 Jeremy Katz 2007-11-12 14:09:10 EST
What is printed on tty3 when the CD is ejected again?
Comment 3 Kevin Cozens 2007-11-14 01:30:56 EST
The only message that appears on tty3 is the message:
  ejecting /tmp/cdrom...

The message appears about 30 seconds after hitting the "Ok" button on the screen
with the "Ok" message. I hit the "Ok" button three times and the DVD was ejected
each time.
Comment 4 Kevin Cozens 2007-11-19 10:41:46 EST
Some additional bits of information (in case they may be helpful). I am using a
computer which I have only had for about 6 months. I initially installed Fedora
7 on it. I don't recall having a problem with the media test on F7. However,
that was about 6 months ago and I can't say with absolute certainty that I did
perform the media test. The DVD drive I was using during the install is a
DVD+/-R/W drive. It is identified in dmesg as HL-DT-ST DVDRRW GSA-H30L.
Comment 5 Chris Lumens 2008-04-22 10:52:51 EDT
*** Bug 442188 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2008-04-22 10:53:12 EDT
*** Bug 442208 has been marked as a duplicate of this bug. ***
Comment 7 Hans Ulrich Niedermann 2008-04-22 13:23:56 EDT
JFTR: Bug 442188 and bug 442208 referred not to F8 like this bug, but to
what-will-be-F9.
Comment 8 Will Woods 2008-05-14 14:33:09 EDT
*** Bug 446265 has been marked as a duplicate of this bug. ***
Comment 9 Will Woods 2008-05-14 14:33:20 EDT
*** Bug 446301 has been marked as a duplicate of this bug. ***
Comment 10 Will Woods 2008-05-14 14:38:37 EDT
To work around this, you just need to slow down - wait for the machine to detect
that there's a disc in the drive (watch the flashing light) before you hit OK.
Comment 11 Chris Lumens 2008-05-15 00:29:57 EDT
*** Bug 441041 has been marked as a duplicate of this bug. ***
Comment 12 Chris Lumens 2008-05-16 10:40:49 EDT
*** Bug 446838 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2008-05-18 10:28:23 EDT
*** Bug 447165 has been marked as a duplicate of this bug. ***
Comment 14 Andy Lindeberg 2008-06-03 15:41:16 EDT
This bug persists in F9, though it's not really a bug. You need to reinsert the
disc and wait for about fifteen seconds for the system to find it again before
hitting continue. A more graceful error message than "Error" would be helpful,
though.
Comment 15 Hans Ulrich Niedermann 2008-06-03 16:20:38 EDT
Reopening, as the useless error message IS the bug, and I have not read about a
fix for that yet.

At least the useless error message is what I reported as bug 442188, and that
bug has been classified as a duplicate of this-here bug.
Comment 16 Hans Ulrich Niedermann 2008-06-03 16:25:42 EDT
Just for the record, the message in question looks like this:

  +----[Error]----+
  | OK            |
  |          [OK] |
  +---------------+

The user is supposed to read that as "The installer is currently cannot read
from the installation medium. Please wait until the drive has definitely
recognized the medium, which may take a little time." or something along these
lines.

That cannot be realistically expected from a majority of users, IMHO.
Comment 17 Andy Lindeberg 2008-06-17 11:22:59 EDT
*** Bug 451785 has been marked as a duplicate of this bug. ***
Comment 18 Chris Lumens 2008-07-10 17:31:56 EDT
Stupid error message fixed in Rawhide, though we still need to fix the real
problem here.  The real problem is that we're not able to wait for the drive
tray to be pulled back in and the new media to be recognized without some kernel
patching.  Peter's working on that.
Comment 19 Andy Lindeberg 2008-08-14 09:41:32 EDT
*** Bug 459056 has been marked as a duplicate of this bug. ***
Comment 20 Andy Lindeberg 2008-08-26 13:13:20 EDT
*** Bug 459342 has been marked as a duplicate of this bug. ***
Comment 21 Andy Lindeberg 2008-09-11 10:17:40 EDT
*** Bug 461876 has been marked as a duplicate of this bug. ***
Comment 22 Andy Lindeberg 2008-10-02 09:46:45 EDT
*** Bug 465257 has been marked as a duplicate of this bug. ***
Comment 23 Andy Lindeberg 2008-10-10 11:19:58 EDT
This has (finally!) been fixed in today's rawhide.
Comment 24 Paul 2008-10-10 22:52:57 EDT
This is good news to hear. I did want to ask if it will be back-patched to F9

Thanks,
Paul
Comment 25 Jens Petersen 2008-10-12 22:09:26 EDT
(In reply to comment #23)
> This has (finally!) been fixed in today's rawhide.

Has it?  I can still reproduce with the latest rawhide here with anaconda-11.4.1.48-1: it keeps asking me for "The Fedora disc" after checking boot.iso successfully.
Comment 26 Will Woods 2008-10-13 16:01:47 EDT
The situation *has* improved somewhat - loader appears waits for the disc to be sensed by the drive/kernel. But once that happens, it thinks the disc still isn't there. 

As before, you can work around this by inserting the media, waiting a bit for the drive to detect it, and *then* hitting "OK" or "Continue".
Comment 27 Jerry Williams 2008-10-20 20:57:18 EDT
Tried Fedora 10 Snap2 x86_64 DVD and once I test the DVD it ejects it and then it can't seem to find it again.
I also have a second DVD drive and it looks at /dev/sr1 for a while before it will go on.
Comment 28 Jerry Williams 2008-10-20 21:26:01 EDT
I tried this again with Fedora 10 Snap 2 x86_64 and if I put the DVD back in the drive and wait for the light to stop flashing and then select continue then it seems to be okay.  Then I just have to wait the min for /dev/sr1.

I tried this on VBox and if I kind of do that same thing, but I have to Select Devices and Mount the DVD image and then select continue.  If I select continue without doing that I can't seem to recover without a reboot.
Comment 29 Jens Petersen 2008-10-20 21:54:35 EDT
If there isn't an easy way to fix this cleanly then IMHO it would be better just to do a reboot by default after finishing the mediacheck and confirming with the user: the current status quo is just too confusing, or maybe add a message saying "Wait a bit!" or something at least.
Comment 30 Paul 2008-10-21 00:02:50 EDT
So I guess I should say "forget my email about porting to Fedora 9" ...

Given the subsequent emails, I think Jen's (comment #29) is the correct approach. Though I would prefer a "do this cause there is a problem and you need to do such-and-such workaround" rather than a "wait a bit" as that doesn't own up to the issue that is causing the problem.
Comment 31 Andy Lindeberg 2008-10-21 16:57:31 EDT
*** Bug 467566 has been marked as a duplicate of this bug. ***
Comment 32 Andy Lindeberg 2008-10-21 17:08:37 EDT
Aaaargh! You're right, this is still halfway broken.

However, it works just fine if you hit "continue" and let the computer take the disc back in itself. (Wtf.) Peter has said he'll look at the hitting-ok-right-after-reinserting behavior tomorrow.
Comment 33 Jerry Williams 2008-10-21 20:20:45 EDT
Why does it have to eject the disk in the first place?
This causes problem on things like vbox.
When you are testing a DVD you only have 1, why eject it?
Why not have an eject button to go along with the test and continue ones?
Comment 34 Hans Ulrich Niedermann 2008-10-22 03:57:51 EDT
(In reply to comment #33)
> Why does it have to eject the disk in the first place?
> When you are testing a DVD you only have 1, why eject it?

Very good point.

> Why not have an eject button to go along with the test and continue ones?

I like that idea.

I'd ask the user before the media test - give the user these three buttons to choose from:

  * Skip media test
  * Test medium and continue installation (if successful)
  * Test medium and eject it

On three well-named dialog buttons, that would make things a lot easier.

If the explanation is in the text, the buttons could e.g. be called

    "Skip" "Test and continue installation" "Test and eject medium"

That should fit on an 80 column text screen.
Comment 35 Chris Lumens 2008-10-27 10:14:44 EDT
I believe this should be fixed up as of 11.4.1.51-1.  Peter just committed some fixes for it on Thursday.
Comment 36 Will Woods 2008-10-27 15:04:15 EDT
No good, at least for the 3 drives / 2 machines I tested. 

The test goes like this:

0) Burn and boot rawhide's boot.iso
1) Perform mediacheck
2) When mediacheck completes, hit "OK" to acknowledge success and eject the disc
3) Choose "Continue" to continue installation
4) Drive closes, time passes
5) Disc ejects; "Error: The Fedora disc was not found in any of your drives..."
6) Hit OK. Goto 4

There are no log messages from loader during this loop, even with 'loglevel=debug'. tty5 does say:
  Running... /bin/mount -n -t iso9660 -o -ro /dev/sr0 /mnt/stage2
but there's nothing in dmesg, syslog, or anaconda.log.

The only way to break the loop is to insert the disc by hand, wait for the drive/kernel to notice that it's been inserted, and *then* hit OK.

Strangely, if you hit "Test" rather than "Continue" at step 3, it will happily close the drive, wait for it to spin up, and then proceed to test the media, as you would expect.
Comment 37 Jens Petersen 2008-10-27 22:26:20 EDT
(In reply to comment #35)
> I believe this should be fixed up as of 11.4.1.51-1.

Not for me either.
Comment 38 Jens Petersen 2008-10-28 02:39:51 EDT
(In reply to comment #34)
>     "Skip" "Test and continue installation" "Test and eject medium"

How about:

"Install"  "Test and install"  "Test only"
Comment 39 Hans Ulrich Niedermann 2008-10-28 07:34:33 EDT
Hmm.

"Install" "Test and install" "Test and ask"

?
Comment 40 Jens Petersen 2008-10-30 03:28:36 EDT
Sure, as long as "ask" does not sit you in an infinite media eject loop. :)
Comment 41 Hans Ulrich Niedermann 2008-10-30 05:26:25 EDT
Obviously. And make my suggestion

"Install" "Test and install" "Test and ask again"
Comment 42 Jens Petersen 2008-11-03 01:03:14 EST
> The only way to break the loop is to insert the disc by hand, wait for the
> drive/kernel to notice that it's been inserted, and *then* hit OK.

Okay I finally reproduced that - not sure how long one needs to wait I think I waited over 20s.
Comment 43 Chris Lumens 2008-11-05 16:07:50 EST
*** Bug 470033 has been marked as a duplicate of this bug. ***
Comment 44 Jesse Keating 2008-11-11 18:11:44 EST
Yeah, there is still a loop here, I can't break out of it unless I put the disc in manually.
Comment 45 Will Woods 2008-11-12 16:38:10 EST
Still a loop here as well. Here's the /proc/scsi/scsi information about my drives:

Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: LITE-ON  Model: CD-ROM LTN-4891S Rev: NDS3
  Type:   CD-ROM                           ANSI  SCSI revision: 05
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: TSSTcorp Model: CDRWDVD TS-H492C Rev: DE02
  Type:   CD-ROM                           ANSI  SCSI revision: 05

The latter is the one I'm using.
Comment 46 Will Woods 2008-11-12 17:11:55 EST
Reproduced in anaconda-11.4.1.57 (20081112 Rawhide boot.iso).

Maybe it's just certain balky hardware that's affected anymore? Or maybe having multiple drives changes the outcome?

I'll accept moving this bug off the Blocker list if we can show that it works for *most* people.
Comment 47 Will Woods 2008-11-12 17:53:31 EST
Think we finally got this knocked. pjones built a test image that works exactly as expected on my unhappy drives. The fix is in:

  commit e7b3e458315a83340eb07b630da5f7194c035064

Should land in the next anaconda build, which would presumably be anaconda-11.4.1.58-1
Comment 48 Andy Lindeberg 2008-11-12 17:59:39 EST
Confirmed fixed!
Comment 49 Will Woods 2008-11-12 18:12:45 EST
Leaving this open until we actually have a fixed package tagged and signed for f10-final.
Comment 50 Paul 2008-11-12 23:32:51 EST
Assuming this fix holds up as valid and is released into f10, will it be back-patched to f9?
Comment 51 Jens Petersen 2008-11-12 23:49:30 EST
(In reply to comment #50)
> Assuming this fix holds up as valid and is released into f10, will it be
> back-patched to f9?

Err, what for? :)  fedoraunity?   anaconda is not normally backported, I think.
Comment 52 Paul 2008-11-13 00:22:01 EST
"Fedoraunity" is the least of my worries. I have multiple machines I need to upgrade from FC5 to F9 and my experience in dealing with thrid-party software is that sometimes a fix only holds for the current release and sometimes it is possible to baclpatch to the prior release, maybe more.

This thread shows that its impacted alot of people and it seems that if it can be backpatched it would make life easier for those who are still working on F9 and not ready to move to F10.

Whether it happens or not is not a critical issue. But asking if it is possible is a legit question in my book.
Comment 53 Jens Petersen 2008-11-13 02:14:19 EST
(In reply to comment #52)
> I have multiple machines I need to upgrade from FC5 to F9

So to make my question more specific: how would you use such a potential anaconda update?
You would have to do a local respin of f9 to make use of it I think.
Comment 54 Paul 2008-11-13 08:48:04 EST
Ah, light bulb goes off above head !!!

I now understand why this request doesn't make sense, thanks for clarifying (and let's pretend I never asked about a back-patch)
Comment 55 Jeremy Katz 2008-11-13 11:44:33 EST
Package built, tag request in. --> MODIFIED
Comment 56 James Laska 2008-11-14 14:00:26 EST
Confirmed in rawhide-20081114 while booting from and verifying boot.iso media.
Comment 57 Andy Lindeberg 2009-01-13 17:30:48 EST
*** Bug 479543 has been marked as a duplicate of this bug. ***
Comment 58 Andy Lindeberg 2009-01-14 14:06:10 EST
*** Bug 479543 has been marked as a duplicate of this bug. ***
Comment 59 Bug Zapper 2009-06-09 05:21:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 60 Penelope Fudd 2009-06-25 13:39:46 EDT
This bug is still present in Fedora 11 install DVD.

Do a media check; reinsert DVD and click on 'ok''; get a message saying the disk is not recognized as the Fedora disk.
Comment 61 Andy Lindeberg 2009-07-15 11:54:33 EDT
(In reply to comment #60)
> This bug is still present in Fedora 11 install DVD.
> 
> Do a media check; reinsert DVD and click on 'ok''; get a message saying the
> disk is not recognized as the Fedora disk.  

This is not the same bug at all. Please file a separate report for this problem.

We have not gotten any reports since January, so I'm going to close this bug as FINALLY fixed. Hopefully it will stay that way this time.

Note You need to log in before you can comment on or make changes to this bug.