Bug 442190 - padlock drivers noisy on encrypted root boot with non-VIA cpus
padlock drivers noisy on encrypted root boot with non-VIA cpus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
:
: 443092 443905 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-12 11:34 EDT by louisgtwo
Modified: 2008-05-02 13:42 EDT (History)
10 users (show)

See Also:
Fixed In Version: module-init-tools-3.4-13.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 13:42:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2008-04-12 11:34:34 EDT
For fedora9 mkinitrd gives insmod errors with encrypted partitions
before asking for the paraphrase. I believe the cause is module naming.
Both modules aes.ko and sha256.ko were renamed in later kernels to
aes-generic.ko and sha256-generic.ko 

WARNING: Error inserting padlock_aes
(/lib/modules/2.6.25-0.218.rc8.git7.fc9.i686/padlock-aes.ko: No such device
WARNING: Error inserting padlock_sha
(/lib/modules/2.6.25-0.218.rc8.git7.fc9.i686/padlock-sha.ko: No such device

Though the modules load successfully it would be nice to get rid of
these ugly messages.
Comment 1 Jeremy Katz 2008-04-13 22:29:21 EDT
No, the aes-generic and sha256-generic modules get loaded also.  But we try to
load all modules matching the alias which provide the sha256 modalias (and aes)
which includes the padlock modules which are for VIA hardware acceleration. 
There's not really any great ways to avoid this
Comment 2 louisgtwo 2008-04-14 11:19:08 EDT
Well how about silencing the errors. This looks a bit unprofesional.
Comment 3 Jeremy Katz 2008-04-23 22:12:50 EDT
*** Bug 443905 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2008-04-23 22:12:55 EDT
*** Bug 443092 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2008-04-23 22:30:02 EDT
If we're going to quiet things anywhere, it should probably be modprobe.
Comment 6 Jon Masters 2008-04-25 21:27:42 EDT
Um. I'm not able to reproduce at the moment - looks like davej or chuck changed
the kernel config to stop building these padlock drivers?

But what you're asking for is a valid feature. I won't rush out to fix this
tonight if this isn't actually a blocker for F9.
Comment 7 Jeremy Katz 2008-04-28 20:53:45 EDT
As mentioned to jcm privately -- they're still there and built on x86 but
obviously not on x86_64 and ppc (via only makes x86 hardware)

And wwoods -- on the blocker list because otherwise, we're going to get a deluge
of reports about this.  With quiet disabled earlier in the cycle, no one
noticed.  But it's a very very visible thing in a new feature that we're pretty
heavily touting.  Unless we're "happy" dealing with that, it needs to be fixed
Comment 8 Jon Masters 2008-04-28 23:38:38 EDT
It's on my TODO for tomorrow. I'll have to install a 32-bit rawhide tonight to
reproduce - I had foolishly not considered that VIA only make 32-bit hardware :)
Comment 9 Jon Masters 2008-05-01 12:31:51 EDT
Ok, I can reproduce this now. Looking into it.
Comment 10 Jon Masters 2008-05-01 14:22:15 EDT
I've posted a fix, which I'll want to rework for upstream, but this should be ok
for F-9 use. If I get the other fix done today, I'll request another update.
Comment 11 louisgtwo 2008-05-01 23:09:42 EDT
if you are referring to module-init-tools-3.4-13.fc9 from koji that didn't solve
the problem for me.
Comment 12 Jon Masters 2008-05-02 00:19:42 EDT
Did you rebuild your initrd with mkinitrd? You'll need to actually have the
latest version of modprobe in your initrd in order to verify this fix :)

If you need a hand, let me know.

Jon.
Comment 13 louisgtwo 2008-05-02 08:57:39 EDT
No I didn't. Let me know how to do this.
Comment 14 Will Woods 2008-05-02 13:42:47 EDT
Confirmed fixed. No more WARNINGs from modprobe/insmod. We still get the padlock
messages:
  padlock: VIA PadLock not detected.
  padlock: VIA PadLock Hash Engine not detected.
But that's expected (and non-scary).

Louis, updating the kernel will rebuild the initrd for you (there's a new kernel
in today's rawhide as well).

Note You need to log in before you can comment on or make changes to this bug.