Bug 442798 - RAWHIDE Synaptics Touchpad tap button mechanism does not work from thaw from disk
RAWHIDE Synaptics Touchpad tap button mechanism does not work from thaw from ...
Status: CLOSED DUPLICATE of bug 437609
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 17:08 EDT by Shawn Starr
Modified: 2008-05-21 10:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 08:39:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Starr 2008-04-16 17:08:11 EDT
Description of problem: When you suspend a laptop (in this case, a IBM T42 
thinkpad), upon resume the Synaptics touchpad no longer responds to tap 
clicking. 

Version-Release number of selected component (if applicable):
synaptics-0.14.6-7.fc9.src.rpm
xorg-x11-server-1.4.99.901-21.20080407.fc9.src.rpm
kernel-2.6.25-0.218.rc8.git7.fc9.src.rpm

How reproducible:

Always reproducible

Steps to Reproduce:
1. Hibernate to disk
2. Thaw from disk
3. Enter password , check touchpad tap clicking, doesn't work
  
Actual results:

Synaptics touchpad does not respond to tapping commands (tap click)

Expected results:

Synaptics touchpad should respond to tap clicking.
Comment 1 Matěj Cepl 2008-04-28 08:39:13 EDT

*** This bug has been marked as a duplicate of 437609 ***
Comment 2 Axel Thimm 2008-05-21 10:55:57 EDT
(In reply to #bug 437702 comment #1)
> OK, looks like this one was intentional:
> 
> * Mon Mar 10 2008 Adam Jackson <ajax@redhat.com> 0.14.6-4
> - synaptics-0.14.6-tap-to-click.patch: Disable tap to click by default in
>   the name of accessibility.
> 
> I'm not sure this is really a good idea, since this is unexpected behaviour,
> both by upstream documentation as well as shipped documentation (e.g. the patch
> would have had to patch the man pages for example as well).
> 
> Instead it could be something that the gdm login screen could be turning on/off
> along with all the other accessibility items. Also if you really want the
> default to change then do it in teh created xorg.conf, not hardwired in the
> sources where no one will be seraching for this change in behaviour. If F9 ships
> out that way you will get lots of duplicates to this bug report.

OK, so we have 5 reports out of a total of 56 reports of all synaptics bug
reports ever filed. Not the bug raining day, but still a very unpleasant
experience with F9 and tapping.

Fixing it is easy, here is the patch
--- synaptics.spec~	2008-03-28 20:28:10.000000000 +0100
+++ synaptics.spec	2008-04-10 19:45:27.000000000 +0200
@@ -4,3 +4,3 @@
 Version:        0.14.6
-Release:	7%{?dist}
+Release:	8%{?dist}
 Summary:        Synaptics Touchpad Driver
@@ -14,3 +14,2 @@
 Patch1: synaptics-0.14.6-newx.patch
-Patch2: synaptics-0.14.6-tap-to-click.patch
 Patch3: synaptics-0.14.6-poll-delay.patch
@@ -55,3 +54,2 @@
 %endif
-%patch2 -p1 -b .tap
 %patch3 -p1 -b .polldelay
@@ -89,2 +87,5 @@
 %changelog
+* Thu Apr 10 2008 Axel Thimm <Axel.Thimm@ATrpms.net> - 0.14.6-8
+- Reenable tap to click.
+
 * Fri Mar 28 2008 Rex Dieter <rdieter@fedoraproject.org> 0.14.6-7

And for the ones too lazy to rebuild I've placed the fixed synaptics package in
ATrpms' testing area or you can get it directly from

http://atrpms.net/dist/f9/synaptics/

Bought my sanity back.

Note You need to log in before you can comment on or make changes to this bug.