Bug 443048 - GtkLauncher just a script not binary
GtkLauncher just a script not binary
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: WebKit (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
: Reopened
: 443638 444752 501684 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 08:25 EDT by Arkady L. Shane
Modified: 2009-07-11 13:06 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.1.8-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-11 13:06:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GtkLauncher (5.82 KB, application/octet-stream)
2008-04-18 08:25 EDT, Arkady L. Shane
no flags Details

  None (edit)
Description Arkady L. Shane 2008-04-18 08:25:07 EDT
Description of problem:
The Last svn build (r31787) has strange /usr/libexec/WebKit/GtkLauncher file
(see attachment). In older versions of WebKit it was a binary file.
Comment 1 Arkady L. Shane 2008-04-18 08:25:07 EDT
Created attachment 302878 [details]
GtkLauncher
Comment 2 Peter Gordon 2008-04-19 15:36:39 EDT
Ugh...sorry about this. I'm working on a snapshot update to fix some minor
rendering regressions, and I'll fix this while pushing that at the same time. :]
Comment 3 Peter Gordon 2008-04-22 14:06:03 EDT
*** Bug 443638 has been marked as a duplicate of this bug. ***
Comment 4 Mamoru TASAKA 2008-04-30 11:09:58 EDT
*** Bug 444752 has been marked as a duplicate of this bug. ***
Comment 5 Mamoru TASAKA 2008-04-30 11:11:25 EDT
Will be fixed in 1.0.0-0.9.svn32531 and higher
Comment 6 Fedora Update System 2008-04-30 14:10:49 EDT
WebKit-1.0.0-0.9.svn32531.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-04-30 14:12:04 EDT
WebKit-1.0.0-0.9.svn32531.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-05-10 09:57:36 EDT
WebKit-1.0.0-0.9.svn32531.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-05-13 11:31:00 EDT
WebKit-1.0.0-0.9.svn32531.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-07-26 01:57:33 EDT
WebKit-1.0.0-0.9.svn32531.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Edward Sheldrake 2009-05-06 17:29:36 EDT
This bug has re-appeared in webkitgtk-1.1.4-1.fc11, where /usr/libexec/webkitgtk/GtkLauncher is a libtool wrapper script again.
Comment 12 Peter Gordon 2009-05-09 20:09:03 EDT
Ugh, I'll take a look at this again. Thanks. :)
Comment 13 Edward Sheldrake 2009-05-19 16:31:07 EDT
A different way to fix this is to have libtool install the program:

./libtool --mode=install install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
Comment 14 Mamoru TASAKA 2009-05-20 07:17:49 EDT
*** Bug 501684 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2009-05-29 19:57:31 EDT
webkitgtk-1.1.8-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/webkitgtk-1.1.8-1.fc11
Comment 16 Bug Zapper 2009-06-09 05:33:10 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Fedora Update System 2009-06-15 21:48:09 EDT
webkitgtk-1.1.8-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update webkitgtk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6166
Comment 18 Fedora Update System 2009-07-11 13:06:06 EDT
webkitgtk-1.1.8-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.