Bug 443307 - Cannot enter keyboard input into kdm after logout
Cannot enter keyboard input into kdm after logout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
NeedsRetesting
:
: 443699 (view as bug list)
Depends On:
Blocks: KDE4Live
  Show dependency treegraph
 
Reported: 2008-04-20 10:25 EDT by Michael Krauss
Modified: 2008-05-11 23:42 EDT (History)
8 users (show)

See Also:
Fixed In Version: kde-settings-4.0-22.fc9.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 11:26:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Krauss 2008-04-20 10:25:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008041301 Fedora/3.0-0.54.beta5.fc9 Firefox/3.0b5

Description of problem:
It is not possible to login into kdm again after logging out from kde.
Kdm doesn't accept any keystrokes, while interaction by the mouse is still possible.
Workaround: After restarting X server, I can log in again.


Version-Release number of selected component (if applicable):
kdebase-workspace-4.0.3-16.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Log into KDE 
2. Log out from KDE
3. Try to login again

Actual Results:
Kdm didn't accept any keystrokes, so I can't enter my password.

Expected Results:
Kdm should accept input from keyboard.

Additional info:
Comment 1 Rex Dieter 2008-04-20 12:12:12 EDT
I've seen this on occasion too, but only after I suspend->resume my laptop. 
Methinks there's an X bugosity going on here.

Session->Restart X server is a quick-n-dirty workaround.
Comment 2 Rex Dieter 2008-04-20 12:20:04 EDT
This almost certainly isn't kdm at fault here.  At least for me, even
CNTL-ALT-BACKSPACE doesn't work.
Comment 3 Rex Dieter 2008-04-23 15:08:09 EDT
Looking /var/log/kdm.log I see something suspicious:
<stdin>:30:1: error: unterminated #if
no idea if that's bad or where it's coming from though.
Comment 4 Mary Ellen Foster 2008-04-24 07:54:33 EDT
Unfortunately, I see that same line in my kdm.log on Fedora 8. :(
Comment 5 Rex Dieter 2008-05-01 10:03:50 EDT
Including in kdmrc:
TerminateServer=true
(in kde-settings-4.0-22) , until proper fix for bug #443320 comes.
Comment 6 Rex Dieter 2008-05-01 10:17:52 EDT
fixed build available, please test:
http://koji.fedoraproject.org/koji/buildinfo?buildID=47798
Comment 7 Matthias Clasen 2008-05-05 01:43:02 EDT
*** Bug 443699 has been marked as a duplicate of this bug. ***
Comment 8 Will Woods 2008-05-05 11:26:24 EDT
Works just fine in my testing.
Comment 9 John Summerfield 2008-05-11 23:42:31 EDT
I'm thinking the timing of this is bad:
(II) UnloadModule: "evdev"
(II) ImExPS/2 Generic Explorer Mouse: Close
(II) UnloadModule: "evdev"

Note You need to log in before you can comment on or make changes to this bug.