Bug 443860 - Wine crashes or hangs while attempting to reserve DOS space
Wine crashes or hangs while attempting to reserve DOS space
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 433641 443904 446788 447495 (view as bug list)
Depends On: 443552
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 14:47 EDT by Scott Harvanek
Modified: 2008-07-28 18:55 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-28 13:39:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Capture of kernel crash (1.93 KB, text/plain)
2008-05-17 17:07 EDT, Bas Mevissen
no flags Details
kernel crash caused by wine (153.39 KB, image/jpeg)
2008-06-08 06:09 EDT, Jaroslav Sykora
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 114025 None None None Never

  None (edit)
Description Scott Harvanek 2008-04-23 14:47:05 EDT
Description of problem:
When attempting to load any wine program numerous errors of the following occur:

preloader: Warning: failed to reserve range 00000000-60000000
preloader: Warning: failed to reserve range 00000000-60000000
err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please
report
preloader: Warning: failed to reserve range 00000000-60000000
err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please
report
preloader: Warning: failed to reserve range 00000000-60000000

Some programs will not start (winecfg does) and every couple times the machine
will entirely lock up.  At this time this box is current with rawhide.


Version-Release number of selected component (if applicable): wine-0.9.58-1.fc9.i386


How reproducible:
100%


Steps to Reproduce:
1. Run wine <program>.exe
2. Watch log or watch system hang
  
Actual results:
System freeze or program doesn't load whereas it previously did

Expected results:
Working program

Additional info:
This .exe worked just fine under wine on F8 :)
Comment 1 Marcin Łabanowski 2008-04-26 21:00:41 EDT
Same here. It is probably due to change in kernel (I'm running
2.6.25-1.fc9.x86_64). The workaround found in Ubuntu bugzilla[1] helped me. It
is also noted on the Wine Wiki[2]. The workaround is simply:

echo 'vm.mmap_min_addr = 0' >> /etc/sysctl.conf; sysctl -p

Unfortunately, it slightly reduces security - the original value (65536) is said
to prevent some future bugs, but on the other hand, it makes wine unusable. It
is not fixed upstream and it's possible, that it won't be.

[1] https://bugs.launchpad.net/ubuntu/+source/wine/+bug/114025
[2] http://wiki.winehq.org/PreloaderPageZeroProblem
Comment 2 Bug Zapper 2008-05-14 06:01:38 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Andreas Bierfert 2008-05-16 11:37:28 EDT
*** Bug 446788 has been marked as a duplicate of this bug. ***
Comment 4 Bas Mevissen 2008-05-17 17:07:40 EDT
Created attachment 305821 [details]
Capture of kernel crash

Here is a crash dump I captured over the serial console on my box. It is 100%
reproducible here. Box is a rather clean F9 install with Wine installed.
Comment 5 Bas Mevissen 2008-05-17 17:45:12 EDT
The strange thing is that my notebook, with the same software installed, had no
problem with it. 

But on my desktop (where the dump comes from), even setting vm.mmap_min_addr = 0
does not help. Can the severity of this issue been risen? It is a reproducible
system lock-up when doing non-privileged user stuff like starting Wine's notepad
clone. 
Comment 6 Andreas Bierfert 2008-05-21 02:35:35 EDT
*** Bug 443904 has been marked as a duplicate of this bug. ***
Comment 7 Andreas Bierfert 2008-05-21 02:36:17 EDT
*** Bug 447495 has been marked as a duplicate of this bug. ***
Comment 8 Jaroslav Sykora 2008-06-08 06:09:27 EDT
Created attachment 308645 [details]
kernel crash caused by wine

Kernel crash dump and lockup after running wine (without the workaround).
Fedora 8, 2.6.25.4-10.fc8 i686
Comment 9 Jaroslav Sykora 2008-06-08 06:16:09 EDT
This is clearly a *severe* kernel bug because any user can crash the whole
system instantenously. Was it reported upstream to LKML?
Comment 10 Christian Krause 2008-06-08 14:20:58 EDT
(In reply to comment #9)
> This is clearly a *severe* kernel bug because any user can crash the whole
> system instantenously. Was it reported upstream to LKML?

There is a corresponding Bug for the kernel in RH bugzilla: #443552 .


Comment 11 Andreas Bierfert 2008-06-17 05:55:54 EDT
*** Bug 433641 has been marked as a duplicate of this bug. ***
Comment 12 Christian Krause 2008-07-03 04:58:23 EDT
The associated kernel bug #443552 is FIXED now and the problem doesn't happen
anymore.

Most likely this bug can be set to FIXED as well.

Note You need to log in before you can comment on or make changes to this bug.