Bug 443566 - FEAT: Match the new db schema of bz3.0 [#9 TABLE profiles]
FEAT: Match the new db schema of bz3.0 [#9 TABLE profiles]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: XINSUN
Yu Shao
:
: 443562 (view as bug list)
Depends On:
Blocks: hwcert->BZ3_tracker
  Show dependency treegraph
 
Reported: 2008-04-22 04:35 EDT by XINSUN
Modified: 2008-08-04 13:56 EDT (History)
10 users (show)

See Also:
Fixed In Version: 3.2rh-20080801.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 13:56:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch to fix the "delete the refreshed_when " (4.02 KB, patch)
2008-04-22 22:15 EDT, XINSUN
no flags Details | Diff
The patch to fix : 9.1 (refresh_when) and 9.2 (emailflags) (8.64 KB, patch)
2008-04-24 21:57 EDT, XINSUN
no flags Details | Diff
Patch Improve for patching operation. (8.34 KB, patch)
2008-04-25 10:05 EDT, XINSUN
no flags Details | Diff

  None (edit)
Description XINSUN 2008-04-22 04:35:16 EDT
9. Relate to TABLE profiles need to change list below:
   9.1 Delete  the field emailflags from table profiles
       Added :     N/A
       Removed:    FIELD  profiles. emailflags

   9.2 Delete  the field refreshed_when from table profiles
       Added :        N/A
       Removed:    FIELD  profiles. refreshed_when
Comment 1 XINSUN 2008-04-22 22:15:49 EDT
Created attachment 303411 [details]
The patch to fix the "delete the refreshed_when "
Comment 2 Rob Landry 2008-04-23 13:30:34 EDT
Just to verify... the effect here is there are changes in the schema which
impact altering user email preference settings; doing so isn't something that
the catalog supports and thusly this patch simply removes the functions, is that
correct?
Comment 3 XINSUN 2008-04-23 20:19:59 EDT
Rob, :) yes, that is correct, just my thought. Need you and Dave confirm if it
is ok.
Comment 4 XINSUN 2008-04-24 21:57:09 EDT
Created attachment 303720 [details]
The patch to fix : 9.1 (refresh_when) and 9.2 (emailflags)
Comment 5 XINSUN 2008-04-25 01:13:32 EDT
*** Bug 443562 has been marked as a duplicate of this bug. ***
Comment 6 XINSUN 2008-04-25 10:05:48 EDT
Created attachment 303788 [details]
Patch Improve for patching operation. 

Because all the bugs'patch will be patched into one codes tree, 
35a36,51
> @@ -321,14 +300,7 @@
>	       }
>	   }
>      }
> -
> -    $dbh->do(q{UPDATE profiles
> -		     SET refreshed_when = ?
> -		   WHERE userid=?},
> -		undef,
> -		$time,
> -		$id);
> -
> +
>      Bugzilla::DB::UnlockTables() unless $already_locked;
>  }
>

Above codes' process have been moved into bug 433561 's patch

Nicho
Comment 7 XINSUN 2008-04-25 10:07:18 EDT
s/bug 433561/ bug 443561

Sorry. :)
Comment 8 Noura El hawary 2008-04-25 11:02:58 EDT
The patch looks good to me nicho.. regarding the part of the patch that deletes
the email filtering based on the user preferences. I think this shouldn't affect
hwcert as I think it is related to mailing bugs so not doing the email filtering
in hwcert wouldn't annoy anyone I think. otherwise if we will have to replace
this code then it is very complicated and it involves a lot of code changing in
different modules to use the new table email_setting. 

Noura
Comment 9 Noura El hawary 2008-04-27 23:31:59 EDT
Just to confirm my point the Send() function that requires the email filtering
by role only exists in hwcert in the following places:

[root@bugdev hwcert-noura]# grep -r  Send\( .
./Bugzilla/BugMail.pm:sub Send($;$) {
./Bugzilla/Template.pm:                Bugzilla::BugMail::Send($id,
$mailrecipients);

meaning is it not used by hwcert.

Noura
Comment 10 Rob Landry 2008-07-17 17:04:44 EDT
Noura, to confirm, you are happy/otherwise approve this patch does the needed work?
Comment 11 Noura El hawary 2008-07-20 23:20:36 EDT
Hey Rob, Yeah the patch looks good to me.

Noura
Comment 12 eric_liu 2008-08-01 07:35:01 EDT
tested and run good 

Note You need to log in before you can comment on or make changes to this bug.