This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 444392 - make liberation-fonts build from source files
make liberation-fonts build from source files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
https://fedorahosted.org/liberation-f...
: i18n
: 627784 (view as bug list)
Depends On:
Blocks: 440992
  Show dependency treegraph
 
Reported: 2008-04-28 01:52 EDT by Caius Chance
Modified: 2010-08-26 20:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 03:30:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Temporary progress of new source tarball. (2.15 MB, application/x-gzip)
2008-05-01 03:04 EDT, Caius Chance
no flags Details
Pangrams as Test Case. (7.95 KB, application/vnd.oasis.opendocument.text)
2008-05-06 20:22 EDT, Caius Chance
no flags Details
Pangrams as Test Case. (12.94 KB, application/vnd.oasis.opendocument.text)
2008-05-06 21:03 EDT, Caius Chance
no flags Details
Sans test result. (33.45 KB, image/png)
2008-05-06 21:50 EDT, Caius Chance
no flags Details
Serif test result. (33.50 KB, image/png)
2008-05-06 22:02 EDT, Caius Chance
no flags Details
Mono test result. (31.28 KB, image/png)
2008-05-06 22:02 EDT, Caius Chance
no flags Details
PSD (photoshop/gimp format) to testing Sans. (1.02 MB, image/x-psd)
2008-05-07 00:32 EDT, Caius Chance
no flags Details
Sans test result. (33.49 KB, image/png)
2008-05-07 00:33 EDT, Caius Chance
no flags Details
PSD (photoshop/gimp format) to testing Serif. (1.01 MB, image/x-psd)
2008-05-07 00:35 EDT, Caius Chance
no flags Details
Serif test result. (33.58 KB, image/png)
2008-05-07 00:36 EDT, Caius Chance
no flags Details
PSD (photoshop/gimp format) to testing Mono. (1.13 MB, image/x-psd)
2008-05-07 00:36 EDT, Caius Chance
no flags Details
Mono test result. (30.99 KB, image/png)
2008-05-07 00:37 EDT, Caius Chance
no flags Details
Latest pangrams as test case. (125.50 KB, application/msword)
2008-06-03 00:19 EDT, Caius Chance
no flags Details

  None (edit)
Description Caius Chance 2008-04-28 01:52:23 EDT
Description of problem:
Convert liberation-fonts into a open source font project, by means of migration
from TTF to SFD format, rework on the RPM package, host publicly on
fedorahosted.org, etc.

Version-Release number of selected component (if applicable):
liberation-fonts-1.03-1

How reproducible:
N/A

Steps to Reproduce:
N/A
  
Actual results:
N/A

Expected results:
N/A

Additional info:
https://fedorahosted.org/liberation-fonts/
Comment 1 Caius Chance 2008-05-01 03:04:49 EDT
Created attachment 304298 [details]
Temporary progress of new source tarball.

* Wed May 01 2008 Caius Chance <cchance@redhat.com>
- Converted previous TTF files into SFD files to be open source.
- Created fontforge SFD -> TTF scripts.
- Created Makefile.
- Added documentations: AUTHORS, ChangeLog, README.
- Repacked source tarball.
- Released version 1.04.
Comment 2 Caius Chance 2008-05-06 20:22:23 EDT
Created attachment 304705 [details]
Pangrams as Test Case.
Comment 3 Caius Chance 2008-05-06 20:28:20 EDT
Procedures:
1. Screenshots of pangrams in test case odt using all font faces (ver. 1.03).
2. Screenshots of pangrams in test case odt using all font faces (ver. 1.04).
3. Put together by photo editing software.
4. Compare the differences.

Preconditions:
- Anti aliasing is off.
- Hinting is off.
- dpi = 96.
- resolution = 1280 x 1024.

Software used:
- Fedora Rawhide 20080507.
- Latest GIMP.
- Latest oowriter.
Comment 4 Caius Chance 2008-05-06 21:03:38 EDT
Created attachment 304707 [details]
Pangrams as Test Case.

Updated test case.
Comment 5 Caius Chance 2008-05-06 21:50:03 EDT
Created attachment 304711 [details]
Sans test result.

Red color are the 1.04 glyphs. Black color are the 1.03 glyphs.

If there are glyphs of black colors behind red colors which means their
location has differences.
Comment 6 Caius Chance 2008-05-06 22:02:17 EDT
Created attachment 304712 [details]
Serif test result.
Comment 7 Caius Chance 2008-05-06 22:02:39 EDT
Created attachment 304713 [details]
Mono test result.
Comment 8 Caius Chance 2008-05-07 00:32:55 EDT
Created attachment 304719 [details]
PSD (photoshop/gimp format) to testing Sans.

Toggling visibility of layers will help finding out the differences.
Comment 9 Caius Chance 2008-05-07 00:33:53 EDT
Created attachment 304720 [details]
Sans test result.

Motion-blur-like glyphs are the ones having problems.
Comment 10 Caius Chance 2008-05-07 00:35:57 EDT
Created attachment 304721 [details]
PSD (photoshop/gimp format) to testing Serif.
Comment 11 Caius Chance 2008-05-07 00:36:34 EDT
Created attachment 304722 [details]
Serif test result.
Comment 12 Caius Chance 2008-05-07 00:36:56 EDT
Created attachment 304723 [details]
PSD (photoshop/gimp format) to testing Mono.
Comment 13 Caius Chance 2008-05-07 00:37:16 EDT
Created attachment 304724 [details]
Mono test result.
Comment 14 Răzvan Sandu 2008-05-08 02:18:18 EDT
The issue about Romanian incorrectly-generated characters (cedilla-below instead
of comma-below) was recently corrected in bug #13277 at freedesktop.org.

Please see comments #82 and #83, with the appropriate patch:

http://bugs.freedesktop.org/show_bug.cgi?id=13277

Would you please include this correction in Red Hat/Fedora ASAP, since it
affects *thousands* of documents and webpages generated in Romanian language ?

Thanks a lot,
Răzvan
Comment 15 Caius Chance 2008-05-08 02:56:49 EDT
Hi Răzvan,

We are still in the progress of hosting the font correctly on fedorahosted.org.
There were some work needed to be done to ensure the current SFD sources with
minimal differences from the original TTF files that last delivered by the
manufacturer.

Once the hosting process is done, we could start all the patching process.

Sorry for the inconvenience.
Comment 16 Bug Zapper 2008-05-14 06:17:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Caius Chance 2008-05-30 03:30:01 EDT
The fonts is hosted on fedorahosted.org:

https://fedorahosted.org/liberation-fonts/

The latest release of the fonts is available at:

https://fedorahosted.org/liberation-fonts/browser/dist/liberation-fonts-1.04.beta.tar.gz?format=raw
Comment 18 Caius Chance 2008-06-03 00:19:59 EDT
Created attachment 308185 [details]
Latest pangrams as test case.
Comment 19 belerofon 2010-08-26 20:43:08 EDT
*** Bug 627784 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.