Bug 445630 - livecd-creator should refuse to run under enforcing
livecd-creator should refuse to run under enforcing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 429813 (view as bug list)
Depends On:
Blocks: 446972
  Show dependency treegraph
 
Reported: 2008-05-08 00:38 EDT by Jens Petersen
Modified: 2013-01-08 19:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-04 03:17:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-05-08 00:38:53 EDT
Description of problem:
I tried livecd-tools under enforcing again and it actually completely hung my
machine due to conflicting selinux policy being installed for the live image.

Steps to Reproduce:
1. install rawhide (f9) with enforcing
2. run livecd-creator -c live-fedora-desktop.ks
  
Actual results:
2. Gets past glibc-common and hangs machine about 2/3 way through due to some
selinux
policy

Expected results:
2. Barf out or better just plain refuse to run unless Permissive or no selinux.

Additional info:
I heard that pungi does this now.
Comment 1 Bug Zapper 2008-05-14 06:49:01 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jens Petersen 2008-05-20 04:39:22 EDT
(In reply to comment #0)
> I heard that pungi does this now.

Actually it just seems to give out a warning, but that is not
really going far enough I think until the selinux problems are fixed.
Comment 3 Jeremy Katz 2008-05-27 16:25:43 EDT
*** Bug 429813 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2008-05-29 16:33:41 EDT
Patches from eparis on the list, likely to be applied very very soon and then
after some testing will be pushed back for Fedora 9 at least.   
Comment 5 Jeremy Katz 2008-06-09 11:35:33 EDT
The patches have been pushed to git.  Testing on git HEAD would be welcome and
then I'll do an f9-branch to just do a small set of the changes for Fedora 9
Comment 6 Jens Petersen 2008-07-04 03:17:26 EDT
livecd-tools-017.1-1.fc9 looks good (I tested it in rawhide).

Note You need to log in before you can comment on or make changes to this bug.