Bug 446972 - default selinux hangs system while running livecd-creator
default selinux hangs system while running livecd-creator
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On: 429813 445630
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 15:41 EDT by Pedro Silva
Modified: 2013-01-09 23:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.17.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 20:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First warning (3.02 KB, text/plain)
2008-05-16 15:41 EDT, Pedro Silva
no flags Details
Second warning (2.74 KB, text/plain)
2008-05-16 15:43 EDT, Pedro Silva
no flags Details

  None (edit)
Description Pedro Silva 2008-05-16 15:41:59 EDT
Description of problem:

Running with default selinux targeted policies, while running livecd-creator,
the system hangs. The system was running firefox, evolution and the
livecd-creator process.

setroubleshoot warns me a few times during the livecd-creator process. 

livcecd-creator downloads packages, installs them, warnings start and near the
end of install packages the system hangs and I have to reset the machine.

Version-Release number of selected component (if applicable):

selinux-policy-targeted-3.3.1-42.fc9.noarch

How reproducible:

Install fedora 9 using default selinux options.

run: livecd-creator --config=liveusb-f9.ks --fslabel=myfedora
  
Actual results:

System hangs during livecd-creator process, during package install.

Expected results:

livecd-creator process sucessfully finishs.

Additional info:

Attachments contain two selinux warnings registered by selinuxtroubleshooter.
Comment 1 Pedro Silva 2008-05-16 15:41:59 EDT
Created attachment 305733 [details]
First warning
Comment 2 Pedro Silva 2008-05-16 15:43:30 EDT
Created attachment 305735 [details]
Second warning
Comment 3 Daniel Walsh 2008-05-16 16:50:47 EDT
You must put the machine in permissive mode while using livecd creator.  We are
working hard to fix this problem.

Steps to create the livecd

#setenforce 0
livecd_creator ...
#load_policy
#setenforce 1

Sometimes you might require a reboot.
Comment 4 Pedro Silva 2008-05-16 18:36:16 EDT
Thank you for your quick response. I linked this bug wih #429813 since they seem
to be related. I didn't link it to #445630 since I do think that livecd-creator
should work under targeted selinux policies.
Comment 5 Daniel Walsh 2008-07-02 15:35:05 EDT
SELinux policy has been updated to handle this.  A patch has been submitted to
livecd to handle this properly.

Fixed in selinux-policy-3.3.1-72.fc9.noarch
Comment 6 Jeremy Katz 2008-07-02 20:40:48 EDT
livecd-tools for F9 has been pushed and rawhide is in git -- testers from git
appreciated as more indicators to do a rawhide build.  Worst case, I'll be doing
one the end of next week for the alpha freeze

Note You need to log in before you can comment on or make changes to this bug.