Bug 445761 - MacBook4,1 keyboard and trackpad do not work properly
MacBook4,1 keyboard and trackpad do not work properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 445762 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 18:03 EDT by Stewart Adam
Modified: 2008-06-12 22:27 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.25.6-55.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 22:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -nn (2.49 KB, text/plain)
2008-05-14 22:47 EDT, Stewart Adam
no flags Details
lsusb (766 bytes, text/plain)
2008-05-14 22:47 EDT, Stewart Adam
no flags Details

  None (edit)
Description Stewart Adam 2008-05-08 18:03:13 EDT
Description of problem:
appletouch can't recognize trackpad of the MacBook Pro 4,1

Version-Release number of selected component (if applicable):
kernel-2.6.25-14.fc9.x86_64
synaptics-0.14.6-7.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot up
2. /sbin/modprobe appletouch
3. Restart X
  
Actual results:
Appletouch does not recognize touchpad (synaptics doesn't detect a device, no
new input messages in logs)

Expected results:
Touchpad is detected

Additional info:
See bug 426574 - Maybe it's related?
Comment 1 Bug Zapper 2008-05-14 06:52:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Chuck Ebbert 2008-05-14 20:36:44 EDT
The trackpad and keyboard problem are really one bug.
Comment 3 Chuck Ebbert 2008-05-14 20:37:07 EDT
*** Bug 445762 has been marked as a duplicate of this bug. ***
Comment 4 Chuck Ebbert 2008-05-14 20:38:15 EDT
Please post the output of the 'lsusb' and 'lspci -nn' commands.
Comment 5 Stewart Adam 2008-05-14 22:47:16 EDT
Created attachment 305431 [details]
lspci -nn

I did some more research and found this: http://touchd.sourceforge.net/

Looks like the touchpad might need some extra tricks... Either way, here's the
ouput.
Comment 6 Stewart Adam 2008-05-14 22:47:31 EDT
Created attachment 305432 [details]
lsusb
Comment 7 Stewart Adam 2008-05-17 18:33:37 EDT
I got to compiling and running touchd (http://touchd.sourceforge.net/) and it
worked very well. There were a few problems starting it (segfaults) and the cap
locks LED doesn't work once it's running, but I think it's a good starting
point. From what I've read just adding the device IDs won't work for the MacBook
4,1 since the trackpad doesn't work like a synaptic device anymore.
Comment 8 Teguh DC 2008-05-23 17:00:32 EDT
Bug 445762 seem not duplicated Bug 445761, someone in ubuntu forum has solution
for bug 445762 (fn key). https://wiki.ubuntu.com/MacBookPro/Penryn
Comment 9 Stewart Adam 2008-05-23 19:34:02 EDT
I tried getting that to work, 'usbhid' isn't compiled as a module so
unfortunately that specific fix won't work for Fedora but if we can get that
quirk in to usbhid.c then it will work fine.

On the other hand, would missing the ability to control the backlight go under
hal, kernel or gnome-power-manager? If it's the kernel, I have the feeling it's
the same problem as the trackpad/keyboard and we'll just need to add a quirk or
device ID.
Comment 10 Chuck Ebbert 2008-05-27 16:24:38 EDT
(In reply to comment #9)
> I tried getting that to work, 'usbhid' isn't compiled as a module so
> unfortunately that specific fix won't work for Fedora but if we can get that
> quirk in to usbhid.c then it will work fine.

You can add this to the kernel boot options for the MacBook Air:

usbhid.quirks=0x05ac:0x0223:0x00000800,0x05ac:0x0224:0x00004800,0x05ac:0x0225:0x00000800

And this for the MacBook Pro 4,1:

usbhid.quirks=0x05ac:0x0230:0x00000800,0x05ac:0x0231:0x00004800,0x05ac:0x0232:0x00000800
Comment 11 Chuck Ebbert 2008-05-27 16:47:04 EDT
keyboard patches are in kernel-2.6.25.4-34
Comment 12 Chuck Ebbert 2008-05-27 16:49:42 EDT
oops, actually in 2.6.25.4-35
Comment 13 Stewart Adam 2008-05-28 18:15:49 EDT
Perfect, I downloaded the kernel from koji and it works (almost) perfectly.

One thing I noticed is the F5/F6 keys for backlight control still report F5/F6
with fn or without it - Is this also part of the same bug?
Comment 14 Stewart Adam 2008-06-04 19:37:09 EDT
Forgot to mention that F3+F4 (as in the expose and dashboard keys, not the
actual F3+F4 key presses) aren't detected by xev but no setkeycode messages
appears in dmesg either.
Comment 15 Fedora Update System 2008-06-11 21:38:41 EDT
kernel-2.6.25.6-55.fc9 has been submitted as an update for Fedora 9
Comment 16 Fedora Update System 2008-06-12 22:27:00 EDT
kernel-2.6.25.6-55.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.