Bug 466103 - Buttons not positioned properly when using Compiz
Buttons not positioned properly when using Compiz
Status: CLOSED DUPLICATE of bug 446457
Product: Fedora
Classification: Fedora
Component: nodoka-theme-gnome (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2008-10-08 06:54 EDT by Peter Robinson
Modified: 2008-10-24 16:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 16:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot showing theme issues. (132.29 KB, image/png)
2008-10-08 07:05 EDT, Peter Robinson
no flags Details
Another screen shot (114.95 KB, image/png)
2008-10-10 17:07 EDT, Peter Robinson
no flags Details

  None (edit)
Description Peter Robinson 2008-10-08 06:54:52 EDT
I'm seeing some issues with the rendering of the default theme on Fedora 10 beta (and all later updates). There is a screen shot attached which shows the issues. The device is a eeePC 901 with a 1024x600 res screen with intel graphics. Some of the issues include:
- Min/Max/Close buttons a separated
- Clock date/time font too big for panel
- Task text at bottom too big for panel
- Menu text is a much better size but it looks to be top aligned rather than vertically centred.

The text in general seems to be quite large, but that might be me being use to larger res screens. One example is that the ekiga startup config wizard doesn't fit to the screen (nor evolution but its generally massive).
Comment 1 Peter Robinson 2008-10-08 07:05:08 EDT
Created attachment 319742 [details]
screen shot showing theme issues.
Comment 2 Martin Sourada 2008-10-08 09:46:58 EDT
(In reply to comment #0)
> I'm seeing some issues with the rendering of the default theme on Fedora 10
> beta (and all later updates). There is a screen shot attached which shows the
> issues. The device is a eeePC 901 with a 1024x600 res screen with intel
> graphics. Some of the issues include:
> - Min/Max/Close buttons a separated
That might be issue either with metacity theme or metacity itself, try switching to another theme

> - Clock date/time font too big for panel
> - Task text at bottom too big for panel
> - Menu text is a much better size but it looks to be top aligned rather than
> vertically centred.
> 
> The text in general seems to be quite large, but that might be me being use to
> larger res screens. One example is that the ekiga startup config wizard doesn't
> fit to the screen (nor evolution but its generally massive).
All the rest is a problem with too big fonts, set them to smaller size. Is your DPI set correctly? 

Anyway, icons are obviously rendered OK, so this bug (well, it's probably two different bugs) should be filled under different component.
Comment 3 Peter Robinson 2008-10-08 09:53:42 EDT
> > issues. The device is a eeePC 901 with a 1024x600 res screen with intel
> > graphics. Some of the issues include:
> > - Min/Max/Close buttons a separated
> That might be issue either with metacity theme or metacity itself, try
> switching to another theme

Happens with compiz too
 
> > - Clock date/time font too big for panel
> > - Task text at bottom too big for panel
> > - Menu text is a much better size but it looks to be top aligned rather than
> > vertically centred.
> > 
> > The text in general seems to be quite large, but that might be me being use to
> > larger res screens. One example is that the ekiga startup config wizard doesn't
> > fit to the screen (nor evolution but its generally massive).
> All the rest is a problem with too big fonts, set them to smaller size. Is your
> DPI set correctly? 

How would I tell?
 
> Anyway, icons are obviously rendered OK, so this bug (well, it's probably two
> different bugs) should be filled under different component.

What component would that be?
Comment 4 Martin Sourada 2008-10-08 10:48:36 EDT
(In reply to comment #3)
> > > issues. The device is a eeePC 901 with a 1024x600 res screen with intel
> > > graphics. Some of the issues include:
> > > - Min/Max/Close buttons a separated
> > That might be issue either with metacity theme or metacity itself, try
> > switching to another theme
> 
> Happens with compiz too
> 
Well, that would suggest the problem is with nodoka-metacity-theme, but since that haven't changed since F9 and it F9 it works, I am not sure...

> > > - Clock date/time font too big for panel
> > > - Task text at bottom too big for panel
> > > - Menu text is a much better size but it looks to be top aligned rather than
> > > vertically centred.
> > > 
> > > The text in general seems to be quite large, but that might be me being use to
> > > larger res screens. One example is that the ekiga startup config wizard doesn't
> > > fit to the screen (nor evolution but its generally massive).
> > All the rest is a problem with too big fonts, set them to smaller size. Is your
> > DPI set correctly? 
> 
> How would I tell?
Go to System->Preferences->Look and Feel->Appearances, select Fonts tab and click Details at the top there should be Resolution. If that number is incorrect for the screen res (in pixels)/screen real size (in inches) than I'd guess it's a problem with xorg detecting wrongly the size of your display. If it's correct and the font sizes are aroud 10pt (I think that's the default setting) then I guess the default is not optimised for ultra-small screens...

> 
> > Anyway, icons are obviously rendered OK, so this bug (well, it's probably two
> > different bugs) should be filled under different component.
> 
> What component would that be?
Not sure, check the comments above, it might help a little.
Comment 5 Peter Robinson 2008-10-08 11:12:06 EDT
Moving to nodoka-theme-gnome (closest match to nodoka-metacity-theme so presume they're built from same src package) but as a note this eeePC has never had F-9 installed on it, it was clean install from Live-CD to F-10 Alpha, then another clean Live-CD to F-10 Beta.

Will investigate the screen size/res issue too.
Comment 6 Martin Sourada 2008-10-10 16:43:18 EDT
(In reply to comment #5)
> Moving to nodoka-theme-gnome (closest match to nodoka-metacity-theme so presume
> they're built from same src package) but as a note this eeePC has never had F-9
> installed on it, it was clean install from Live-CD to F-10 Alpha, then another
> clean Live-CD to F-10 Beta.
> 
That's the correct match. I've checked the image you attached once again and it seems you have compositing turned on so I guess you have compiz tunred on (unless you tweaked with metacity gconf settings for compositing). Based on my experience with F10 Beta (and F9 as well) I presume the issue is that the nodoka metacity theme is rendered wrong when using compiz instead of metacity for some reason (it's rendered correctly when using metacity, even on F10 beta).

> Will investigate the screen size/res issue too.
Please use another bug for that then (since it's unrelated) ;-)
Comment 7 Peter Robinson 2008-10-10 17:07:06 EDT
Created attachment 320059 [details]
Another screen shot
Comment 8 Peter Robinson 2008-10-10 17:13:48 EDT
Yes, I'm running compiz. Just enabled straight through the Desktop Effects. I've attached another screenshot where the menu fonts have changed size (seems a little random).
Comment 9 Martin Sourada 2008-10-10 18:16:44 EDT
I'm changing the bug description to better fit what this bug is about. Please file another bug (or mention it in fedora-test-list) for the fonts problem, but I guess it might be just that the screen size is too small (and has high DPI) which makes the fonts (as font size is in real-world units, not in pixels) too big (relatively to the screen size).
Comment 10 Thomas J. Baker 2008-10-13 16:24:05 EDT
I've seen compiz render the metacity theme incorrectly and reported the bug https://bugzilla.redhat.com/show_bug.cgi?id=465470 along with one fix (upgrade to compiz 0.7.8).
Comment 11 Adel Gadllah 2008-10-24 16:48:19 EDT

*** This bug has been marked as a duplicate of bug 446457 ***

Note You need to log in before you can comment on or make changes to this bug.