Bug 447035 - Actions fail to show in menus
Actions fail to show in menus
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus-actions (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
: 447611 447876 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 03:01 EDT by Dams
Modified: 2008-05-22 18:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 11:37:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2008-05-17 03:01:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko Galeon/2.0.5

Description of problem:
I've configured 4 actions with nautilus-actions-config and none of them are showing the nautilus menu when I right-click on files that matched the actions rules.

Version-Release number of selected component (if applicable):
nautilus(0:2.22.2-7.fc9).x86_64 nautilus-actions(0:1.4.1-3.fc9).x86_64

How reproducible:
Always


Steps to Reproduce:
1. run nautilus-actions-config
2. Click on Add
3. Give the rule a funny label, and maybe a not-less funny tooltip.
4. As an action path try /bin/rm, and parameters should be %M
5. In the Conditions tab, be sure to have Filenames:* Mimetypes:*/* Match case checked (or not). Check "only files".
6. Validate the action.
7 Right click on a regular file

Actual Results:
The action doesnt show up in the nautilus menu

Expected Results:
You should see the label action in the menu.

Additional info:
Comment 1 Deji Akingunola 2008-05-17 03:14:02 EDT
This is probably due to internal nautilus-2.22 rewrite based on gvfs. I will
look into possible solutions and also check up with upstream.
Comment 2 Deji Akingunola 2008-05-17 11:37:59 EDT
Its actually not so much of nautilus changes, as of my hard-coding configure
options.
Fixed in rawhide and F9 updates.
Comment 3 Fedora Update System 2008-05-17 11:56:44 EDT
nautilus-actions-1.4.1-4.fc9 has been submitted as an update for Fedora 9
Comment 4 Dams 2008-05-17 12:04:37 EDT
Thank you. 

If I understand correctly your commitlog, the nautilus/extensions-1.0 direction
should be empty, shouldnt it ?

[anvil@gruyere ~]# ls /usr/lib64/nautilus/extensions-1.0
libnautilus-actions.so  libnautilus-share.so
[anvil@gruyere ~]# rpm -qf /usr/lib64/nautilus/extensions-1.0/*
nautilus-actions(0:1.4.1-3.fc9).x86_64
nautilus-share(0:0.7.2-12.fc9).x86_64

The nautilus-share is broken too, isnt it ?
Comment 5 Deji Akingunola 2008-05-17 12:14:58 EDT
(In reply to comment #4)
> Thank you. 
> 
> If I understand correctly your commitlog, the nautilus/extensions-1.0 direction
> should be empty, shouldnt it ?
>
Yes. Notice it's also not owned by any package.
 
> [anvil@gruyere ~]# ls /usr/lib64/nautilus/extensions-1.0
> libnautilus-actions.so  libnautilus-share.so
> [anvil@gruyere ~]# rpm -qf /usr/lib64/nautilus/extensions-1.0/*
> nautilus-actions(0:1.4.1-3.fc9).x86_64
> nautilus-share(0:0.7.2-12.fc9).x86_64
> 
> The nautilus-share is broken too, isnt it ?

Yes, I would think so.
Comment 6 Dams 2008-05-17 12:21:25 EDT
I'll fill a bug against it if it's not already opened then.
Comment 7 Deji Akingunola 2008-05-20 17:18:32 EDT
*** Bug 447611 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2008-05-22 16:37:14 EDT
nautilus-actions-1.4.1-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Deji Akingunola 2008-05-22 18:39:15 EDT
*** Bug 447876 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.