Bug 447633 - libvirt with lokkit support SELinux denials
libvirt with lokkit support SELinux denials
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
: 437802 447632 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 17:40 EDT by Alan Pevec
Modified: 2008-06-11 10:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: libvirt-0.4.2-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 13:55:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Pevec 2008-05-20 17:40:12 EDT
Description of problem:
lokkit support doesn't work with SELinux: denied { write } comm="lokkit"
scontext=virtd_t tcontext=etc_t tclass=file for name="iptables" and
name="system-config-firewall" and also denied { read } comm="sh"
name="2.6.25.3-18.fc9.i686" scontext=virtd_t tcontext=modules_object_t tclass=dir

Version-Release number of selected component (if applicable):
libvirt-0.4.2-3.fc9

How reproducible:
always with SELinux enforcing

Steps to Reproduce:
1. yum --enablerepo=updates-testing update libvirt
2. service libvirt restart
3.
  
Actual results:
SELinux denial reports

Expected results:
no denials

Additional info:
Comment 1 Alan Pevec 2008-05-20 17:42:34 EDT
*** Bug 447632 has been marked as a duplicate of this bug. ***
Comment 2 Mark McLoughlin 2008-06-04 13:32:21 EDT
We're going to disable lokkit support again - see bug #449996
Comment 3 Mark McLoughlin 2008-06-04 13:55:50 EDT
Fixed with:

* Wed Jun  4 2008 Mark McLoughlin <markmc@redhat.com> - 0.4.2-4.fc9
- Disable lokkit support again (#449996, #447633)
- Ensure PolicyKit is enabled (#446616)
Comment 4 Fedora Update System 2008-06-04 17:00:57 EDT
libvirt-0.4.2-4.fc9 has been submitted as an update for Fedora 9
Comment 5 Daniel Berrange 2008-06-11 10:48:42 EDT
*** Bug 437802 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.