Bug 448895 - Firefox plugins are not working
Firefox plugins are not working
Status: CLOSED DUPLICATE of bug 437596
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 448896 (view as bug list)
Depends On:
Blocks: ff-pluginfinder
  Show dependency treegraph
 
Reported: 2008-05-29 08:20 EDT by antonio montagnani
Modified: 2008-09-04 10:15 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 10:15:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of firefox (15.41 KB, text/plain)
2008-06-02 13:28 EDT, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2008-05-29 08:20:42 EDT
Description of problem:
Latest release of firefox doesn' see my plugins

Version-Release number of selected component (if applicable):
firefox-3.0-0.60.beta5.fc9.i386

How reproducible:
always

Steps to Reproduce:
1.open for example www.fon.com
2.It says that the flash-plugin is not installed (that is not true..)
3.
  
Actual results:
No plugin is working (about:plugin is empty, but my usr/lib/mozilla/plugins
contains:
gecko-mediaplayer-dvx.so   gecko-mediaplayer-wmp.xpt
gecko-mediaplayer-dvx.xpt  gecko-mediaplayer.xpt
gecko-mediaplayer-qt.so    libflashplayer.so
gecko-mediaplayer-qt.xpt   libjavaplugin.so
gecko-mediaplayer-rm.so    librhythmbox-itms-detection-plugin.so
gecko-mediaplayer-rm.xpt   nphelix.so
gecko-mediaplayer.so	   nphelix.xpt
gecko-mediaplayer-wmp.so   nppdf.so

Expected results:
It should work

Additional info:
Comment 1 Matěj Cepl 2008-05-29 09:34:19 EDT
*** Bug 448896 has been marked as a duplicate of this bug. ***
Comment 2 Matěj Cepl 2008-05-29 09:37:09 EDT
Hi, before we can do anything about this bug we need to get some more
information from you to be able to think about directions for further investigation.

Please, paste here as a comment output of these commands:

yum list installed \*firefox\* \*mozilla\* \*nsplugin\* \*flash\*

also if we can get output of the command

mozilla-plugin-config -l

that would be helpful.

Thank you.
Comment 3 antonio montagnani 2008-05-29 09:46:10 EDT
 yum list installed \*firefox\* \*mozilla\* \*nsplugin\* \*flash\*
Plugin caricati:refresh-packagekit, upgrade-helper
Pacchetti installati
firefox.i386                             3.0-0.60.beta5.fc9     installed       
flash-plugin.i386                        9.0.124.0-release      installed       
libflashsupport.i386                     000-0.5.svn20070904    installed       
mozilla-filesystem.i386                  1.9-2.fc9              installed  

 mozilla-plugin-config -l
bash: mozilla-plugin-config: command not found
[antonio@Casa ~]$ whereis mozilla-plugin-config
mozilla-plugin-config:

I don't know why mozilla-plugin-config is not found....
Comment 4 antonio montagnani 2008-05-29 18:13:56 EDT
I found that mozplugger wan not on the system (disinstalled....maybe, as it had
been working for  along time)
After installation of mozplugger, plugins management seem to be o.k.

Still I don't understand why mozilla-plugin-config is not working...
Comment 5 antonio montagnani 2008-05-30 12:43:28 EDT
I have lost my plugins again after a system-config-display (But I suppose that
it is not connected..); it seems that mozplugger is not properly working...
Comment 6 antonio montagnani 2008-05-30 13:02:41 EDT
And Seamonkey sees all installed plugins: so this definitely a bug of Firefox
Comment 7 antonio montagnani 2008-05-30 15:01:45 EDT
I logged as root (I have only one user and root) and firefox sees all plugins!!!

I am sure that something is wrong as on some websites I am requested for flash
plugin that is installed...
Comment 8 antonio montagnani 2008-05-30 15:59:21 EDT
I deleted .mozilla folder from the user folder and I re-loaded another .mozilla
from another computer, and now it sees all plugins.
Which is the corrupted file?? and why is this file corrupted????
Comment 9 antonio montagnani 2008-05-31 09:15:58 EDT
It happened again!!! I re-installed from a backup copy of pluginreg.dat in
.mozilla/firefox/6tmpgl6r.default folder. Before re-installing I noticed that
file was only 13 kb and the backup copy and working file is 65 kb.
Unfortunately I deleted the corrupted file before re-installing.
I found anyway that there is another pluginreg.dat file in .mozilla folder that
is exactly about 13 kb.
Are they connected???
Comment 10 Matěj Cepl 2008-06-02 08:10:23 EDT
What's the output of the command

mozilla-plugin-config -f -c ; mozilla-plugin-config -l
Comment 11 antonio montagnani 2008-06-02 08:19:50 EDT
 mozilla-plugin-config -f -c ; mozilla-plugin-config -l
bash: mozilla-plugin-config: command not found
bash: mozilla-plugin-config: command not found
[antonio@Casa ~]$ whereis mozilla-plugin-config
mozilla-plugin-config:

I think that I have no mozilla-plugin-config installed on my system.
Comment 12 Matěj Cepl 2008-06-02 13:07:27 EDT
OK, could you try it once more and attach here output of command (run as root):

ausearch -m AVC -ts today

and also output of

getenforce

would be helpful.

Thank you.
Comment 13 Matěj Cepl 2008-06-02 13:10:46 EDT
Also, if you could check the rights settings for your ~/.mozilla? Are you sure,
the problem isn't there? (running in terminal

firefox >firefox-log.txt 2>&1 &

and attaching firefox-log.txt would be helpful (just try to use the plugin, so
that the log file is not excessively long)
Comment 14 antonio montagnani 2008-06-02 13:17:44 EDT
 /sbin/ausearch -m AVC -ts today
<no matches>
 only as root...otherwise I get a message that file is locked..

 /usr/sbin/getenforce
Disabled
(In reply to comment #12)
> OK, could you try it once more and attach here output of command (run as root):
> 
> ausearch -m AVC -ts today
> 
> and also output of
> 
> getenforce
> 
> would be helpful.
> 
> Thank you.

 /sbin/ausearch -m AVC -ts today
<no matches>
 only as root...otherwise I get a message that file is locked..

 /usr/sbin/getenforce
Disabled
Comment 15 antonio montagnani 2008-06-02 13:28:24 EDT
Created attachment 307541 [details]
log of firefox
Comment 16 Stefano Cavallari 2008-06-06 05:53:33 EDT
I tried to run this in order to understand what is going on:

strace -f firefox -e open 2>&1 | grep /usr/lib/mozilla > /tmp/firefox_strace

Firefox now shows all the plugins without changing anything after the strace.
Doesn't make sense.

Anyway someone who still see the bug should try that command. I really hope it
still doesn't work after that.
Comment 17 Jonathan Wakely 2008-06-30 04:12:08 EDT
I see all plugins disappear when my Firefox session is restored after restarting
KDE.  If I "killall firefox" then restart it and choose "restore session" again,
all my plugins are present.

$ yum list installed \*firefox\* \*mozilla\* \*nsplugin\* \*flash\*
Loaded plugins: fedorakmod, priorities
Installed Packages
firefox.x86_64                           3.0-1.fc9              installed
flash-plugin.i386                        9.0.124.0-release      installed
libflashsupport.x86_64                   000-0.5.svn20070904    installed
libflashsupport.i386                     000-0.5.svn20070904    installed
mozilla-filesystem.x86_64                1.9-2.fc9              installed
nspluginwrapper.i386                     0.9.91.5-27.fc9        installed
nspluginwrapper.x86_64                   0.9.91.5-27.fc9        installed


$ mozilla-plugin-config -l
EXCLUDE_WRAP:
libtotem*
libjavaplugin*
gecko-mediaplayer*
mplayerplug-in*
EXCLUDE_LINK:

File/Link /usr/lib/mozilla/plugins-wrapped/libjavaplugin_oji.so
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.libflashplayer.so
  Original plugin:
File/Link /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so
/usr/lib64/mozilla/plugins-wrapped/nswrapper_32_64.libflashplayer.so
  Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so
/usr/lib64/mozilla/plugins-wrapped/nswrapper_32_64.libflashplayer.so
  Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
  Wrapper version string: 0.9.91.5
Comment 18 Timothy Murphy 2008-09-04 07:56:12 EDT
My experience mirrors that described in Comment #17.
If I shutdown Fedora 9 (with KDE-4.0.6) with Firefox-3.0.1 running
so that Firefox starts automatically when I re-boot
then most of the Firefox plugins are not installed.
If I close Firefox and re-start it, the plugins appear.

Incidentally, the only plugin that does appear on re-boot
is Helix, which is also the only plugin in ~/.mozilla/plugins .
The plugins only in /usr/lib/mozilla/plugins do not appear on re-boot.
Comment 19 Matěj Cepl 2008-09-04 09:50:24 EDT
OK, I blame KDE for this and reassigning to people who should know better, what's going on there.
Comment 20 Rex Dieter 2008-09-04 10:15:46 EDT
session management is likely the issue here, since firefox depends on it's app-wrapper, /usr/bin/firefox to set that.  KDE4 restores apps using the full path of the executable.

See also bug #437596 (and similar bug #455975).

marking as dup.

*** This bug has been marked as a duplicate of bug 437596 ***

Note You need to log in before you can comment on or make changes to this bug.