Bug 449735 - Berkeley db4 4.7.25 is released
Berkeley db4 4.7.25 is released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: db4 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
http://www.oracle.com/technology/docu...
:
: 450662 (view as bug list)
Depends On: 449467
Blocks: 449737 449740 449741
  Show dependency treegraph
 
Reported: 2008-06-03 05:47 EDT by Robert Scheck
Modified: 2013-07-02 19:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 06:23:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-06-03 05:47:45 EDT
Description of problem:
Berkeley db4 4.7.25 (stable) was released some time ago and Fedora development 
hangs around the older 4.6.21...

Version-Release number of selected component (if applicable):
db4-4.6.21-5

Actual results:
db4-4.6.21-5

Expected results:
db4-4.7.25-1 or newer ;-)

Additional info:
Simple version bump, removing non-applying/rejected patches followed by a 
rebuild currently fails for me on i386:

cc -c -I. -I../.. -D_GNU_SOURCE -D_REENTRANT -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables
-fno-strict-aliasing ../../mutex/mut_tas.c  -fPIC -DPIC -o .libs/mut_tas.o
../../mutex/mut_tas.c:9:23: error: db_config.h: No such file or directory
../../mutex/mut_tas.c:11:20: error: db_int.h: No such file or directory
Comment 1 Jindrich Novy 2008-06-03 06:28:19 EDT
Yup, I'm aware of the 4.7.25 for a while now. The new packages are prepared, but
fails to build because of the autoconf-2.62, we currently have in rawhide. I'm
in  touch with Stepan Kasal to figure it out.
Comment 2 Jindrich Novy 2008-06-16 03:16:40 EDT
*** Bug 450662 has been marked as a duplicate of this bug. ***
Comment 3 Robert Scheck 2008-06-16 03:38:56 EDT
Ping?
Comment 4 acount closed by user 2008-07-06 05:20:24 EDT
is it ready for fedora 10 ?

-thanks-
Comment 5 Robert Scheck 2008-07-06 15:57:37 EDT
http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/autoconf/current/
SOURCES/autoconf-2.62-fix-multiline-string.patch?revision=195750&view=markup is 
the required fix for autoconf, so please get db4 now into Fedora :)
Comment 6 Robert Scheck 2008-07-06 15:58:13 EDT
See also: http://bugs.gentoo.org/show_bug.cgi?id=217976
Comment 7 Jindrich Novy 2008-07-07 04:17:36 EDT
Great news! I will try to push the autoconf guys to apply the mandriva patch to
have the new db4 in asap.

Thanks!
Comment 8 Jindrich Novy 2008-07-09 06:23:48 EDT
db-4.7.25 is now in rahide

Note You need to log in before you can comment on or make changes to this bug.