Bug 450739 - k3b: dvd burning requires raising limits
k3b: dvd burning requires raising limits
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
: 436961 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 14:59 EDT by Nadav Kavalerchik
Modified: 2014-01-12 19:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 04:36:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadav Kavalerchik 2008-06-10 14:59:58 EDT
Description of problem:
i can not open k3b and burn a DVD directly from the gui (menus)
i have to open a console and issue the command "ulimit -l unlimited"
and then run k3b from the same console and only then i burns DVDs without
a problem.

this is the state of ulimit before i issue the commands:
[root@server ~]# ulimit -a
core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 51058
max locked memory       (kbytes, -l) 32
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 10240
cpu time               (seconds, -t) unlimited
max user processes              (-u) 51058
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited

i hear/read (in forums) it is a setting inside the kernel
is their a way to set it system-wide so i do not have to go into
console for that ?

these are the debug messages it get 
when i try an unsuccessful DVD burn
================================

[root@server ~]# ulimit -l
32
[root@server ~]# ulimit -a
core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 51058
max locked memory       (kbytes, -l) 32
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 10240
cpu time               (seconds, -t) unlimited
max user processes              (-u) 51058
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited
[root@server ~]# k3b
[root@server ~]# (K3bDevice::HalConnection) initializing HAL >= 0.5
Mapping udi /org/freedesktop/Hal/devices/storage_model_CD/DVDW_SH_S182D to devic
e /dev/sr0
/dev/sr0 resolved to /dev/sr0
/dev/sr0 is block device (0)
/dev/sr0 seems to be cdrom
bus: 0, id: 0, lun: 0
(K3bDevice::Device) /dev/sr0: init()
(K3bDevice::Device) /dev/sr0 feature: CD Mastering
(K3bDevice::Device) /dev/sr0 feature: CD Track At Once
(K3bDevice::Device) /dev/sr0 feature: DVD Read (MMC5)
(K3bDevice::Device) /dev/sr0 feature: DVD+R
(K3bDevice::Device) /dev/sr0 feature: DVD+RW
(K3bDevice::Device) /dev/sr0 feature: DVD+R Double Layer
(K3bDevice::Device) /dev/sr0 feature: DVD-R/-RW Write
(K3bDevice::Device) /dev/sr0 feature: Rigid Restricted Overwrite
(K3bDevice::Device) /dev/sr0 feature: Layer Jump Recording
(K3bDevice::Device) /dev/sr0 unknown profile: 2
(K3bDevice::Device) /dev/sr0: dataLen: 60
(K3bDevice::Device) /dev/sr0: checking for TAO
(K3bDevice::Device) /dev/sr0: checking for SAO
(K3bDevice::Device) /dev/sr0: checking for SAO_R96P
(K3bDevice::Device) /dev/sr0: checking for SAO_R96R
(K3bDevice::Device) /dev/sr0: checking for RAW_R16
(K3bDevice::Device) /dev/sr0: checking for RAW_R96P
(K3bDevice::Device) /dev/sr0: checking for RAW_R96R
(K3bDevice::Device) /dev/sr0: GET PERFORMANCE dataLen = 72
(K3bDevice::Device) /dev/sr0: GET PERFORMANCE successful with reported length: 6
8
(K3bDevice::Device) /dev/sr0:  Number of supported write speeds via GET PERFORMA
NCE: 4
(K3bDevice::Device) /dev/sr0 : 22160 KB/s
(K3bDevice::Device) /dev/sr0 : 16620 KB/s
(K3bDevice::Device) /dev/sr0 : 11080 KB/s
(K3bDevice::Device) /dev/sr0 : 5540 KB/s
(K3bDevice::DeviceManager) setting current write speed of device /dev/sr0 to 221
60
Could not resolve /dev/hda
/dev/hda resolved to /dev/hda
(K3bDevice::Device) could not open device /dev/hda for reading
                    (No such file or directory)
could not open device /dev/hda (No such file or directory)
Could not resolve /dev/hdd
/dev/hdd resolved to /dev/hdd
(K3bDevice::Device) could not open device /dev/hdd for reading
                    (No such file or directory)
could not open device /dev/hdd (No such file or directory)
Could not resolve /dev/hdc
/dev/hdc resolved to /dev/hdc
(K3bDevice::Device) could not open device /dev/hdc for reading
                    (No such file or directory)
could not open device /dev/hdc (No such file or directory)
/dev/sr0 resolved to /dev/sr0
(K3bDevice::DeviceManager) dev /dev/sr0 already found
(K3bDevice::DeviceManager) found config entry for devicetype: TSSTcorp CD/DVDW S
H-S182D
First sec data area: 43:41:33 (LBA 196608) (402653184
Last sec data area: 00:00:00 (LBA 0) (0 Bytes)
Last sec layer 1: 00:00:00 (LBA 0) (0 Bytes)
Layer 1 length: 00:00:01 (LBA 1) (2048 Bytes)
Layer 2 length: 00:00:00 (LBA 0) (0 Bytes)
DiskInfo:
Mediatype:       DVD-R Sequential
Current Profile: DVD-R Sequential
Disk state:      empty
Empty:           1
Rewritable:      0
Appendable:      0
Sessions:        0
Tracks:          0
Layers:          1
Capacity:        510:46:46 (LBA 2298496) (4707319808 Bytes)
Remaining size:  510:46:46 (LBA 2298496) (4707319808 Bytes)
Used Size:       00:00:00 (LBA 0) (0 Bytes)
(K3bDevice::Device) /dev/sr0: GET PERFORMANCE dataLen = 72
(K3bDevice::Device) /dev/sr0: GET PERFORMANCE successful with reported length: 6
8
(K3bDevice::Device) /dev/sr0:  Number of supported write speeds via GET PERFORMA
NCE: 4
(K3bDevice::Device) /dev/sr0 : 22160 KB/s
(K3bDevice::Device) /dev/sr0 : 16620 KB/s
(K3bDevice::Device) /dev/sr0 : 11080 KB/s
(K3bDevice::Device) /dev/sr0 : 5540 KB/s
Devices:
------------------------------
Blockdevice:    /dev/sr0
Generic device:
Vendor:         TSSTcorp
Description:    CD/DVDW SH-S182D
Version:        SB04
Write speed:    4200
Profiles:       DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Du
al Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW,
DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW
Read Cap:       DVD-ROM, DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual L
ayer Sequential, DVD-R Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD
-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW
Write Cap:      DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequ
ential, DVD-R Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Seque
ntial, DVD+RW, DVD+R, DVD+R Dual Layer, CD-R, CD-RW
Writing modes:  SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R,
Restricted Overwrite, Layer Jump
Reader aliases: /dev/sr0
------------------------------
[mpeg @ 0x859f04]Could not find codec parameters (Audio: mp2)
QGDict::hashKeyString: Invalid null key
QGDict::hashKeyString: Invalid null key
(K3bDevice::Device) /dev/sr0: GET CONFIGURATION length det failed.
(K3bDevice::Device) /dev/sr0: GET CONFIGURATION length det failed.
(K3bDevice::Device) /dev/sr0: GET CONFIGURATION length det failed.
(K3bDevice::Device) /dev/sr0: GET CONFIGURATION length det failed.
(K3bDevice::Device) /dev/sr0: GET PERFORMANCE dataLen = 72
(K3bDevice::Device) /dev/sr0: GET PERFORMANCE successful with reported length: 6
8
(K3bDevice::Device) /dev/sr0:  Number of supported write speeds via GET PERFORMA
NCE: 4
(K3bDevice::Device) /dev/sr0 : 22160 KB/s
(K3bDevice::Device) /dev/sr0 : 16620 KB/s
(K3bDevice::Device) /dev/sr0 : 11080 KB/s
(K3bDevice::Device) /dev/sr0 : 5540 KB/s
(K3bDevice::HalConnection) lock queued for /org/freedesktop/Hal/devices/storage_
model_CD/DVDW_SH_S182D
(K3bDevice::HalConnection) unlock queued for /org/freedesktop/Hal/devices/storag
e_model_CD/DVDW_SH_S182D
(K3bDevice::ScsiCommand) failed:
                           command:    READ DVD STRUCTURE (ad)
                           errorcode:  70
                           sense key:  NOT READY (2)
                           asc:        3a
                           ascq:       2
(K3bDevice::Device) /dev/sr0: READ DVD STRUCTURE length det failed
(K3bDevice::Device) Unable to read DVD structure for num of layers.
(K3bDevice::ScsiCommand) failed:
                           command:    READ DVD STRUCTURE (ad)
                           errorcode:  70
                           sense key:  NOT READY (2)
                           asc:        3a
                           ascq:       2
(K3bDevice::Device) /dev/sr0: READ DVD STRUCTURE length det failed
(K3bDevice::ScsiCommand) failed:
                           command:    READ TRACK INFORMATION (52)
                           errorcode:  70
                           sense key:  NOT READY (2)
                           asc:        3a
                           ascq:       2
(K3bDevice::Device) /dev/sr0: READ TRACK INFORMATION length det failed.
(K3bDevice::ScsiCommand) failed:
                           command:    READ TRACK INFORMATION (52)
                           errorcode:  70
                           sense key:  NOT READY (2)
                           asc:        3a
                           ascq:       2
(K3bDevice::Device) /dev/sr0: READ TRACK INFORMATION with real length 36 failed.
DiskInfo:
Mediatype:       DVD-R Sequential
Current Profile: DVD-R Sequential
Disk state:      empty
Empty:           1
Rewritable:      0
Appendable:      0
Sessions:        0
Tracks:          0
Layers:          1
Capacity:        00:00:00 (LBA 0) (0 Bytes)
Remaining size:  00:00:00 (LBA 0) (0 Bytes)
Used Size:       00:00:00 (LBA 0) (0 Bytes)
(K3bDevice::Device) /dev/sr0: GET PERFORMANCE dataLen = 24
(K3bDevice::Device) /dev/sr0: GET PERFORMANCE successful with reported length: 2
0
(K3bDevice::Device) /dev/sr0:  Number of supported write speeds via GET PERFORMA
NCE: 1
(K3bDevice::Device) /dev/sr0 : 24930 KB/s
(K3bDevice::Device) /dev/sr0: GET CONFIGURATION length det failed.
(K3bDevice::Device) /dev/sr0: GET CONFIGURATION length det failed.
removing udi /org/freedesktop/Hal/devices/volume_empty_dvd_r

================================



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.insert a blanc DVD
2.open k3b from the system menu
3.choose some iso file and start to burn
  
Actual results:
errors reported in the burn dialog and the DVD is ejected

Expected results:
burn the DVD

Additional info:
kde 3.5.9 , k3b 1.0.4 , fc8 updated.
Comment 1 Nadav Kavalerchik 2008-06-10 15:37:07 EDT
for now, 
i have set these parameters in : /etc/scurity/limits.conf
root soft memlock unlimited
root hard memlock unlimited

which worked around this issue BUT i am not sure what impact it has
on the system ? :-( ?

i have and LTSP server that runs 70 clients and i wonder if i can change these
parameters system-wide ?

so this issue is half closed :-)
Comment 2 Rex Dieter 2008-06-30 10:51:21 EDT
Roman, thoughts here?  I don't have any dvd's handy to test.  Can you confirm? 
Is this a k3b or wodim issue?
Comment 3 Roman Rakus 2008-07-01 04:49:55 EDT
I think it's similar to bug #220481.
Nadav try to:
1) Start K3b
2) Go to Settings->Configure K3b
3) Selete the Advanced tab in the Writing section
4) Activate "Manual writing buffer size" and set it to 4MB
Comment 4 Roman Rakus 2008-07-11 08:02:34 EDT
Now I try to burn DVD-RW. With k3b-1.0.4-5.fc8.x86_64.rpm I get error. When I
activate Manual buffer size and set it to 4MB, DVD is burn. I try to update to
the newest k3b and DVD is also well burn.
The easiest way to solve this problem is to update to the new k3b ;)
Comment 5 Roman Rakus 2008-07-11 08:05:37 EDT
Nadav try new k3b and please give a feedback if problem still persists.
Comment 6 Nadav Kavalerchik 2008-07-12 04:40:47 EDT
i confirm that... updating to latest k3b on fc9 solved this issue :-)

since development of fc8 is no longer active,
 i guess this issue can be considered closed ?
Comment 7 Roman Rakus 2008-07-14 04:36:26 EDT
Definitely. Closing. Because it is already solved, closing not a bug.
Comment 8 Roman Rakus 2008-07-16 07:16:13 EDT
*** Bug 436961 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.