Bug 453399 - Keyboard delay rate is suddenly increased every once in a while
Keyboard delay rate is suddenly increased every once in a while
Status: CLOSED DUPLICATE of bug 445898
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-keyboard (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-30 08:54 EDT by Petr Machata
Modified: 2015-05-04 21:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-21 03:12:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (3.07 KB, text/plain)
2008-06-30 09:33 EDT, Petr Machata
no flags Details
Xorg.0.log (33.32 KB, text/plain)
2008-06-30 09:37 EDT, Petr Machata
no flags Details

  None (edit)
Description Petr Machata 2008-06-30 08:54:20 EDT
Description of problem:
Without any particular reason, X on F-9 sometimes suddenly changes keyboard
behaviour.  Normally, when I press a key, the character pattern is as follows:
  (press) x (delay) xxxxxxxxx (release)
After the spurious change, the behaviour changes to this:
  (press) (delay) xxxxxxxxxxxx (release)
I never manage to press the key just long enough to emit one character, the
minimum I achieved was two.  This leads me to suspicion that two chars are
actually emitted when the repeating pattern occurs.

Control keys (alt, ctrl) behave yet differently.  X server takes time to notice
that the key is held, but then refuses to release it.  Hence as soon as I press
alt, I can not use backspace, otherwise whole X session goes awol, which is a
typical way such sessions end, because I can never quite keep myself from
pressing backspace instinctively.

Mouse is not affected by this problem.

The keyboard is dell-branded SK-8115.

It has never happened to me on F-8.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.4.99.902-3.20080612.fc9.i386
xorg-x11-drv-keyboard-1.3.0-3.fc9.i386

How reproducible:
Not very well.  Today it already happened twice, before that the system was on
for a week without a problem.

Steps to Reproduce:
Sorry, no idea.
  
Additional info:
I'll attach relevant logs in a minute.
I'll try to run xorg.conf-less when it happens next, I don't really need
accented characters for my work.
It seems to me that bug 450249 could be related.
Comment 1 Petr Machata 2008-06-30 09:33:08 EDT
Created attachment 310583 [details]
xorg.conf
Comment 2 Petr Machata 2008-06-30 09:37:13 EDT
Created attachment 310584 [details]
Xorg.0.log
Comment 3 Petr Machata 2008-08-01 05:05:25 EDT
I can confirm that the bug appears also when I run the X server conf-less.

Also the bug has always occurred when I was using the keyboard.  I left the
server idle for 9 days (over the holiday), and I normally leave it idle over the
weekend.  When I came back, the keyboard has always worked.
Comment 4 Petr Machata 2008-08-20 09:02:22 EDT
I can reproduce this behaviour at will by pressing and holding a left shift key for approximately ten seconds.  The same then changes the keyboard back into the "normal" mode.  This seems to be some sort of esoteric feature.
Comment 5 Peter Hutterer 2008-08-21 02:20:05 EDT
can you please cross-check with Bug 445898 and Bug 448604? This sounds like SlowKeys.
Comment 6 Petr Machata 2008-08-21 03:04:44 EDT
445898 seems to be it.
Comment 7 Peter Hutterer 2008-08-21 03:12:54 EDT
Closing as duplicate then.

*** This bug has been marked as a duplicate of bug 445898 ***

Note You need to log in before you can comment on or make changes to this bug.