Bug 453582 - Python script aborted with Modules/gcmodule.c Assertion `gc->gc.gc_refs != 0' error
Python script aborted with Modules/gcmodule.c Assertion `gc->gc.gc_refs != 0'...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-01 09:23 EDT by Takanori MATSUURA
Modified: 2014-01-21 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 01:40:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb output (18.26 KB, text/plain)
2008-07-01 09:23 EDT, Takanori MATSUURA
no flags Details

  None (edit)
Description Takanori MATSUURA 2008-07-01 09:23:49 EDT
+++ This bug was initially created as a clone of Bug #171809 +++

Because bug 171809 has been already closed, I have opened the new one.
Bug 404911, bug 384221 and bug 408341 may dup. of this bug.

When I use pymol program (sorry, it's not a fedora-released package), the
following error occurs.

python: Modules/gcmodule.c:276: visit_decref: Assertion `gc->gc.gc_refs != 0'
failed.

And we can get the same error by using other python-based programs.

The same program works fine if I use home-made python-2.5.2 without applying any
patch in Fedora package.
So I believe this is a Fedora-specific python bug.
Comment 1 Takanori MATSUURA 2008-07-01 09:23:49 EDT
Created attachment 310665 [details]
gdb output
Comment 2 James Antill 2008-07-01 09:37:06 EDT
 As you can see with the other bugs, these types of things are assumed to be
pretty much never python GC bugs (or _lots_ of people would be hitting them).
 If you have a shared object that is being loaded into python, esp. if it's
"unusual" I'd look there first.
 After that, you can try running under valgrind (you need the valgrind changes)
as it's _possible_ some core python .so is doing something bad under a weird
condition ... but I'll note that I've never seen that yet.
Comment 3 Takanori MATSUURA 2008-07-02 01:40:44 EDT
Oops,

The bug has been fixed in the latest trunk of pymol by adding "Py_XINCREF".


Sorry for bugspam.

Note You need to log in before you can comment on or make changes to this bug.