Bug 458428 - [Indic] Firefox displays garbage Indic characters on parts of some English webpages
[Indic] Firefox displays garbage Indic characters on parts of some English we...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 460865 (view as bug list)
Depends On:
Blocks: F10Target 461722
  Show dependency treegraph
 
Reported: 2008-08-08 03:43 EDT by Pravin Satpute
Modified: 2008-12-12 06:12 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-19 00:58:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
image showing bug (179.14 KB, image/png)
2008-08-08 03:43 EDT, Pravin Satpute
no flags Details
when started Firefox 3 in pa_IN locale (28.10 KB, image/png)
2008-09-16 01:28 EDT, Parag Nemade
no flags Details
when started Firefox 3 in gu_IN locale (28.08 KB, image/png)
2008-09-16 01:29 EDT, Parag Nemade
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 455647 None None None Never

  None (edit)
Description Pravin Satpute 2008-08-08 03:43:34 EDT
Created attachment 313788 [details]
image showing bug 

Description of problem:
Firefox shows some garbage devanagari characters in some website. Lets say in 
https://bugzilla.redhat.com/enter_bug.cgi?classification=Fedora
http://en.wikipedia.org/wiki/Firefox
same thing is happening with many website

in some website if we zoom view of firefox it gives proper result and again after zooming out it gives same result


Version-Release number of selected component (if applicable):
firefox-3.0.1-1.fc9.i386

How reproducible:
Everytime

Steps to Reproduce:
1. Change locale to mr_IN
2. start firefox 
3. open following link
http://en.wikipedia.org/wiki/Firefox
https://bugzilla.redhat.com/enter_bug.cgi?classification=Fedora
  
Actual results:
showing some garbage Devanagari characters in English paragraphs

Expected results:
It should not show garbage characters

Additional info:
tried by changing encoding, font but nothing giving different output
Comment 1 Matěj Cepl 2008-09-01 08:04:26 EDT
Tried

LANG=mr_IN firefox

and cannot reproduce here. What do I do wrong?
Comment 2 Pravin Satpute 2008-09-05 02:18:29 EDT
It is still coming
problem looks with rendering side,
since if i increase the size of text(zoom), everything looks nice
can you try by reducing size of view?
is there any dependency firefox has which i have not told you yet??
Comment 3 Parag Nemade 2008-09-12 07:25:49 EDT
I confirm this bug exists with following image
http://paragn.fedorapeople.org/FF3renderingborken.png
Comment 4 Jens Petersen 2008-09-16 00:28:55 EDT
Reproduced for Hindi in rawhide on the fedora page: http://fedoraproject.org/static/firefox/.
Comment 5 Jens Petersen 2008-09-16 01:00:13 EDT
Seems to happen for: bn, gu, hi, mr, ne, pa, ta,

but not for: kn, ml, or, si, te, mai (or th)
Comment 6 Parag Nemade 2008-09-16 01:09:46 EDT
yes bug exists for bn, gu, hi, mr, pa, ta Indic locales in rawhide
also exists for bn_BD locale.

I can see English text for http://fedoraproject.org/static/firefox/ only after I keep zooming in. Otherwise default text appeared in mix like for locale in which firefox started and English alphabets.
Comment 7 Parag Nemade 2008-09-16 01:28:25 EDT
Created attachment 316808 [details]
when started Firefox 3 in pa_IN locale
Comment 8 Parag Nemade 2008-09-16 01:29:33 EDT
Created attachment 316809 [details]
when started Firefox 3 in gu_IN locale
Comment 9 Parag Nemade 2008-09-16 01:31:32 EDT
As written in firefox-mozconfig firefox builds in rawhide are not using system cairo
as_add_options --disable-system-cairo
Comment 10 Jens Petersen 2008-09-16 21:25:00 EDT
*** Bug 460865 has been marked as a duplicate of this bug. ***
Comment 11 Matěj Cepl 2008-09-19 00:58:57 EDT
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=455647) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 12 Martin Stransky 2008-12-12 06:12:28 EST
*** Bug 460865 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.