Bug 460865 - [Indic] garbage Indic characters appearing instead of ascii
[Indic] garbage Indic characters appearing instead of ascii
Status: CLOSED DUPLICATE of bug 458428
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
: i18n, MoveUpstream, Reopened
Depends On:
Blocks: 461722
  Show dependency treegraph
 
Reported: 2008-09-02 03:14 EDT by A S Alam
Modified: 2013-07-02 20:50 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 06:12:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Firefox broken Rendering (107.09 KB, image/jpeg)
2008-09-02 03:14 EDT, A S Alam
no flags Details
Fedora docs page (107.48 KB, image/jpeg)
2008-09-02 03:21 EDT, A S Alam
no flags Details
fedora docs page in Hindi (hi_IN) locale (104.92 KB, image/jpeg)
2008-09-02 03:22 EDT, A S Alam
no flags Details
Illustration of the problem from IRC (32.73 KB, image/png)
2008-09-12 08:49 EDT, Matěj Cepl
no flags Details

  None (edit)
Description A S Alam 2008-09-02 03:14:33 EDT
Created attachment 315503 [details]
Firefox broken Rendering

Description of problem: 
while using firefox with certain web-page, English text is broken and shown Character in locale presently system has. I have Punjabi (pa_IN) default and Firefox is showing character in Punjabi with those locale. Screenshot with Yellow line "showing" Punjabi Unicode Characters, which are "NOT Junk". Those Website has only English contents

I have following website with problem:
http://bugzilla.redhat.com/
http://docs.fedoraproject.org/release-notes/
(not it is not limited to those only, other website also have problem, while not all)

While http://www.bbc.co.uk/ is working fine

Version-Release number of selected component (if applicable):
firefox-3.0.1-1.fc10.i386
pango-1.21.5-1.fc10.i386
cairo-1.7.4-1.fc10.i386


How reproducible:
90%

Steps to Reproduce:
1. Login to Punjabi Locale (pa_IN)
2. start firefox
3. open website http://docs.fedoraproject.org/release-notes/
  
Actual results:
All content should be in English as per website language

Expected results:
some characters in few lines are shown in non-english locale

Additional info:
1) if you copy-paste content in Text Editor, then it is in English.
2) other language (hi-IN) also tested and have same problem exist
Comment 1 A S Alam 2008-09-02 03:21:53 EDT
Created attachment 315504 [details]
Fedora docs page
Comment 2 A S Alam 2008-09-02 03:22:28 EDT
Created attachment 315505 [details]
fedora docs page in Hindi (hi_IN) locale
Comment 3 A S Alam 2008-09-02 03:23:09 EDT
Note: all those websites working fine (without problem) in English locale (en_US)
Comment 4 A S Alam 2008-09-02 03:29:36 EDT
Note 2: While download upstream version (localized in pa-IN locale) and run with those website, Result are bug-free
firefox-3.0.1.tar.bz2
Comment 5 Tony Fu 2008-09-09 23:06:56 EDT
requested by Jens Petersen (#27995)
Comment 6 Matěj Cepl 2008-09-12 08:49:13 EDT
Created attachment 316568 [details]
Illustration of the problem from IRC
Comment 8 Behdad Esfahbod 2008-09-14 16:35:52 EDT
I have a guess here.  I'm thinking that this is only happening when Firefox is compiled with system cairo.  If that's the case, search the firefox layout code for a commented pango_cairo_font_get_scaled_font().  Uncommenting that line may fix it.  That's my wild guess anyway.
Comment 9 A S Alam 2008-09-15 06:40:10 EDT
(In reply to comment #4)
> Note 2: While download upstream version (localized in pa-IN locale) and run
> with those website, Result are bug-free
> firefox-3.0.1.tar.bz2
it is not true (bug is there) , still find bug while use update package on fedora.
Comment 10 Matěj Cepl 2008-09-16 08:05:58 EDT
Is this duplicate of bug 458428?
Comment 11 Jens Petersen 2008-09-16 21:25:00 EDT
yes

*** This bug has been marked as a duplicate of bug 458428 ***
Comment 12 Parag Nemade 2008-11-10 06:47:15 EST
can we have this bug fixed in new xulrunner package built for F9 and F10 updates?
SRPM is available at http://paragn.fedorapeople.org/firefox-3.0.x/xulrunner-1.9.0.2-6.fc10.src.rpm

I did koji scratch build also but not sure why it failed for x86_64 arch.
http://koji.fedoraproject.org/koji/taskinfo?taskID=924216
Comment 13 Jens Petersen 2008-11-10 23:00:21 EST
Yes it would be very good to have this patch for fedora.
Comment 14 Bug Zapper 2008-11-25 21:56:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Martin Stransky 2008-12-12 06:12:28 EST

*** This bug has been marked as a duplicate of bug 458428 ***

Note You need to log in before you can comment on or make changes to this bug.