Bug 461722 - [RHEL5] [Indic] garbage Indic characters appearing instead of ascii
[RHEL5] [Indic] garbage Indic characters appearing instead of ascii
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
: i18n
Depends On: 458428 460865
Blocks: 462316
  Show dependency treegraph
 
Reported: 2008-09-10 03:36 EDT by A S Alam
Modified: 2013-07-02 20:50 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 07:32:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of reproduction (67.83 KB, image/png)
2008-09-23 06:23 EDT, Matěj Cepl
no flags Details
Patch is available from upstream. (2.40 KB, patch)
2008-10-30 05:58 EDT, Martin Stransky
no flags Details | Diff
updated patch for 3.0.4 (1.61 KB, patch)
2008-11-10 06:47 EST, Martin Stransky
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 455647 None None None Never

  None (edit)
Description A S Alam 2008-09-10 03:36:22 EDT
+++ This bug was initially created as a clone of Bug #460865 +++

Created an attachment (id=315503)
Firefox broken Rendering

Description of problem: 
while using firefox with certain web-page, English text is broken and shown Character in locale presently system has. I have Punjabi (pa_IN) default and Firefox is showing character in Punjabi with those locale. Screenshot with Yellow line "showing" Punjabi Unicode Characters, which are "NOT Junk". Those Website has only English contents

I have following website with problem:
http://bugzilla.redhat.com/
http://docs.fedoraproject.org/release-notes/
(not it is not limited to those only, other website also have problem, while not all)

While http://www.bbc.co.uk/ is working fine

Version-Release number of selected component (if applicable):
firefox-3.0.1-1.fc10.i386
pango-1.21.5-1.fc10.i386
cairo-1.7.4-1.fc10.i386


How reproducible:
90%

Steps to Reproduce:
1. Login to Punjabi Locale (pa_IN)
2. start firefox
3. open website http://docs.fedoraproject.org/release-notes/
  
Actual results:
All content should be in English as per website language

Expected results:
some characters in few lines are shown in non-english locale

Additional info:
1) if you copy-paste content in Text Editor, then it is in English.
2) other language (hi-IN) also tested and have same problem exist

--- Additional comment from aalam@redhat.com on 2008-09-02 03:21:53 EDT ---

Created an attachment (id=315504)
Fedora docs page

--- Additional comment from aalam@redhat.com on 2008-09-02 03:22:28 EDT ---

Created an attachment (id=315505)
fedora docs page in Hindi (hi_IN) locale

--- Additional comment from aalam@redhat.com on 2008-09-02 03:23:09 EDT ---

Note: all those websites working fine (without problem) in English locale (en_US)

--- Additional comment from aalam@redhat.com on 2008-09-02 03:29:36 EDT ---

Note 2: While download upstream version (localized in pa-IN locale) and run with those website, Result are bug-free
firefox-3.0.1.tar.bz2

--- Additional comment from tfu@redhat.com on 2008-09-09 23:06:56 EDT ---

requested by Jens Petersen (#27995)

--------------

RHEL5.3
firefox-3.0.2-2.el5
xulrunner-1.9.0.2-4.el5
yelp-2.16.0-21.el5
Comment 1 Lawrence Lim 2008-09-12 02:39:41 EDT
Please confirm if there's any issue with en_US locale.
Comment 2 A S Alam 2008-09-12 02:54:36 EDT
there is no such issue if locale is en_US
Comment 3 Matěj Cepl 2008-09-12 05:08:16 EDT
It is weird, cannot reproduce neither with LANG={zh_CN,cs_CZ,hi_IN} firefox. Probably I haven't installed proper non-European fonts, which packages should I install to reproduce this?
Comment 4 A S Alam 2008-09-12 05:42:02 EDT
Package is fonts-hindi 
and Please try to login with Hindi Environment for Gnome Desktop (firefox interface will be Hindi hi_IN)
Comment 6 Parag Nemade 2008-09-15 07:13:37 EDT
I am unable to reproduce this bug in rawhide with firefox-3.0.1-1.fc10 build
installed.
I actually tried to update EL5 system to firefox-3.0.1-1.el5 but somehow got
dependency problems so unable to test firefox-3.0.1-1.el5 build on EL5 system.
And latest build firefox-3.0.2-2.el5 is giving above described problem.
Comment 7 Parag Nemade 2008-09-16 01:15:59 EDT
Ok. I got this bug successfully reproduced in rawhide when I start firefox in Indic locales  bn, gu, hi, mr, pa, ta 
so bug started existing from I guess firefox-3.0-1 build
Comment 8 Parag Nemade 2008-09-16 01:32:03 EDT
As written in firefox-mozconfig firefox builds in EL5 are not using system cairo
as_add_options --disable-system-cairo
Comment 10 Matěj Cepl 2008-09-19 13:31:46 EDT
Attached screenshots to RHEL4 bug, although they were done with RHEL5.
attachment 317212 [details] -- firefox illustrating non-reproducing
attachment 317215 [details] -- screenshot in hindi-logged in kvm session
Comment 11 Matěj Cepl 2008-09-22 11:15:03 EDT
Guys, help me to reproduce this, please? I just cannot reproduce this. I tried
even logging with hi_IN in login, all gedit and other Gnome programs are in
Hindi (I suppose), but http://docs.fedoraproject.org/release-notes/ still looks
good for me. I have installed fonts-hindi and yet I cannot reproduce it -- see
the attached screenshot in the above comment.
Comment 12 Jens Petersen 2008-09-23 04:46:06 EDT
Matej, can you try <http://fedoraproject.org/static/firefox/>?
I found it easy to reproduce on Fedora with that.
Comment 13 Matěj Cepl 2008-09-23 06:23:49 EDT
Created attachment 317461 [details]
screenshot of reproduction

Yup, that's much better! Thanks
Comment 14 Martin Stransky 2008-10-30 05:58:52 EDT
Created attachment 321902 [details]
Patch is available from upstream.
Comment 15 Parag Nemade 2008-11-10 04:54:27 EST
For me above patch does not working on 3.0.2 source. Bug is still present for 3.0.x branch. But its fixed in upstream for 3.1 branch. Can we have above patch backported to 3.0.x release?
Comment 16 Parag Nemade 2008-11-10 06:11:38 EST
Thanks Martin, I got upstream patch working now. Test rpms are available at http://paragn.fedorapeople.org/firefox-3.0.x/
Comment 17 Martin Stransky 2008-11-10 06:47:00 EST
Created attachment 323059 [details]
updated patch for 3.0.4

There's an updated patch for 3.0.4 - i tested it and works fine in firefox 3.0.4.
Comment 23 RHEL Product and Program Management 2009-01-27 15:43:37 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 24 Martin Stransky 2009-02-05 07:32:37 EST
Should be fixed now by 3.0.6.

Note You need to log in before you can comment on or make changes to this bug.