Bug 458914 - dolphin . opening Documents folder
dolphin . opening Documents folder
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 03:08 EDT by Jithin Emmanuel
Modified: 2008-10-09 10:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 17:46:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 169016 None None None Never

  None (edit)
Description Jithin Emmanuel 2008-08-13 03:08:53 EDT
Description of problem:
dolphin . opens /home/user/Documents directory regardless of where you issue the command. and dolphin .. opens home directory. I deally dolphin . should have opened current working directory

Version-Release number of selected component (if applicable):
1.2

How reproducible:


Steps to Reproduce:
1.in terminal type dolphin .
2.
3.
  
Actual results:
opens /home/user/Documents directory

Expected results:
should have opened current directory

Additional info:
http://bugs.kde.org/show_bug.cgi?id=169016
Comment 1 Johan Cwiklinski 2008-08-13 05:13:31 EDT
Since Fedora 9 Dolphin is now part of kdebase, its no longer packaged separately.
Comment 2 Jithin Emmanuel 2008-08-13 23:36:05 EDT
Is there any temporary fix to this problem?
Comment 3 Johan Cwiklinski 2008-08-13 23:48:16 EDT
I could not reproduce your problem with the latest kdebase (4.1.0-1) from updates-testing.

Maybe you should consider upgrading to kde 4.1, or wait for its inclusion in stable updates.
Comment 4 Jithin Emmanuel 2008-08-14 00:11:43 EDT
My kdebase is also 4.1.0-9.fc9. I also use kde 4.1 from updates testing
Also in my kick off menu system->file manager use to open HOME but now its opening HOME/Documents
Comment 5 Jithin Emmanuel 2008-08-14 01:07:05 EDT
I did an update in kdelibs,kdegames and oxygen-icon-theme from testing just now and now its working correctly. I dont know what did the trick.
But file manager from system menu is still opening Documents. Is this the actual behaviour? I remember it opening Home folder before.
Comment 6 Steven M. Parrish 2008-08-14 19:56:19 EDT
Yes File Manager does default to opening the documents folder.  There a (RFE) filed requesting we add Home to the top level menu.  See https://bugzilla.redhat.com/show_bug.cgi?id=457756  We also discussed this during a recent KDE SiG meeting and you can find the minutes of that meeting here. https://fedoraproject.org/w/uploads/a/a2/Kde-sig-2008-08-05.txt

For now will close this bug as working
Comment 7 Jithin Emmanuel 2008-08-23 00:57:26 EDT
The problem exists. Now I can tell you how exactly to reproduce it.

If there is any open dolphin windows dolphin . will open Documents folder irrespective of where the command is issued/.
Comment 8 Steven M. Parrish 2008-09-25 19:21:08 EDT
Rex, Kevin is this a real issue we need to address or is it as I believe working normally?
Comment 9 Kevin Kofler 2008-09-25 23:54:14 EDT
I can reproduce is. The important part for reproducing this bug is "If there is any open dolphin windows" - Dolphin must be already running for it to misbehave this way.
Comment 10 Steven M. Parrish 2008-09-28 17:07:50 EDT
Thanks for the report.  I checked upstream and could not find a matching bug.Please file a bug report in the the upstream bugzilla located at http://bugs.kde.org for the particular component involved.

Once you've filed your bug report to the upstream bugzilla, please add the upstream info to this report. We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.
Comment 11 Jithin Emmanuel 2008-09-29 00:12:27 EDT
Actually I filed this bug there. At that time I didnt know how to reproduce and they closed it. Now I reopened it.

https://bugs.kde.org/show_bug.cgi?id=169016
Comment 12 Steven M. Parrish 2008-09-29 17:46:52 EDT

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 13 Kevin Kofler 2008-10-09 10:25:12 EDT
*** Bug 466266 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.