Bug 460261 - Evolution filters using imap
Evolution filters using imap
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 03:19 EDT by Frank Murphy
Modified: 2008-09-03 05:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: evolution-data-server-2.22.3-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 05:33:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Receiving Options (51.69 KB, image/png)
2008-08-27 04:47 EDT, Frank Murphy
no flags Details
Bugzilla msg in inbox (268.63 KB, image/png)
2008-08-27 04:48 EDT, Frank Murphy
no flags Details
email headers full (2.84 KB, text/plain)
2008-08-27 10:33 EDT, Frank Murphy
no flags Details
Syslog-Snip (1.56 KB, text/plain)
2008-08-28 05:02 EDT, Frank Murphy
no flags Details
Partial filter-log (4.05 KB, text/plain)
2008-08-30 07:17 EDT, Frank Murphy
no flags Details
Junk Screenshot (57.87 KB, image/png)
2008-09-01 11:45 EDT, Frank Murphy
no flags Details
Evo-Just after fetching (255.33 KB, image/png)
2008-09-01 15:22 EDT, Frank Murphy
no flags Details
filters_xml (8.95 KB, text/xml)
2008-09-02 06:35 EDT, Frank Murphy
no flags Details

  None (edit)
Description Frank Murphy 2008-08-27 03:19:17 EDT
Description of problem:
Filters don't work consistently, inbox has to be highlighted "apply filter(s)"
Gmail Imap.


Version-Release number of selected component (if applicable):
evolution-2.12.3-5.fc8
evolution-data-server-1.12.3-6.fc8
evolution-webcal-2.12.0-1.fc8
evolution-remove-duplicates-0.0.3-1.fc8


How reproducible:
Always

Steps to Reproduce:
1. Gmail imap
2. Create Folder
3. Create Filter
  
Actual results:
No filtering

Expected results:
Filtering

Additional info:  
Bug 247779   -  [RHEL5.2] Evolution message filters on imap folders only work sometimes
Comment 1 Milan Crha 2008-08-27 04:02:22 EDT
Are you able to reproduce this reliably, please? I really would like to see this fixed, but I was not able to reproduce it myself. Can we check some basic things, please:
a) In account preferences, on tab Receiving Options is an option "Apply filters to new messages in INBOX on this server" checked.
b) on tab "IMAP Headers" you've chosen which option?
c) how does your filter look like?
Comment 2 Frank Murphy 2008-08-27 04:47:00 EDT
Created attachment 315072 [details]
Receiving Options
Comment 3 Frank Murphy 2008-08-27 04:48:26 EDT
Created attachment 315073 [details]
Bugzilla msg in inbox

This shows your "needinfo" in the inbox, whereas it shoyuld be in Bugzilla folder.
Comment 4 Frank Murphy 2008-08-27 04:52:35 EDT
(In reply to comment #1)
> Are you able to reproduce this reliably, please? I really would like to see
> this fixed, but I was not able to reproduce it myself. Can we check some basic
> things, please:
> a) In account preferences, on tab Receiving Options is an option "Apply filters
> to new messages in INBOX on this server" checked.

Took screenshots

> b) on tab "IMAP Headers" you've chosen which option?

Basic and Mailing List

> c) how does your filter look like?

Screenshot
Comment 5 Matthew Barnes 2008-08-27 09:29:44 EDT
(In reply to comment #3)
That particular example is a bad one, since <bugzilla@redhat.com> isn't a mailing list.  You'd be better off matching on "Sender" for that one.

What about the other filter rules I see listed.  Are those also broken?
Comment 6 Frank Murphy 2008-08-27 09:52:32 EDT
(In reply to comment #5)
> (In reply to comment #3)
> That particular example is a bad one, since <bugzilla@redhat.com> isn't a
> mailing list.  You'd be better off matching on "Sender" for that one.

Looking at this, will revisit filters, and substite sender\receipent etcc.
see if still broken.

> 
> What about the other filter rules I see listed.  Are those also broken?

as bugzilla filter wasn't the best,
will take  this revening to re-visit filters and ammend,
to either include\exclude. as possible cause.
Comment 7 Frank Murphy 2008-08-27 10:33:27 EDT
Created attachment 315104 [details]
email headers full

Finished quicket than thought.

Filter is: mailing list is ilug at linux.ie
Comment 8 Frank Murphy 2008-08-27 10:39:40 EDT
from commnet above
bugzilla email still in inbox, despite (now) sender as filter.
Comment 9 Frank Murphy 2008-08-28 03:26:35 EDT
Have now tested, with imap full headers, no difference.
Custom header filters etc..

But have come across these gnome bugzillas in googling.
http://bugzilla.gnome.org/show_bug.cgi?id=368417
http://bugzilla.gnome.org/show_bug.cgi?id=444503
Comment 10 Milan Crha 2008-08-28 03:46:47 EDT
Thanks for your investigation. I'm so sorry I didn't recall before, but there is some hidden way to look what are the filters doing. You can turn this on as is described here:
http://www.go-evolution.org/FAQ#How_can_I_see_what_my_filters_are_doing.3F

Maybe, there will be shown whether are filters invoked on new mail and why it failed or anything regarding the issue.
Comment 11 Frank Murphy 2008-08-28 05:02:12 EDT
Created attachment 315189 [details]
Syslog-Snip

yum install gconf-editor
Not allowing me change keys

syslog.snip
Comment 12 Frank Murphy 2008-08-28 05:51:02 EDT
Have just done a backup of evolution,
restored to F9 laptop. (no gconf-editor problems)
But still filters not working.
Comment 13 Frank Murphy 2008-08-30 07:17:20 EDT
Created attachment 315421 [details]
Partial filter-log

filter are only logged when filters manually applied. F8 box. logif from F8 box

No manual filtering on F9, no loggin, and no auto-filtering


So little mails filtered, as in the interim, have started to use thunderbird, with no filtering problems.

But would prefer working evo.
Comment 14 Milan Crha 2008-09-01 10:59:11 EDT
Can you paste here also the settings of Edit->Preferences->Mail Preferences->Tab Junk, I would like to reproduce it with your settings and I suspect that the junk filter reported success or something, which had the result of stopping other rules to apply to the message. But I want to check it. Thanks in advance.
Comment 15 Frank Murphy 2008-09-01 11:45:30 EDT
Created attachment 315486 [details]
Junk Screenshot
Comment 16 Milan Crha 2008-09-01 13:07:50 EDT
Thanks. The bad thing is it seems like working fine for me with the 2.12.3. What I did:
Edit->Mesage filters, added simple rule (the second) to incoming messages: sender contains "milan", then I sent myself message form account with this enabled and it works. The other possible thing, I can think of (and I'm at the end of thoughts), is that some other rule forced to stop processing before the expected rule became processed. What does happen if you move the bugzilla rule to the top? (I guess the bugzilla rule is quite similar to that mine, but for you it doesn't work.)
Comment 17 Frank Murphy 2008-09-01 15:10:18 EDT
Have put the bugzilla rule to top of list,
will see where this comment ends up.
Based on Sender = bugzilla@r.dh.t.com
Comment 18 Frank Murphy 2008-09-01 15:22:50 EDT
Created attachment 315491 [details]
Evo-Just after fetching

Captured message untouched as yet.
In inbox.
Am thinking it's just one of those things,
Same problem on the F9 with 2.23? I think.
Last thought is have you a gmail you can imap from, in case it's a gmail\evo thing.
Comment 19 Milan Crha 2008-09-02 06:30:07 EDT
2.23 is in F10. And I'm tried yesterday with 2.12 on F8, but also on actual trunk of Evolution (2.23.91). Both seemed to work fine, but let it run for some time, will see. I doubt a bit it's only gmail's IMAP, but I can try.
Comment 20 Frank Murphy 2008-09-02 06:35:09 EDT
Created attachment 315523 [details]
filters_xml

added this in case it's doing anything funny here.
Comment 21 Milan Crha 2008-09-02 09:44:32 EDT
I see you use "sender is" in "Fedora-Bugzilla", can you try to change this to "sender *contains*"? maybe the "is" checking is too strict?
Comment 22 Frank Murphy 2008-09-02 11:06:50 EDT
set to contains now.
also installed evo*-debuginfo, ya never know.
Comment 23 Frank Murphy 2008-09-02 11:18:53 EDT
Still the same:

but this if from the cli:

/usr/bin/evolution
CalDAV Eplugin starting up ...
** (evolution:4152): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:4152): DEBUG: mailto URL program: evolution
get frankly3d@gmail.com imap://frankly3d%40gmail.com@imap.gmail.com:993/
Find Items 0
creating
fff


That's all she said
Comment 24 Milan Crha 2008-09-02 13:02:26 EDT
That "fff" is from the mail notification, when it creates the icon in notification area, or something very close to it, if I recall correctly.

I've got the idea, maybe you are really right, that could be caused with GMail's IMAP implementation, or more precise, with their mail server. The 2.12 runs filtering only on \Recent messages, which is IMAP flag on the message with a meaning "you are first seeing this message" (or something like that). It has also flag \Seen, which you can set/unset when marking message read/unread. These two flags are independent. In case GMail is resetting the \Recent flag, then Evolution 2.12 will not filter messages at all. In 2.22 and now on the IMAP filters all messages new for the instance, thus it would work fine regardless the \Recent flag.

The question is, are your filter rules ignored fully or they sometimes apply automatically and sometimes not? (I do not count when you hit Ctrl+Y, which applies filters manually on selected messages in actual folder.)

Probably "the best" thing would be to update to Fedora 9 and try version 2.22.
Comment 25 Milan Crha 2008-09-02 13:16:17 EDT
I tried with my GMail account accessing through IMAP, sending myself the message and even I saw that first time, it isn't marked as \Recent, which explains all the issues you are seeing.
Comment 26 Frank Murphy 2008-09-03 05:08:04 EDT
Tested on a rawhide install (different Box) filters worked even thought Inbox had read msgs.

Can I u\g Evo on the F8 without doing full F9 due to
https://bugzilla.redhat.com/show_bug.cgi?id=442250

Leftie here.
Comment 27 Milan Crha 2008-09-03 05:33:50 EDT
Evolution is heavily tight to the gtk+/glib/gnome version. It would be easier to compile evolution-data-server from the source package on your machine, with added patch from upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=324804#c37
but it has been slightly modified, the actual version could be seen on
http://svn.gnome.org/viewvc/evolution-data-server?view=revision&revision=8469

I'm closing this as current release, but we can discuss further, I'm fine with that. Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.