Bug 461660 - Problems entering 8-bit characters in emacs
Problems entering 8-bit characters in emacs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
: 474442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 15:05 EDT by Kjartan Maraas
Modified: 2009-09-21 07:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 07:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2008-09-09 15:05:00 EDT
Description of problem:

When I try to enter various chars with accents and other things they all fail in emacs from rawhide. éǎčä and so on all give a message that the character is undefined like for example:

<dead-acute> is undefined

I've tried ed, vi, gvim, gedit and many other apps and none of them show this problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Pawel Salek 2008-11-05 18:07:12 EST
I believe the accented characters in general are not the problem - I can directly type in emacs characters on my Swedish keyboard, äö and so on. It is the handling of dead keys that does not work. I need to use them in order to insert characters like ã and so on.
Comment 2 Kjartan Maraas 2008-11-06 07:12:17 EST
Yeah, this is the same for me. I can type norwegian characters like æøå but not áǎ etc for which I need to use key combos like alt+shift\+<letter>
Comment 4 Bug Zapper 2008-11-25 22:00:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Rafael Ávila de Espíndola 2008-12-04 09:23:18 EST
*** Bug 474442 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Novotny 2008-12-17 09:11:25 EST
the same also with Czech characters like Č, I will analyze this...
Comment 7 Edgar Hoch 2009-02-03 19:59:41 EST
I have the same problem with dead keys in german keyboard layout, but also in USA international keyboard layout with dead keys.

The emacs package is emacs-22.2-5.fc9.x86_64 on Fedora 10 - with a fresh Fedora 10 installation (no upgrade), and all current updates installed.
I use gnome, locale is de_DE.UTF-8. Scim is off.
Other applications don't have this problem.
I hope that I remember right that in Fedora 9 the dead keys worked fine with emacs.

Has anyone an idea what the reason may be (why are the dead key undefined) and how to solve it?
Comment 8 Kjartan Maraas 2009-04-29 05:56:11 EDT
Still seeing this in today's rawhide.
Comment 9 Kjartan Maraas 2009-04-29 10:46:27 EDT
Got this fixed now with Ray's help and suggestion in bug 462438. Defaults cruft left over from earlier upgrades which probably would have been fixed with a clean install.
Comment 10 Edgar Hoch 2009-04-29 11:58:20 EDT
Kjartan, is this fixed for you for a clean rawhide (Fedora 11 Preview) installation, or for F10 or F9?
Comment 11 Kjartan Maraas 2009-04-29 13:46:48 EDT
It's fixed for me on a current rawhide system after fixing the gdm defaults for the norwegian bokmål locale according to the above mentioned bug. Haven't got a chance to test a clean install or f9/f10 at the moment.
Comment 12 Pawel Salek 2009-04-30 01:36:11 EDT
I have cleaned up the gconf tree on F10 the suggestion from bug 462438 but this did not help xterm or emacs.
Comment 13 Jyrki Tikka 2009-05-14 17:10:36 EDT
adding

(require 'iso-transl)

to your ~/.emacs file will fix this problem. This does not mean that something is not seriously broken.
Comment 14 Kjartan Maraas 2009-06-02 16:06:35 EDT
Pawel, did you log out and back in before trying again? Maybe some stuff was cached by the daemon? It's working here for both xterm and emacs and I don't get the locale warning when starting xterm from gnome-terminal any more.
Comment 15 Pawel Salek 2009-06-02 16:32:33 EDT
I have rebooted several times, too. Still no go. I can however confirm that loading iso-transl fixes the problem for emacs.
Comment 16 Daniel Novotny 2009-09-21 07:57:08 EDT
this works in F11 and rawhide, after Emacs update to 23.1

Note You need to log in before you can comment on or make changes to this bug.