Bug 462160 - session is never active
session is never active
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 453436 462286 462287 (view as bug list)
Depends On:
Blocks: F10Beta/F10BetaBlocker
  Show dependency treegraph
 
Reported: 2008-09-13 01:49 EDT by Sean Middleditch
Modified: 2015-01-14 18:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 10:59:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Middleditch 2008-09-13 01:49:27 EDT
ConsoleKit always thinks my session is not active.  As system policy requires that only the active session can perform certain useful functions (like turning off the computer), this is a major problem.

ConsoleKit-0.3.0-1.fc10.x86_64
gdm-2.23.92-3.fc10.x86_64
gnome-session-2.23.92-1.fc10.x86_64
kernel-2.6.27-0.312.rc5.git7.fc10.x86_64
kernel-2.6.27-0.323.rc6.fc10.x86_64
PolicyKit-0.9-2.fc10.x86_64
udev-127-1.fc10.x86_64

elanthis@localhost:~$ ck-list-sessions 
Session2:
	unix-user = '500'
	realname = 'Sean Middleditch'
	seat = 'Seat3'
	session-type = ''
	active = FALSE
	x11-display = ':0'
	x11-display-device = ''
	display-device = ''
	remote-host-name = ''
	is-local = TRUE
	on-since = '2008-09-13T05:30:59.469783Z'
	login-session-id = '1'

I'm logging in using GDM.  When trying to shutdown with GDM or from the Panel, I get the following message (this one specifically is from the Panel):
Sep 13 01:48:19 localhost gnome-session[2923]: WARNING: Unable to stop system: Not privileged for action: org.freedesktop.consolekit.system.stop no
Comment 1 Ray Strode [halfline] 2008-09-15 09:57:31 EDT
This should be fixed in gdm-2.23.92-4.fc10
Comment 2 Ray Strode [halfline] 2008-09-15 10:39:06 EDT
*** Bug 462287 has been marked as a duplicate of this bug. ***
Comment 3 Ray Strode [halfline] 2008-09-15 10:39:44 EDT
*** Bug 462286 has been marked as a duplicate of this bug. ***
Comment 4 Pierre Ossman 2008-09-15 11:51:37 EDT
Confirmed working with latest update.
Comment 5 Matthias Clasen 2008-09-16 13:02:21 EDT
*** Bug 453436 has been marked as a duplicate of this bug. ***
Comment 6 Jens Petersen 2008-09-16 20:44:39 EDT
Looks good to me too (tested with gdm-2.23.92-6.fc10).
Comment 7 Sean Middleditch 2008-09-16 22:43:29 EDT
indeed, fixed for me too.  thank you!
Comment 8 Matthias Clasen 2008-09-17 10:59:19 EDT
Lets close this then

Note You need to log in before you can comment on or make changes to this bug.