Bug 463103 - NFS and URL method fail in starting
NFS and URL method fail in starting
Status: CLOSED DUPLICATE of bug 462786
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-21 15:45 EDT by Kazunori Asayama
Modified: 2008-09-22 01:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-22 01:20:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazunori Asayama 2008-09-21 15:45:47 EDT
Description of problem:

NFS installation crashes just after entering the server name and the path name.

The 'URL' installation method also ends up the same result after retrieving install.img.

Version-Release number of selected component (if applicable):

anaconda-11.4.1.38-1

How reproducible:

Every time.

Steps to Reproduce:
1. Start installer with 'askmethod'.
2. Choose language and keyboard.
3. Select installation method 'NFS directory'.
4. Configure TCP/IP with:
   Enable IPv4 Support with DHCP
   Disable IPv6 Support
6. Enter the NFS server and the directory.

  
Actual results:

The installer crashes with the message below:

Running anaconda 11.4.1.38, the Fedora system installer - please wait...
04:27:08 Starting graphical installation...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 857, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 335, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 66, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 252, in __init__
    if isys.isDeviceDHCP(dev):
  File "/usr/lib/anaconda/isys.py", line 930, in isDeviceDHCP
    ip4_setting = settings['ipv4']
KeyError: 'ipv4'
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0 LOOP_CLR_FD failed: 6
        /proc done
        /dev/pts done
        /sys done
        /mnt/stage2 done
        /selinux done
you may safely reboot your system

Expected results:

The installer proceeds.

Additional info:
Comment 1 Kazunori Asayama 2008-09-21 16:00:31 EDT
Hmm... is this problem the same as Bug 462786 ?
Comment 2 Kazunori Asayama 2008-09-21 16:09:02 EDT
The Bug 462592 also seems to be the same...
Comment 3 Jens Petersen 2008-09-22 01:20:51 EDT

*** This bug has been marked as a duplicate of bug 462786 ***

Note You need to log in before you can comment on or make changes to this bug.