Bug 462957 - [LTC 6.0 FEAT] 201598:FCP - HBA API followup for upstream
[LTC 6.0 FEAT] 201598:FCP - HBA API followup for upstream
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.0
Assigned To: Jan Zeleny
Ben Levenson
: FutureFeature
: 468256 (view as bug list)
Depends On:
Blocks: 356741 425967 554559
  Show dependency treegraph
 
Reported: 2008-09-19 17:50 EDT by IBM Bug Proxy
Modified: 2010-11-10 15:12 EST (History)
9 users (show)

See Also:
Fixed In Version: libhbaapi-2.2-8.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:12:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-19 17:50:48 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:20 EDT
1. Feature Overview:
Feature Id:	[201598]
a. Name of Feature:	FCP - HBA API followup for upstream
b. Feature Description
This item comprises a rework of the existing HBA API library and kernel functions such that:
a) The new library fits into the common libHBAAPI approach as a vendor specific library
b) The kernel functions are reworked to allow easier integration into upstream kernels.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Both
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	lib-zfcp-hbaapi-2.0

3. Business Case
Enablement of system management applications to use zFCP infrastructure. The result is improved
usability of the zFCP infrastructure.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):

Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-01 15:37:49 EDT
Do you have a pointer to the code?
Comment 2 IBM Bug Proxy 2009-02-04 23:50:40 EST
(In reply to comment #6)
> Do you have a pointer to the code?
>

Yes: http://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi-2.0.html
Comment 3 IBM Bug Proxy 2009-03-02 08:50:30 EST
package from upstream, no code to attach to feature BZ
Comment 4 Mike Christie 2009-03-18 12:37:12 EDT
IBM,

How does
http://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi-2.0.html 

match up with the sourcefroge hbaapi wrapper and the linux hbaapi lib here:
http://www.open-fc.org/openfc/gitweb/?p=openfc/libhbalinux.git;a=summary

We have requests to add these to fedora 11/RHEL6 already. Here are the fedora11 requests:

https://bugzilla.redhat.com/show_bug.cgi?id=489929
https://bugzilla.redhat.com/show_bug.cgi?id=489962


It looks like http://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi-2.0.html  has a different hbaapi.h. Did you guys do that because you had issues in the past with the sourceforge one or is it just the same file but cleaned up?

Will http://www.open-fc.org/openfc/gitweb/?p=openfc/libhbalinux.git;a=summary work for you guys? It is supposed to be a common linux lib when it is done.

Does your lib have advantages or disadvantages?
Comment 5 Mike Christie 2009-03-18 12:39:29 EDT
Adding   Jan Zeleny because they are handling the packages referenced in comment #4.
Comment 6 IBM Bug Proxy 2009-03-19 04:40:41 EDT
------- Comment From sven.schuetz@de.ibm.com 2009-03-19 04:31 EDT-------
Hi,
to your questions. HBA API consists of two parts:
1.The "wrapper" or "common" library. That is the one from
http://sourceforge.net/projects/hbaapi which is requested in the first bugzilla.
https://bugzilla.redhat.com/show_bug.cgi?id=489929

2. The so called vendor library, which is the actual implementation.
That's the one the open-fc guys requested in the second bugzilla.
https://bugzilla.redhat.com/show_bug.cgi?id=489962

Our library is a vendor library just like in 2.
http://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi-2.0.html
It just contains a version of hbaapi.h in case the wrapper/common library is not present. During the configure stage you can chose if the wrapper is present (hbaapi.h from our package is not needed) or if the wrapper is not present (hbaapi.h from our package will be needed).

For your question if the open-fc approach will work for us:
In theory or in the future, yes. Today, no. If everything would be perfect, we could use one approach where we have one library which uses standard interfaces. Today, both the open-fc and our approach are to a little extend platform specific. They use some PCI libraries to get certain information which are not available on System z. We use some system z specifics which are not present on other platforms.
The functionality both libraries offer is the roughly the same.

My suggestion would be:

As the wrapper library is designed to have multiple vendor libraries living together on one system, let's include both - the wrapper library and both of the vendor libraries - theirs and ours. They can coexist nicely. For future releases we should try to merge our approaches so that we only have one vendor library left  (that would mean to eliminate platform specifics in the current approaches). I will get in contact with the open-fc guys to bring that forward.
Comment 7 Siddharth Nagar 2009-06-04 16:34:23 EDT
*** Bug 468256 has been marked as a duplicate of this bug. ***
Comment 8 Jan Zeleny 2009-10-02 03:02:51 EDT
HBA API has been included in Fedora 11 and 12, should be present in RHEL6 beta. Changing status to MODIFIED.
Comment 9 releng-rhel@redhat.com 2009-10-29 09:44:04 EDT
Fixed in 'libhbaapi-2.2-8.el6', included in compose 'RHEL6.0-20091028.0'.
Moving to ON_QA.
Comment 10 IBM Bug Proxy 2010-06-17 17:01:21 EDT
------- Comment From mgrf@de.ibm.com 2010-06-17 16:50 EDT-------
This feature is verified on R6 snapshots
Set feature to "verified"  Thx
Comment 11 releng-rhel@redhat.com 2010-11-10 15:12:56 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.