Bug 463409 - ks=http://... installs hangs on "waiting for hardware to initialize"
ks=http://... installs hangs on "waiting for hardware to initialize"
Status: CLOSED DUPLICATE of bug 462083
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 464310 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-23 04:26 EDT by Hans de Goede
Modified: 2008-10-02 01:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 01:12:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-09-23 04:26:10 EDT
Sorry dcantrell, I don't want to be the bearer of bad news.

While trying to do a kickstart install using anaconda 11.4.1.38 this morning
with the ks.cfg file on a local http server, loader would hang at the "waiting for hardware to initialize ..." message.

The funny thing is I can do a normal install with install.img and all the packages on that same webserver just fine (using the default dhcp settings), so this seems to be something specific to the kickstart path (where the network gets brought up earlier).

I'll try to catch you on irc between 21:00 - 22:00 tonight, so thats between 9:00 - 10:00 for you, in case you need me to run any tests to pin this down.
Comment 1 Hans de Goede 2008-09-23 04:27:19 EDT
p.s.

I've been using the same ks setup with 11.4.1.32 and their it works fine, so this is a regression which happened between 11.4.1.32 and 11.4.1.38
Comment 2 Chris Lumens 2008-09-23 10:00:36 EDT
"Waiting for hardware to initialize" is all udevsettle running.  Are there any messages on tty4 indicating the kernel's waiting on something to happen?  I have installs get hung up from time to time when a USB key is plugged into a certain port.  They just sit there waiting, with the kernel spewing messages on tty4.  Once the USB key is removed, everything proceeds.  You could be seeing something similar.
Comment 3 Hans de Goede 2008-09-23 10:25:17 EDT
Ok, I just tried this again, there are interesting messages on tty3, esp. the last one:
INFO: getting kickstart file
INFO: only have one network device: eth0
INFO: sending dhcp request through device eth0
ERROR: failed to start NetworkManager (6)
Comment 4 Hans de Goede 2008-09-27 14:30:11 EDT
*** Bug 464310 has been marked as a duplicate of this bug. ***
Comment 5 Alexandre Oliva 2008-10-02 01:12:08 EDT

*** This bug has been marked as a duplicate of bug 462083 ***

Note You need to log in before you can comment on or make changes to this bug.