Bug 464795 - Graphical error during install.
Graphical error during install.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 465497 465632 470925 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 11:06 EDT by Jóhann B. Guðmundsson
Modified: 2009-12-18 01:27 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:27:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"LCD Shoot" (524.33 KB, image/jpeg)
2008-09-30 11:06 EDT, Jóhann B. Guðmundsson
no flags Details
Anaconda.log (1.90 KB, text/plain)
2008-09-30 11:07 EDT, Jóhann B. Guðmundsson
no flags Details
X.log (24.72 KB, text/plain)
2008-09-30 11:07 EDT, Jóhann B. Guðmundsson
no flags Details
Dmesg output (15.01 KB, text/plain)
2008-10-02 08:03 EDT, Jóhann B. Guðmundsson
no flags Details
Phone "LCD shoot" (366.87 KB, image/jpeg)
2008-11-05 04:28 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2008-09-30 11:06:23 EDT
Created attachment 318084 [details]
"LCD Shoot"

Description of problem:

Picture says more then thousand words..

Version-Release number of selected component (if applicable):

Fedora-10-Beta-i386-DVD.iso
( Anaconda 11.4.1.40 )

How reproducible:

Always

Steps to Reproduce:
1. Insert the DVD and begin install
2.
3.
  
Actual results:

See picture

Expected results:

Perfection but I guess that will never be achieved..

But that does not stop one from trying.

Additional info:

Bypass this by adding kernel parameter nomodeset
Comment 1 Jóhann B. Guðmundsson 2008-09-30 11:07:02 EDT
Created attachment 318085 [details]
Anaconda.log
Comment 2 Jóhann B. Guðmundsson 2008-09-30 11:07:31 EDT
Created attachment 318086 [details]
X.log
Comment 4 Hans de Goede 2008-10-01 10:31:42 EDT
Johan,

Thanks for reporting this issue.

I'm pretty sure this is the new mode setting code acting up.

Can you please try another install and then at the initial screen where you can choose between install / memtest / local boot, press <tab> and then add " nomodeset" at the end of the cmdline? Thanks!

If that works please also try to boot the installed system, chances are things will go boom when booting too. In that case when grub starts press <a> and then again add " nomodeset" at the end of the cmdline.

Thanks!
Comment 5 Jóhann B. Guðmundsson 2008-10-01 13:49:20 EDT
Welcome to Red Hat Hans.

Now if you take very close look at the "Additional info:"
field in the bug report you notes a line that says this

"Bypass this by adding kernel parameter nomodeset" 

Which indeed I did :) 

Unfortunately that did not result in fireworks or a big boom
( which I would have loved to experience.. )
even thou the Dell Inspiron 6000 is notorious for bursting into flames.

Now what I would do is to take a close look at this 

(II) RADEON(0): Panel Size from BIOS: 1680x1050 <-- ;) 
( wonder why the ati gets this )

Afaik the highest resolution for this laptop is 1600x1200. 

Thou i am by a mile any expert on this issue..
Comment 6 Hans de Goede 2008-10-01 16:02:19 EDT
Thans (for the welcome) 

Oops, I missed that additional info blurb. Still what you are exactly trying to say is not clear to me. So you tried with nomodeset and then it works normally, or you tried with nomodeset and then it still does not work?

If / once you've managed to install F-10 beta (use a text mode install if necessary) does X work in the installed system? I'm pretty sure X / the kernel mode setting is to blame, but I would like to get some confirmation that the installed system behaves the same before reassigning this to X / kernel.
Comment 7 Jóhann B. Guðmundsson 2008-10-01 18:19:27 EDT
After I added the kernel parameter nomodeset to grub at install time
I was able to install and made 4 successful installs in a row.

X works on the installed systems if I have the nomodeset parameter 

If I dont add nomodeset after an successful install the system will 
freeze at firstboot.
Comment 8 Hans de Goede 2008-10-02 05:06:57 EDT
OK, so this definitely is a modeset bug, changing component to kernel and adding airlied to the CC (although I think he gets the kernel bug mails too).
Comment 9 Matěj Cepl 2008-10-02 07:17:29 EDT
I think that /var/log/dmesg could be useful.
Comment 10 Jóhann B. Guðmundsson 2008-10-02 08:03:37 EDT
Created attachment 319216 [details]
Dmesg output
Comment 11 Jóhann B. Guðmundsson 2008-10-02 08:04:52 EDT
If I'm not shooting in the dark here... 

[drm] Panel Size 1680x1050 <--- Should be 1600x1200
Comment 12 Jóhann B. Guðmundsson 2008-10-02 09:29:37 EDT
If I boot/install normally as in without setting nomodeset and force resolution=1600x1200 it centres the install window but
it's not fully stretched and btw the mouse pointer is visible and not limited 
inside the now centred menu widget as in I can move the "pointer over the darkness" to the left and right edge of the monitor and top and bottom.
Comment 13 Chris Lumens 2008-10-03 11:58:02 EDT
*** Bug 465497 has been marked as a duplicate of this bug. ***
Comment 14 Hans de Goede 2008-10-05 13:52:44 EDT
*** Bug 465632 has been marked as a duplicate of this bug. ***
Comment 15 Pepijn Schmitz 2008-10-05 14:07:39 EDT
In various comments above the correct resolution is said to be "1600x1200". Surely this laptop has a 16:10 (widescreen) panel and the correct resolution should be "1920x1200"? Unless there are different versions of the Dell Inspiron 6000, which I have and am experiencing this exact same problem on. I'll try if "nomodeset" works for me.
Comment 16 Pepijn Schmitz 2008-10-05 14:19:46 EDT
I had already tried adding resolution=1920x1200 to the installer command line, by the way, but that made no difference in my case.
Comment 17 Jóhann B. Guðmundsson 2008-10-05 17:40:30 EDT
Last time I checked my LCD was UXGA 1600x1200...

Do you have the Mobile Intel® 915GM/PM/GMS chip?

I'm a little curious about the 1920x1200 res you have on your laptop
afaik the max panel display resolution of this chipset
is 1600x1200 so either you must be using another chipset or just got scammed by Dell

Plus last friday it did an f10-beta installation on my T61p which
has Nvidia quadro card and a resolution of 1920x1200 and anaconda did not 
fully stretch on that one so I'm starting to think we are hitting more than one bug....
Comment 18 Pepijn Schmitz 2008-10-05 18:50:30 EDT
No, I have an ATI Mobility Radeon X300 chipset, and so do you, according to the X.log file you attached... :-)

Also, 1600x1200 is a 4:3 ratio, and while Wikipedia (http://en.wikipedia.org/wiki/Dell_Inspiron#Inspiron_6000) says there were indeed different versions of the Inspiron 6000 they all had widescreen panels.

I suspect that you have a version of the Inspiron 6000 that has the ATI chipset and a panel with a native resolution of 1680 x 1050 (which was one of the available resolutions according to Wikipedia). Perhaps 1600x1200 refers to the maximum resolution at which the chipset can drive an external display. Could this be the case?

Furthermore, I checked my dmesg output, and it has the line:

[drm] Panel Size 1920x1200

So I think it's likely that the kernel isn't misidentifying the panel size after all, and the bug is elsewhere...
Comment 19 Pepijn Schmitz 2008-10-05 18:53:24 EDT
I checked whether nomodeset made a difference, and it does. I can install Fedora 10 Beta if I specify that on the kernel command line for the installation, and for the first boot. After that I can boot successfully whether or not I include it, although if I do, the text mode consoles use a tiny font (but they do use the entire screen).
Comment 20 Jóhann B. Guðmundsson 2008-10-21 03:37:28 EDT
**Snapshot 2***

Anaconda is correctly filled in the display which it did not last time.

Font is off along with X freezes.

Booting with nomodeset i'm able to install without 
X to freeze.
Comment 21 Jóhann B. Guðmundsson 2008-11-05 04:28:27 EST
Created attachment 322552 [details]
Phone "LCD shoot"

Still an issue with preview...
Comment 22 Jóhann B. Guðmundsson 2008-11-05 04:40:42 EST
While performing that install Anaconda froze while installing packages...

Testing now with nomodeset
Comment 23 Jóhann B. Guðmundsson 2008-11-05 05:14:46 EST
Manage to install without an freeze with nomodeset set but 
the display remains "not fully stretched"
Comment 24 Jóhann B. Guðmundsson 2008-11-05 06:26:13 EST
Hum I have a potential idea on what might be causing this Freeze when 
not using the nomodeset kp and I think it is the screen-lock or the screen-saver
in X.

Is there any reason that this *feature* is in the installer?

I suggest removing it.. 
It makes no sense to have this in a installer.
Comment 25 Chris Lumens 2008-11-11 10:49:50 EST
*** Bug 470925 has been marked as a duplicate of this bug. ***
Comment 26 Bug Zapper 2008-11-25 22:17:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 27 Jerome Glisse 2009-08-14 06:17:49 EDT
Does it works any better with fedora 11 ?
Comment 28 Jóhann B. Guðmundsson 2009-08-14 06:53:42 EDT
Nope the same issue was in F11 installer atleast for both my laptops ( radeon/nouveou )
Comment 29 Bug Zapper 2009-11-18 03:26:50 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 30 Bug Zapper 2009-12-18 01:27:24 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.