Bug 465641 - Cannot run Gnome-do in Fedora 10 rawhide
Cannot run Gnome-do in Fedora 10 rawhide
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gnome-do (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
:
: 477995 480336 (view as bug list)
Depends On: 463211
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-04 23:03 EDT by Mario Chacon
Modified: 2009-01-16 12:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 17:18:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Chacon 2008-10-04 23:03:31 EDT
Description of problem:
I cannot run gnome-d

Version-Release number of selected component (if applicable):


How reproducible:
Run gnome-do

Steps to Reproduce:
1. Run gnome-do
2.
3.
  
Actual results:
Add-in could not be loaded: The required addin 'Do.Core,1.0' is not installed.
Mono.Addins.MissingDependencyException: The required addin 'Do.Core,1.0' is not installed.
  at Mono.Addins.AddinSessionService.ResolveLoadDependencies (System.Collections.ArrayList addins, System.Collections.Stack depCheck, System.String id, Boolean optional) [0x00000] 
  at Mono.Addins.AddinSessionService.ResolveLoadDependencies (System.Collections.ArrayList addins, System.Collections.Stack depCheck, System.String id, Boolean optional) [0x00000] 

Unhandled Exception: System.InvalidOperationException: Extension node not found in path: /Do/ItemSource
  at Mono.Addins.ExtensionContext.AddExtensionNodeHandler (System.String path, Mono.Addins.ExtensionNodeEventHandler handler) [0x00000] 
  at Mono.Addins.AddinManager.AddExtensionNodeHandler (System.String path, Mono.Addins.ExtensionNodeEventHandler handler) [0x00000] 
  at Do.Core.PluginManager.Initialize () [0x00000] 
  at Do.Do.Main (System.String[] args) [0x00000] 


Expected results:


Additional info:
Comment 1 Mario Chacon 2008-10-08 23:19:45 EDT
Hi!.
Can i do something to fix it?
Comment 2 Sindre Pedersen Bjørdal 2008-10-09 04:38:26 EDT
This issue is well known and will be fixed by me updating gnome-do to the latest versin (0.6.1.0). I am working on this and it will be ready soon.
Comment 3 Will Woods 2008-10-10 13:50:23 EDT
gnome-do 0.6.1.0 depends on a new package (notify-sharp) review.
Comment 4 Mario Chacon 2008-10-16 10:31:37 EDT
I downloaded the latest version 0.6.1.0 and when i try to run it i get this error:

Add-in could not be loaded: The required addin 'Do.Core,1.0' is not installed.
Mono.Addins.MissingDependencyException: The required addin 'Do.Core,1.0' is not installed.
  at Mono.Addins.AddinSessionService.ResolveLoadDependencies (System.Collections.ArrayList addins, System.Collections.Stack depCheck, System.String id, Boolean optional) [0x00000] 
  at Mono.Addins.AddinSessionService.ResolveLoadDependencies (System.Collections.ArrayList addins, System.Collections.Stack depCheck, System.String id, Boolean optional) [0x00000] 

Unhandled Exception: System.InvalidOperationException: Extension node not found in path: /Do/ItemSource
  at Mono.Addins.ExtensionContext.AddExtensionNodeHandler (System.String path, Mono.Addins.ExtensionNodeEventHandler handler) [0x00000] 
  at Mono.Addins.AddinManager.AddExtensionNodeHandler (System.String path, Mono.Addins.ExtensionNodeEventHandler handler) [0x00000] 
  at Do.Core.PluginManager.Initialize () [0x00000] 
  at Do.Do.Main (System.String[] args) [0x00000] 

Thanks for your help...
Comment 5 Guillaume Kulakowski 2008-10-29 10:18:03 EDT
Good since the last update. but there is a problem with the "Files and Folders Plugin", no activation possible.
Comment 6 Martin Ebourne 2008-11-10 17:31:13 EST
The problem with the files plugin is:

Assembly not found: gconf-sharp, Version=2.20.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f
WARNING: [Do.File,1.4] Could not load some add-in assemblies: The classes in the module cannot be loaded.

Also other plugins such as disk mounter fail similarly:

Assembly not found: gnome-vfs-sharp, Version=2.20.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f
WARNING: [Do.DiskMounter,1.0] Could not load some add-in assemblies: The classes in the module cannot be loaded.

They are all looking for the gnome-sharp 2.20 libraries, but Fedora 10 is gnome-sharp 2.24. Is this a build problem?
Comment 7 Bug Zapper 2008-11-25 22:33:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Sindre Pedersen Bjørdal 2008-12-02 08:47:30 EST
This happens because the plugins you are using are downloaded and installed from upstreams plugin repository. This plugin repository uses a build system which differs in it's gnome-desktop-sharp libraries from F10. Hence the binary plugins downloaded from upstream just won't work and there's really not much I can do about it. 

The upcoming release of gnome-do (0.8) scheduled for release in january (I think) will move away from the central online repository to locally hosted plugins, when this happens these issues will be solveable by downstream package managers. 

Suggestions for workarounds welcome.
Comment 9 Sindre Pedersen Bjørdal 2008-12-27 13:02:36 EST
*** Bug 477995 has been marked as a duplicate of this bug. ***
Comment 10 Sindre Pedersen Bjørdal 2009-01-16 12:27:09 EST
*** Bug 480336 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.