Bug 466644 - Right double quotation marks break text interface
Right double quotation marks break text interface
Status: CLOSED DUPLICATE of bug 492999
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 469542 470927 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-11 19:37 EDT by Ville-Pekka Vainio
Modified: 2013-01-09 23:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 17:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville-Pekka Vainio 2008-10-11 19:37:40 EDT
Description of problem:
The anaconda text interface breaks if the U+201D RIGHT DOUBLE QUOTATION MARK characters - ” ” - are used in a translation. The problem is probably best demonstrated with a couple of screenshots:
http://vpv.fedorapeople.org/misc/anaconda-quotes-problem1.png
http://vpv.fedorapeople.org/misc/anaconda-quotes-problem2.png

Version-Release number of selected component (if applicable):
The anaconda version in Fedora 10 Beta

How reproducible:
Always, though might be a bit difficult for non-Finnish speakers to reproduce

Steps to Reproduce:
1. Boot the Fedora 10 Beta DVD with lang=fi (as in Finnish)
2. In the first anaconda text interface screen, select OK
3. You should see something like http://vpv.fedorapeople.org/misc/anaconda-quotes-problem1.png
4. If you select "Tarkasta" in that screen, you should see something like http://vpv.fedorapeople.org/misc/anaconda-quotes-problem2.png


Actual results:
There's a box (that's probably <E2>) and <80><9D> where the character ” should be and the text "flows out" of the screen.

Expected results:
” (right double quotation mark) characters in the text interface should just work.

Additional info:
I've picked Severity: High, because this bug makes it quite difficult to use the text interface in Finnish.

I see two options for making the Finnish translations work in time for Fedora 10. Either the core cause of this bug (no Unicode support in the text interface?) gets fixed, or the Finnish translators have to convert all the right double quotation marks in the text interface into quotation marks (22).

I'd rather use the right double quotation marks in the Finnish translation, because that's what is generally recommended to be used when writing Finnish. In Anaconda's graphical interface they work fine.
Comment 1 Miroslav Lichvar 2008-10-15 09:47:59 EDT
This is caused by missing locale support, not newt's fault.

Slang doesn't print the ” character correctly because it's not in the UTF8 mode as nl_langinfo(CODESET) doesn't return "UTF-8". And the newt windows are broken because mbrtowc() and wcwidth() don't work.
Comment 2 Jesse Keating 2008-10-29 13:11:22 EDT
Per Chris Lumens, this isn't a blocker.
Comment 3 Chris Lumens 2008-11-04 10:50:51 EST
*** Bug 469542 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2008-11-04 10:52:41 EST
Our options for fixing this are:

(1) Bring wlite back into anaconda.

(2) Add all the glibc locale data into the second stage.

Both of these are horrible.
Comment 5 Chris Lumens 2008-11-10 17:03:04 EST
*** Bug 470927 has been marked as a duplicate of this bug. ***
Comment 6 Bug Zapper 2008-11-25 22:47:44 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Ville-Pekka Vainio 2009-01-28 02:10:29 EST
I'm still seeing this in Rawhide. Any chance of this being fixed before Fedora 11? Or should we start making changes to the po files to only use character which anaconda can deal with?
Comment 8 Chris Lumens 2009-01-28 08:18:24 EST
A lot of the text mode interface code is going to be going away before F11, so it's worth seeing if these strings will still even be present in text mode before making the drastic changes I outlined above.  However if you do want to be absolutely sure, I'd start modifying the po files.  It is very unlikely we will do either of my previous options.
Comment 9 Ville-Pekka Vainio 2009-01-31 17:29:12 EST
For other translators following this bug report, here's a way of finding out how many bytes a character needs in UTF-8 (thanks to another Finnish translator for the hint): $ echo -n a | wc --bytes

It seems anaconda's text interface can deal with 1-byte and 2-byte characters, but not with 3-byte characters. With Finnish the situation is quite simple, since characters such as 'ä', 'ö' and 'å' are all 2 bytes, the character causing the problems is the 3-byte '”', which can be in this situation changed to '"' - even though '”' is generally recommended to be used when writing Finnish.
Comment 10 Ville-Pekka Vainio 2009-05-13 17:23:45 EDT

*** This bug has been marked as a duplicate of bug 492999 ***

Note You need to log in before you can comment on or make changes to this bug.