Bug 467201 - [NetApp 5.4 bug] Dynamic SCSI rescan script needed
[NetApp 5.4 bug] Dynamic SCSI rescan script needed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sg3_utils (Show other bugs)
5.4
All Linux
high Severity high
: beta
: 5.4
Assigned To: Dan Horák
BaseOS QE
: OtherQA, Reopened
: 476571 (view as bug list)
Depends On: 467713
Blocks: 461680 RHEL5u4_relnotes 479692 483784
  Show dependency treegraph
 
Reported: 2008-10-16 06:49 EDT by Martin George
Modified: 2009-09-02 07:23 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In Red Hat Enterprise Linux 5.4, a new script, rescan-scsi-bus.sh, has been added to sg3_utils package, a set of low-level SCSI utilities. It uses the capabilities of the Linux kernel to add and remove SCSI devices without the need to reboot the machine or reload a kernel module. This script should be considered tech-preview Warning: When performing operations to dynamically configure and unconfigure LUNs, it is strongly recommended that IO be quiesced. It has been observed that online storage re-configuration may cause device name changes. This should be checked before resuming I/O, to avoid data loss. Consult your storage array vendor documentation for possible restrictions regarding these issues.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:23:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin George 2008-10-16 06:49:59 EDT
Feature request:
Dynamic SCSI rescan functionality can be currently implemented by manually echoing values into the SCSI sysfs files. This is an extremely useful feature in enterprise scenarios, as a reload of the underlying driver(which does a SCSI rescan) is not practical as it is disruptive.

It would be ideal if the RHEL kernel provides a bundled SCSI rescan script which performs the following dynamic SCSI rescan functionalities:

1) Detect luns added to the host.

2) Remove luns from the host.

3) Resize existing luns on the host.


Version-Release number of selected component (if applicable):
RHEL 5.3.
Comment 1 Dan Horák 2008-10-16 07:07:19 EDT
Are you looking for something like the rescan-scsi-bus.sh script from http://www.garloff.de/kurt/linux/scsidev/ ?
Comment 2 Martin George 2008-10-16 07:39:56 EDT
Exactly. 

This could be made a part of the sg3_utils package. Are there any plans to include this in future RHEL kernels?
Comment 3 Dan Horák 2008-10-16 08:39:04 EDT
Please submit a request for enhancement via the standard support channel and let them bind the request with this bug.

I can add the script into Fedora on my own, so it will then appear in RHEL 6.
Comment 4 Andrius Benokraitis 2008-10-16 12:53:48 EDT
Dan - NetApp is a formal engineering Partner and therefore this bugzilla will serve as the official feature request I'll monitor (being their assigned partner manager).
Comment 5 Andrius Benokraitis 2008-10-20 09:39:05 EDT
A cloned bug for RHEL 6.0 has been created at bug 267201.
Comment 6 Andrius Benokraitis 2008-10-20 09:39:59 EDT
Correction: a cloned bug for RHEL 6.0 has been created at bug 467713.
Comment 7 Andrius Benokraitis 2009-02-02 23:27:13 EST
*** Bug 476571 has been marked as a duplicate of this bug. ***
Comment 8 Andrius Benokraitis 2009-02-02 23:28:35 EST
Dan - any chance this could be a candidate for fast track?
Comment 9 Dan Horák 2009-02-03 04:37:48 EST
Yes in theory, but sg3_utils isn't an approved component for 5.4.
Comment 10 Andrius Benokraitis 2009-02-03 11:11:36 EST
Dan - exactly my reasoning. Since this isn't an approved component, would this be a monumental amount of work for fast track (since it looks like the work is already done upstream)?
Comment 11 Mike Christie 2009-02-03 13:42:53 EST
(In reply to comment #0)
> It would be ideal if the RHEL kernel provides a bundled SCSI rescan script
> which performs the following dynamic SCSI rescan functionalities:
> 
> 1) Detect luns added to the host.
> 
> 2) Remove luns from the host.
> 
> 3) Resize existing luns on the host.
> 

For FC did you also want it to fine new targets (normally you would have to write to the issue_lip sysfs file before doing a scsi scan)?
Comment 15 Martin George 2009-02-04 06:30:54 EST
(In reply to comment #11)
> For FC did you also want it to fine new targets (normally you would have to
> write to the issue_lip sysfs file before doing a scsi scan)?

Well, the rescan-scsi-bus.sh script available in the sg3_utils package already takes care of this:

#rescan-scsi-bus.sh -h
Usage: rescan-scsi-bus.sh [options] [host [host ...]]
Options:
 -l      activates scanning for LUNs 0-7    [default: 0]
 -L NUM  activates scanning for LUNs 0--NUM [default: 0]
 -w      scan for target device IDs 0 .. 15 [default: 0-7]
 -c      enables scanning of channels 0 1   [default: 0]
 -r      enables removing of devices        [default: disabled]
 -i      issue a FibreChannel LIP reset     [default: disabled]
--remove:        same as -r
--issue-lip:     same as -i
--forceremove:   Remove and readd every device (DANGEROUS)
--nooptscan:     don't stop looking for LUNs is 0 is not found
--color:         use coloured prefixes OLD/NEW/DEL
--hosts=LIST:    Scan only host(s) in LIST
--channels=LIST: Scan only channel(s) in LIST
--ids=LIST:      Scan only target ID(s) in LIST
--luns=LIST:     Scan only lun(s) in LIST
 Host numbers may thus be specified either directly on cmd line (deprecated) or
 or with the --hosts=LIST parameter (recommended).
LIST: A[-B][,C[-D]]... is a comma separated list of single values and ranges
 (No spaces allowed.)

It would be ideal if this script makes it to the RHEL OS.
Comment 16 Mike Christie 2009-02-04 11:31:40 EST
(In reply to comment #15)
> (In reply to comment #11)
> > For FC did you also want it to fine new targets (normally you would have to
> > write to the issue_lip sysfs file before doing a scsi scan)?
> 
> Well, the rescan-scsi-bus.sh script available in the sg3_utils package already
> takes care of this:
> 

Yeah, sorry for the confusion everyone.

rescan-scsi-bus.sh was in the archive dir of sg3_utils, and I could not find it and that threw me about what was being requested.

Sorry about that.
Comment 19 RHEL Product and Program Management 2009-02-05 11:32:27 EST
Quality Engineering Management has reviewed and declined this request.  You may
appeal this decision by reopening this request.
Comment 20 Andrius Benokraitis 2009-02-05 11:56:11 EST
Setting as an exception, since this has also been proposed in RHEL 4.8 and RHEL 6.0.
Comment 23 James Kirkland 2009-03-03 18:49:00 EST
I have several customers that have asked for this functionality.  It is functionality that is available and expected in peple migrating from other UNIX variants.  The ability to detect specifically hot SAN device additions and removals is key to most enterprise customers.  It will make it increaingly difficult to displace other UNIX solutions without this basic functionality.
Comment 26 Chris Ward 2009-06-14 19:15:53 EDT
~~ Attention Partners RHEL 5.4 Partner Alpha Released! ~~

RHEL 5.4 Partner Alpha has been released on partners.redhat.com. There should
be a fix present that addresses this particular request. Please test and report back your results here, at your earliest convenience. Our Public Beta release is just around the corner!

If you encounter any issues, please set the bug back to the ASSIGNED state and
describe the issues you encountered. If you have verified the request functions as expected, please set your Partner ID in the Partner field above to indicate successful test results. Do not flip the bug status to VERIFIED. Further questions can be directed to your Red Hat Partner Manager. Thanks!
Comment 27 Dan Horák 2009-06-26 04:49:59 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
In Red Hat Enterprise Linux 5.4, a new script, rescan-scsi-bud.sh, has been added to sg3_utils package, a set of low-level SCSI utilities. It uses the capabilities of the Linux kernel to add and remove SCSI devices without the need to reboot the machine or reload a kernel module.
Comment 28 Chris Ward 2009-07-03 14:10:50 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 29 Martin George 2009-07-03 14:24:20 EDT
There are still open bugs associated with this rescan script. Please check bug 507379 for details.
Comment 30 Chris Ward 2009-07-10 15:05:41 EDT
~~ Attention Partners - RHEL 5.4 Snapshot 1 Released! ~~

RHEL 5.4 Snapshot 1 has been released on partners.redhat.com. If you have already reported your test results, you can safely ignore this request. Otherwise, please notice that there should be a fix available now that addresses this particular request. Please test and report back your results here, at your earliest convenience. The RHEL 5.4 exception freeze is quickly approaching.

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Do not flip the bug status to VERIFIED. Instead, please set your Partner ID in the Verified field above if you have successfully verified the resolution of this issue. 

Further questions can be directed to your Red Hat Partner Manager or other appropriate customer representative.
Comment 33 Rob Evers 2009-08-18 10:14:46 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,5 @@
-In Red Hat Enterprise Linux 5.4, a new script, rescan-scsi-bud.sh, has been added to sg3_utils package, a set of low-level SCSI utilities. It uses the capabilities of the Linux kernel to add and remove SCSI devices without the need to reboot the machine or reload a kernel module.+In Red Hat Enterprise Linux 5.4, a new script, rescan-scsi-bus.sh, has been added to sg3_utils package, a set of low-level SCSI utilities. It uses the capabilities of the Linux kernel to add and remove SCSI devices without the need to reboot the machine or reload a kernel module.
+
+This script should be considered tech-preview
+
+It is strongly recommended that rescan-scsi-bus.sh be used on host bus adapters where IO is quiesced.  Not doing so can lead to data corruption.
Comment 34 Rob Evers 2009-08-18 11:15:12 EDT
comment 33:  I didn't realize that I was replacing the first content.  I meant to append the last lines to the previous content.
Comment 35 Rob Evers 2009-08-19 12:40:40 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -2,4 +2,8 @@
 
 This script should be considered tech-preview
 
-It is strongly recommended that rescan-scsi-bus.sh be used on host bus adapters where IO is quiesced.  Not doing so can lead to data corruption.+Warning:
+
+When performing operations to dynamically configure and unconfigure LUNs, it is strongly recommended that IO be quiesced.  It has been observed that online storage re-configuration may cause device name changes.  This should be checked before resuming I/O, to avoid data loss.
+
+Consult your storage array vendor documentation for possible restrictions regarding these issues.
Comment 36 errata-xmlrpc 2009-09-02 07:23:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1357.html

Note You need to log in before you can comment on or make changes to this bug.