Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 467713 - [NetApp 6.0 feat] Include a bundled dynamic SCSI rescan script
[NetApp 6.0 feat] Include a bundled dynamic SCSI rescan script
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sg3_utils (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: 6.0
Assigned To: Dan Horák
Michal Nowak
: FutureFeature, OtherQA
Depends On: 469628
Blocks: 217209 467201 476571 538787 554559
  Show dependency treegraph
 
Reported: 2008-10-20 09:38 EDT by Andrius Benokraitis
Modified: 2015-07-14 00:26 EDT (History)
10 users (show)

See Also:
Fixed In Version: sg3_utils-1.26-2.fc10
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 09:58:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrius Benokraitis 2008-10-20 09:38:22 EDT
+++ This bug was initially created as a clone of Bug #467201 +++

Feature request:
Dynamic SCSI rescan functionality can be currently implemented by manually echoing values into the SCSI sysfs files. This is an extremely useful feature in enterprise scenarios, as a reload of the underlying driver(which does a SCSI rescan) is not practical as it is disruptive.

It would be ideal if the RHEL kernel provides a bundled SCSI rescan script which performs the following dynamic SCSI rescan functionalities:

1) Detect luns added to the host.

2) Remove luns from the host.

3) Resize existing luns on the host.


Version-Release number of selected component (if applicable):
RHEL 5.3.

--- Additional comment from dhorak@redhat.com on 2008-10-16 07:07:19 EDT ---

Are you looking for something like the rescan-scsi-bus.sh script from http://www.garloff.de/kurt/linux/scsidev/ ?

--- Additional comment from marting@netapp.com on 2008-10-16 07:39:56 EDT ---

Exactly. 

This could be made a part of the sg3_utils package. Are there any plans to include this in future RHEL kernels?

--- Additional comment from dhorak@redhat.com on 2008-10-16 08:39:04 EDT ---

Please submit a request for enhancement via the standard support channel and let them bind the request with this bug.

I can add the script into Fedora on my own, so it will then appear in RHEL 6.

--- Additional comment from andriusb@redhat.com on 2008-10-16 12:53:48 EDT ---

Dan - NetApp is a formal engineering Partner and therefore this bugzilla will serve as the official feature request I'll monitor (being their assigned partner manager).
Comment 1 Andrius Benokraitis 2008-10-20 09:40:43 EDT
The RHEL 5.4 bug for this issue can be found at bug 467201.
Comment 2 Dan Horák 2008-11-03 03:08:10 EST
I have cloned this bug for Fedora Rawhide and made it block this bug. Dependency on the RHEL 5.4 original bug (auto created during cloning) is removed.
Comment 3 Dan Horák 2009-03-19 09:43:49 EDT
since sg3_utils-1.26-2.fc10 in Fedora
Comment 4 releng-rhel@redhat.com 2009-11-02 18:13:51 EST
Fixed in 'sg3_utils-1.26-2.fc10'. 'sg3_utils-1.27-2.el6' included in compose 'RHEL6.0-20091102.0'.
Moving to ON_QA.
Comment 6 Dan Horák 2010-08-17 06:08:19 EDT
Michal, NetApp feedback is tracked in bug #538787
Comment 8 Ronald Pacheco 2010-09-23 14:07:58 EDT
NetApp has verified bug 538787, so marking this one as verified, too.
Comment 9 releng-rhel@redhat.com 2010-11-11 09:58:43 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.