Bug 476571 - [NetApp 5.4 feat] Include a bundled dynamic SCSI rescan script
Summary: [NetApp 5.4 feat] Include a bundled dynamic SCSI rescan script
Status: CLOSED DUPLICATE of bug 467201
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sg3_utils
Version: 5.4
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 5.4
Assignee: Dan Horák
QA Contact: BaseOS QE
URL:
Whiteboard:
Keywords: FutureFeature, OtherQA
Depends On: 467713
Blocks: 461680 479692
TreeView+ depends on / blocked
 
Reported: 2008-12-15 19:29 UTC by Andrius Benokraitis
Modified: 2015-07-14 04:26 UTC (History)
5 users (show)

(edit)
Clone Of:
: 479692 (view as bug list)
(edit)
Last Closed: 2009-02-03 04:27:13 UTC


Attachments (Terms of Use)

Description Andrius Benokraitis 2008-12-15 19:29:47 UTC
+++ This bug was initially created as a clone of Bug #467713 +++

+++ This bug was initially created as a clone of Bug #467201 +++

Feature request:
Dynamic SCSI rescan functionality can be currently implemented by manually echoing values into the SCSI sysfs files. This is an extremely useful feature in enterprise scenarios, as a reload of the underlying driver(which does a SCSI rescan) is not practical as it is disruptive.

It would be ideal if the RHEL kernel provides a bundled SCSI rescan script which performs the following dynamic SCSI rescan functionalities:

1) Detect luns added to the host.

2) Remove luns from the host.

3) Resize existing luns on the host.


Version-Release number of selected component (if applicable):
RHEL 5.3.

--- Additional comment from dhorak@redhat.com on 2008-10-16 07:07:19 EDT ---

Are you looking for something like the rescan-scsi-bus.sh script from http://www.garloff.de/kurt/linux/scsidev/ ?

--- Additional comment from marting@netapp.com on 2008-10-16 07:39:56 EDT ---

Exactly. 

This could be made a part of the sg3_utils package. Are there any plans to include this in future RHEL kernels?

--- Additional comment from dhorak@redhat.com on 2008-10-16 08:39:04 EDT ---

Please submit a request for enhancement via the standard support channel and let them bind the request with this bug.

I can add the script into Fedora on my own, so it will then appear in RHEL 6.

--- Additional comment from andriusb@redhat.com on 2008-10-16 12:53:48 EDT ---

Dan - NetApp is a formal engineering Partner and therefore this bugzilla will serve as the official feature request I'll monitor (being their assigned partner manager).

--- Additional comment from andriusb@redhat.com on 2008-10-20 09:40:43 EDT ---

The RHEL 5.4 bug for this issue can be found at bug 467201.

--- Additional comment from dhorak@redhat.com on 2008-11-03 03:08:10 EDT ---

I have cloned this bug for Fedora Rawhide and made it block this bug. Dependency on the RHEL 5.4 original bug (auto created during cloning) is removed.

Comment 1 Andrius Benokraitis 2009-02-03 04:27:13 UTC

*** This bug has been marked as a duplicate of bug 467201 ***


Note You need to log in before you can comment on or make changes to this bug.