Bug 467231 - FC 10 Beta choosing Etc/UTC in timezone dialog crashes installer
FC 10 Beta choosing Etc/UTC in timezone dialog crashes installer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
: 467552 469832 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 10:22 EDT by andy
Modified: 2008-11-07 03:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 03:12:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback for Etc/UTC anaconda crash (143.13 KB, text/plain)
2008-10-16 16:23 EDT, andy
no flags Details
anaconda_debug.txt (135.81 KB, text/plain)
2008-10-23 06:46 EDT, Michael Cutler
no flags Details

  None (edit)
Description andy 2008-10-16 10:22:48 EDT
Description of problem:

Choosing Etc/UTC in timezone dialog crashes installer

Version-Release number of selected component (if applicable):

10 Beta

How reproducible:

Always

Steps to Reproduce:
1.  Begin install
2.  Choose Etc/UTC as timezone
3.  Installer crashes
  
Actual results:

Must restart installation.

Expected results:

Timezone would be set to UTC and installation would continue.

Additional info:
Comment 1 Chris Lumens 2008-10-16 10:48:35 EDT
Please attach the complete traceback to this bug report so we know how it's failing.
Comment 2 andy 2008-10-16 14:49:10 EDT
How am I supposed to get the traceback?
Comment 3 Chris Lumens 2008-10-16 15:09:06 EDT
Thorough documentation for reporting anaconda bugs can be found at:  http://fedoraproject.org/wiki/Anaconda/BugReporting
Comment 4 andy 2008-10-16 16:23:27 EDT
Created attachment 320605 [details]
Traceback for Etc/UTC anaconda crash

Traceback as requested.  It looks like it can't find Etc on the world map, but that's just my guess from looking at the trace for a few seconds.
Comment 5 Chris Lumens 2008-10-16 16:56:33 EDT
We're definitely not seeing this here with rawhide.  I suppose there could have been a problem in s-c-date for the beta.  Reassigning so they can take a look.
Comment 6 Andy Lindeberg 2008-10-20 10:38:56 EDT
*** Bug 467552 has been marked as a duplicate of this bug. ***
Comment 7 andy 2008-10-22 09:01:28 EDT
This is also a problem in Fedora 9 as I have just learned, so this isn't new.
Comment 8 Michael Cutler 2008-10-23 06:45:20 EDT
I've attached my backtrace from Bug 467552, 

anaconda 11.4.1.40 exception report
Traceback (most recent call first):
  File "/usr/share/system-config-date/timezone_map_gui.py", line 637, in map2canvas
    x = x2 / 2.0 + (x2 / 2.0) * long / 180.0
  File "/usr/share/system-config-date/timezone_map_gui.py", line 466, in _city_label_update
    x, y = self.map2canvas (entry.lat, entry.long)
  File "/usr/share/system-config-date/timezone_map_gui.py", line 479, in city_labels_update
    self._city_label_update ("current")
  File "/usr/share/system-config-date/timezone_map_gui.py", line 498, in mapMoveEvent
    self.city_labels_update ()
  File "/usr/share/system-config-date/timezone_map_gui.py", line 550, in mapEvent
    self.mapMoveEvent (event)
TypeError: unsupported operand type(s) for *: 'float' and 'NoneType'

Local variables in innermost frame:
x2: 1440
lat: None
self: <AnacondaTZMap object at 0x488c3378 (GtkVBox at 0x106ed0a0)>
y2: 720
long: None
Comment 9 Michael Cutler 2008-10-23 06:46:30 EDT
Created attachment 321265 [details]
anaconda_debug.txt
Comment 10 Nils Philippsen 2008-11-05 05:09:38 EST
*** Bug 469832 has been marked as a duplicate of this bug. ***
Comment 11 Nils Philippsen 2008-11-05 05:27:14 EST
This should be fixed in 1.9.34. I'll ask Release Engineering to include this version in F10 final.
Comment 12 Nils Philippsen 2008-11-05 06:59:24 EST
https://fedorahosted.org/rel-eng/ticket/978

Note You need to log in before you can comment on or make changes to this bug.