Bug 46856 - vim.sh - totally screwed up
vim.sh - totally screwed up
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
: 47056 47962 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-01 10:34 EDT by Alexander L. Belikoff
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-01 10:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander L. Belikoff 2001-07-01 10:34:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.5-10smp i686; en-US; rv:0.9.1)
Gecko/20010609

Description of problem:
vim.sh is written the way it doesn't pass to vim any command-line parameters

How reproducible:
Always

Steps to Reproduce:
1.dmesg > foobar
2.vi foobar
3.
	

Actual Results:  vim starts with splash page and no file loaded

Expected Results:  vim should start with file loaded

Additional info:

To fix: ate least change the line:

    vi() { /usr/bin/vim ; }

to

vi() { /usr/bin/vim "$@" ; }
Comment 1 Bernhard Rosenkraenzer 2001-07-02 10:36:07 EDT
Argh, missing \ before a $. Fixed in 5.8-4
Comment 2 Bernhard Rosenkraenzer 2001-07-03 11:45:23 EDT
*** Bug 47056 has been marked as a duplicate of this bug. ***
Comment 3 Bernhard Rosenkraenzer 2001-07-09 05:49:31 EDT
*** Bug 47962 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.